Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
* gnu/packages/mp3.scm (taglib): Add "" around the substitution of
ZLIB_LIBRARIES_FLAGS.
---
gnu/packages/mp3.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (18 lines)
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index a7574f0cf9..2e9b023407 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -182,9 +182,9 @@ a highly stable and efficient implementation.")
;; flag for zlib.
(substitute* "CMakeLists.txt"
(("set\\(ZLIB_LIBRARIES_FLAGS -lz\\)")
- (string-append "set(ZLIB_LIBRARIES_FLAGS -L"
+ (string-append "set(ZLIB_LIBRARIES_FLAGS \"-L"
(assoc-ref inputs "zlib")
- " -lz)")))
+ " -lz\")")))
#t)))))
(inputs `(("zlib" ,zlib)))
(home-page "https://taglib.org")
--
2.28.0