[PATCH] gnu: pre-commit: Update to 2.7.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 7 Sep 2020 19:11
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200907171107.2020-1-monego@posteo.net
* gnu/packages/version-control.scm (pre-commit): Update to 2.7.1.
[native-inputs]: Change git to git-minimal.
---
gnu/packages/version-control.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index bc8e5f21ab..86e30b0ba5 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1444,7 +1444,7 @@ control to Git repositories.")
(define-public pre-commit
(package
(name "pre-commit")
- (version "2.6.0")
+ (version "2.7.1")
(source
(origin
;; No tests in the PyPI tarball.
@@ -1454,7 +1454,7 @@ control to Git repositories.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "144hcnz8vz07nkx7hk8a3ac822186ardwxa8jnl6s8qvm5ip92f2"))))
+ (base32 "0n7qby5a4yz3s02nqcp5js6jg9wrd0x7msblxwb1883ds4b2b71a"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1490,7 +1490,7 @@ control to Git repositories.")
" and not test_run_a_ruby_hook"
" and not test_run_ruby_hook_with_disable_shared_gems"
" and not test_run_versioned_ruby_hook"
- ;; Disable Cargo tests
+ ;; Disable Cargo tests.
" and not test_additional_rust_cli_dependencies_installed"
" and not test_additional_rust_lib_dependencies_installed"
" and not test_local_rust_additional_dependencies"
@@ -1517,14 +1517,14 @@ control to Git repositories.")
" and not test_too_new_version"
" and not test_try_repo_uncommitted_changes"
" and not test_versions_ok"
- ;; This test tries to activate a virtualenv
+ ;; This test tries to activate a virtualenv.
" and not test_healthy_venv_creator"
;; Fatal error: Not a Git repository.
" and not test_all_cmds"
" and not test_try_repo"
- ;; No module named 'pip._internal.cli.main'
+ ;; No module named 'pip._internal.cli.main'.
" and not test_additional_dependencies_roll_forward"
- ; Assertion errors
+ ;; Assertion errors.
" and not test_install_existing_hooks_no_overwrite"
" and not test_uninstall_restores_legacy_hooks"))))
(add-before 'reset-gzip-timestamps 'make-files-writable
@@ -1536,7 +1536,7 @@ control to Git repositories.")
(find-files out "\\.gz$"))
#t))))))
(native-inputs
- `(("git" ,git)
+ `(("git" ,git-minimal)
("python-pytest" ,python-pytest)))
(inputs
`(("python-cfgv" ,python-cfgv)
--
2.20.1
E
E
Efraim Flashner wrote on 8 Sep 2020 10:02
(name . Vinicius Monego)(address . monego@posteo.net)(address . 43258-done@debbugs.gnu.org)
20200908080237.GG1643@E5400
Looks good. Patch pushed!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl9XOp0ACgkQQarn3Mo9
g1EkYhAAg/IHr8139IBrooZTwDCSAGQlUoeuyctcEghg+c2Ed2/OL8MT3jy2R8lr
/TA1RhFToPKhxCpBHMd/2T7DwPEcE9MmG/z4HLMXFvBiXDteAqC66BxEGeeEJ9ol
8Vck7xrn0nWstH1CeokKcz0eVqjq1FNsZ30CMz2bhbdz3leWVRqrhFhqOs7toNek
3dMGUwck4ElVWJqsAwaH/mchNV9rpDOYiHESBrt5a2nRZnYC4JySBCMHkvkiZsX4
UPevPNS4KQnGRYfpu/duY7ItAyQWZyLYDoxkxbjp0dErC9tcbbdcKoiEpq9Xpf9m
CnNQSjZhlRXM+HYtweUBJ31T5uTPjYgEKZAG6z3W+SsygT747Z93WmIEoB2yqm8K
yU83g1UP3HRCNKVejKlq12ay4nwSDCmfesjuXJxhaozSAWaNqXp2qLJWo6lsFIEY
Tg6ljk99GEIOV+xKmX1/d+ScRaHEuOY3+6bqzCbNjEvosdEsgHXWXvd88sas/nE+
hH/PlmZVSTDYahAap4MtoWADuxDo/WhKcP69RXaCFFNxySR79tPWETHhZChEcfWx
HFRGZVBNREP7WFJ67Mt1RKwJwlJxTtjoYioK8qQ90jGHm/kwnKpovTiUrOcfDe8a
9V5RzZP2qYEkK9qjL1n+gDew6ExsX2zXbycpp412/O60/9bQFaU=
=LtYd
-----END PGP SIGNATURE-----


Closed
?