`guix system build -n` to be more informative (builds/substitutes)

  • Open
  • quality assurance status badge
Details
3 participants
  • Vitaliy Shatrov
  • Mark H Weaver
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Vitaliy Shatrov
Severity
normal

Debbugs page

Vitaliy Shatrov wrote 5 years ago
(name . Magst Tom tomaten?)(address . bug-guix@gnu.org)
87sgbv5ha8.fsf@disroot.org
Hello Guix.

I did:
`guix system build -n config.scm`

I get a message, something like:
"3 packages (guix, modules, and ?) would be downloaded."

I ran `sudo guix system build config.scm`. Guix told me it will build
the linux kernel. It was unexpected.

The `guix system build/reconfigure` upgrades the daemon first. Right?

So, if `guix` cannot know beforehand will the User get any substitutes..
Maybe:
* `guix` should stop and ask in case there is a build ahead?
* add a separate 'update-daemon-only' command (or flag) to `system`?


Background:
With `update-daemon-only`, one can just walk away. Then look-up, if any
builds are ahead. Of course i understood that the system-wide config
should be keept minimal. So not that big trouble: just i had an
substitute offered to me (for kernel), but (as `system build -n` didn't
warned me) decided to not use it (as i thought the kernel will not be
updated). When i found out that kernel actually going to be build, i
canceled it. Then switched to kernel that has substitute (same config,
different hash).


---
Thank You for the attention, Vitaliy.
Ricardo Wurmus wrote 5 years ago
(name . Vitaliy Shatrov)(address . guix.vits@disroot.org)(address . 43238@debbugs.gnu.org)
875z8rdw36.fsf@elephly.net
Vitaliy Shatrov <guix.vits@disroot.org> writes:

Toggle quote (11 lines)
> Hello Guix.
>
> I did:
> `guix system build -n config.scm`
>
> I get a message, something like:
> "3 packages (guix, modules, and ?) would be downloaded."
>
> I ran `sudo guix system build config.scm`. Guix told me it will build
> the linux kernel. It was unexpected.

Are these the same “guix” programs? “sudo guix” probably gives you the
root user’s “guix”, whereas just “guix” will give you the current user’s
“guix”.

That’s why we recommend “sudo -E guix” or similar.

--
Ricardo
Vitaliy Shatrov wrote 5 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 43238@debbugs.gnu.org)
87o8mj58kf.fsf@disroot.org
Hello Ricardo.

I made a typo: I do not need a root for `build`.

How it really was:

`guix system build -n config.scm`
---> 3 packages download

sudo guix system _RECONFIGURE_ config.scm
---> Hey-ho: building Linux!

C-c

edit config.scm, use kernel that has substitute.

guix build -n config.scm --substitute-url=URL
---> Will download Linux.

sudo guix sytem reconfugure config.scm
---> download, apply. ahm cool.


---
Am sorry, Vitaliy.
Mark H Weaver wrote 5 years ago
(name . Vitaliy Shatrov)(address . guix.vits@disroot.org)(address . 43238@debbugs.gnu.org)
875z8qr81z.fsf@netris.org
Hi Vitaliy,

I reported this issue in April as bug #40612, so this is a duplicate.


That bug is still open, but it seems blocked on differences of opinion.

Mark
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 43238@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43238
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help