[PATCH] gnu: lxqt-panel: Patching the kbindicator to xkeyboard-config path for reading the keyboard layouts.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Hamzeh Nasajpour
Owner
unassigned
Submitted by
Hamzeh Nasajpour
Severity
normal

Debbugs page

Hamzeh Nasajpour wrote 5 years ago
[PATCH] gnu: lxqt-panel: Patching the kbindicator to xkeyboard -config path for reading the keyboard layouts.
(address . guix-patches@gnu.org)
8248a4f3-9706-450d-ac60-370547b53262@www.fastmail.com
Toggle diff (31 lines)
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 21587609ce..8d54bb0bd7 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -591,7 +591,8 @@ of other programs.")
("qtsvg" ,qtsvg)
("qtx11extras" ,qtx11extras)
("solid" ,solid)
- ("xcb-util" ,xcb-util)))
+ ("xcb-util" ,xcb-util)
+ ("xkeyboard-config" ,xkeyboard-config)))
(native-inputs
`(("pkg-config" ,pkg-config)
("lxqt-build-tools" ,lxqt-build-tools)
@@ -619,7 +620,15 @@ of other programs.")
(("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
(string-append (assoc-ref outputs "out")
"/share/lxqt/translations")))
- #t)))))
+ #t))
+ (add-after 'unpack 'set-xkeyboard-config-file-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Set the path to xkeyboard-config.
+ (let ((xkb (assoc-ref inputs "xkeyboard-config")))
+ (substitute* "plugin-kbindicator/src/x11/kbdlayout.cpp"
+ (("/usr/share/X11/xkb/rules/evdev.xml")
+ (string-append xkb "/share/X11/xkb/rules/evdev.xml")))
+ #t))))))
(home-page "https://lxqt.github.io")
(synopsis "The LXQt desktop panel")
(description "lxqt-panel represents the taskbar of LXQt.")
Efraim Flashner wrote 5 years ago
Re: [bug#43230] [PATCH] gnu: lxqt-panel: Patching the kbindicator to xkeyboard-config path for reading the keyboard layouts.
(name . Hamzeh Nasajpour)(address . h.nasajpour@pantherx.org)(address . 43230-done@debbugs.gnu.org)
20200906063403.GC1643@E5400
I rewrote the commit message and pushed it.

Thanks!


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl9UgtoACgkQQarn3Mo9
g1HshA/8CJURrTdvd2ZaxTVI8hKb35k/SEl4Mva3N3Q4ji84ABFG6yV8PiypfemS
5wSgAoOxZrYP2CnrobuTw/VHIcAMvcZFRyNjyPW5ldSIsDpEppLRegYzcvyGqp/t
LXxlHzEm8BCEZl5v9pWqaRbg3GlATJzz0ysmmfFsaomUrQ2yY5LS+kGGS7r2Zilb
arnd0GZqSKQXAps3Rll2KUacvmPcJ0jNP0S1+9XWXy8J8bOfZ1HCecDRx6VKfUlY
uIU7Qq9dyomUW5h8y6A6SpyF713OgZ/j8loneCP88lqtT10qhkytU/DkFFuT+AyU
dgXOyvz+O0t6cOl6WXTjO0/9aP0YhEhUy1xjgb+9LojoGzEn0Y7UBfrMFmI4rEEH
TT9Y+eJwpHEYJB660M9rFFM1JZbfrvcLMmWkz8Ho7y3qTqeIXFRy2/nJZeJ+Xgld
CGZr3jRs4lCoDKxh3st7Dt+z8nvXHDfVr+1RBqnDBo5nHWL9rojM9VZNA/snXvVg
SyAYRRnsCI56VX7pK5LptAKBiGsnJwMuwktUQ+MU618wywchI1gtd6e252H3QFG1
xXLdSLUjtAm0XJx/Yf47c1CSwZ63bguTmp9R/8ylD9ZxRLiKqRbXgNSYt5lhCbOm
QSsQA+iwy5mrc1Yo9kGOe7sJn4T4qDM0h/OcG6PUrhv+enH+P3A=
=E3yT
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43230@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43230
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help