[PATCH] gnu: emacs-lice-el: Update to 0.2-2.482e58a.

  • Done
  • quality assurance status badge
Details
3 participants
  • Oleg Pykhalov
  • Nicolas Goaziou
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20200905081205.17967-1-mike@rohleder.de
* gnu/packages/emacs-xyz.scm (emacs-lice-el): Update to 0.2-2.482e58a.
[arguments]: Add phase 'install-templates.
---
gnu/packages/emacs-xyz.scm | 16 +++++++++++++---
1 file changed, 13 insertions(+), 3 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d9716ba91c..a5a5e72411 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15890,10 +15890,10 @@ Magit.")
(license license:gpl3+)))
(define-public emacs-lice-el
- (let ((commit "4339929927c62bd636f89bb39ea999d18d269250"))
+ (let ((commit "482e58ab83fff86ed754b00be27b62a219597e7c"))
(package
(name "emacs-lice-el")
- (version (git-version "0.2" "1" commit))
+ (version (git-version "0.2" "2" commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -15902,8 +15902,18 @@ Magit.")
(file-name (git-file-name name version))
(sha256
(base32
- "0879z761b7gajkhq176ps745xpdrivch349crransv8fnsc759yb"))))
+ "0yxkjyhfk8kpr8yqz54gdx6xwkj4s8bnbz60162jh12crj0bs5n7"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-templates
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively
+ "template"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs/site-lisp/template"))
+ #t)))))
(home-page "https://github.com/buzztaiki/lice-el")
(synopsis "License and header template for Emacs")
(description "@code{lice.el} provides following features:
--
2.28.0
Oleg Pykhalov wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 43211@debbugs.gnu.org)
87lfhnz4hl.fsf@gmail.com
Hi,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (14 lines)
> * gnu/packages/emacs-xyz.scm (emacs-lice-el): Update to 0.2-2.482e58a.
> [arguments]: Add phase 'install-templates.
> ---
> gnu/packages/emacs-xyz.scm | 16 +++++++++++++---
> 1 file changed, 13 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index d9716ba91c..a5a5e72411 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -15890,10 +15890,10 @@ Magit.")
> (license license:gpl3+)))
>
> (define-public emacs-lice-el
[…]
Toggle quote (14 lines)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-after 'install 'install-templates
> + (lambda* (#:key outputs #:allow-other-keys)
> + (copy-recursively
> + "template"
> + (string-append (assoc-ref outputs "out")
> + "/share/emacs/site-lisp/template"))
> + #t)))))
> (home-page "https://github.com/buzztaiki/lice-el")
> (synopsis "License and header template for Emacs")
> (description "@code{lice.el} provides following features:

The ‘site-lisp’ is not an appropriate place for this data. It's better
to install those files in [1] directory, and substitute ‘lice.el’
accordingly so it could find them.

[1] /gnu/store/...emacs-lice-el.../share/emacs-lice-el/template

Could you update the patch with this change, please?


Thanks,
Oleg.
Michael Rohleder wrote 5 years ago
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)(address . 43211@debbugs.gnu.org)
87k0x7uti0.fsf@rohleder.de
Hi Oleg,

Oleg Pykhalov <go.wigust@gmail.com> writes:
Toggle quote (8 lines)
> The ‘site-lisp’ is not an appropriate place for this data. It's better
> to install those files in [1] directory, and substitute ‘lice.el’
> accordingly so it could find them.
>
> [1] /gnu/store/...emacs-lice-el.../share/emacs-lice-el/template
>
> Could you update the patch with this change, please?

Ah, yes!
From f2099ef8870380fd3c3fd37a4b55fe3b8a556216 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sun, 6 Sep 2020 11:30:57 +0200
Subject: [PATCH] gnu: emacs-lice-el: Update to 0.2-2.482e58a.

* gnu/packages/emacs-xyz.scm (emacs-lice-el): Update to 0.2-2.482e58a.
[arguments]: Add phase 'patch-template-directory and 'install-templates.
---
gnu/packages/emacs-xyz.scm | 24 +++++++++++++++++++++---
1 file changed, 21 insertions(+), 3 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1d890407cc..76488c0de0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15891,10 +15891,10 @@ Magit.")
(license license:gpl3+)))
(define-public emacs-lice-el
- (let ((commit "4339929927c62bd636f89bb39ea999d18d269250"))
+ (let ((commit "482e58ab83fff86ed754b00be27b62a219597e7c"))
(package
(name "emacs-lice-el")
- (version (git-version "0.2" "1" commit))
+ (version (git-version "0.2" "2" commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -15903,8 +15903,26 @@ Magit.")
(file-name (git-file-name name version))
(sha256
(base32
- "0879z761b7gajkhq176ps745xpdrivch349crransv8fnsc759yb"))))
+ "0yxkjyhfk8kpr8yqz54gdx6xwkj4s8bnbz60162jh12crj0bs5n7"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-template-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (chmod "lice.el" #o666)
+ (emacs-substitute-variables "lice.el"
+ ("lice:system-template-directory"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs-lice-el/template")))
+ #t))
+ (add-after 'install 'install-templates
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively
+ "template"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs-lice-el/template"))
+ #t)))))
(home-page "https://github.com/buzztaiki/lice-el")
(synopsis "License and header template for Emacs")
(description "@code{lice.el} provides following features:
--
2.28.0
Thanks!

--
Good decisions come from experience, and experience come from bad decisions.
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl9UsCcRHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyUsIgf/cQzki9s8c4hyPNyyaoTFEc008pt2JYls
yEeHLrAcZh7xIuP3/2g9UTawB4x0l5+9XJnONexPGFw19/60j9UKPuqTiyXsITa+
Q1mN9FhBZ3Fj4vW9LcrAFUE6Bga5ju2tUUQkxylL6OrigNEKiohY52/07Qxh8oBg
EMPps3ldj2v//EuB1xI/SHA46rpWgGE3WEhdmRJcw2cCJmgHyJmhcKZcYit9RrGm
9kIaMNP2BaaGiZWjco/Zk8nk4CGVmxo4Ujf0/+SAWjrOV2AQddVcA/IcJj1KqBZD
jRP39jIqKQyhfc+4GV6sacXbLKA5mlORGq2fkqZlC2a8sAuKelUM6w==
=WnhO
-----END PGP SIGNATURE-----

Michael Rohleder wrote 4 years ago
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)(address . 43211@debbugs.gnu.org)
87een0jo1q.fsf@rohleder.de
Here is a rebased (to current master) patch.
Toggle quote (1 lines)
> From bc2163d6da160b58591f77f352cf4ea8543454e2 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sun, 6 Sep 2020 11:30:57 +0200
Subject: [PATCH] gnu: emacs-lice-el: Update to 0.2-2.482e58a.

* gnu/packages/emacs-xyz.scm (emacs-lice-el): Update to 0.2-2.482e58a.
[arguments]: Add phase 'patch-template-directory and 'install-templates.
---
gnu/packages/emacs-xyz.scm | 24 +++++++++++++++++++++---
1 file changed, 21 insertions(+), 3 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ae95b15c12..f0b3bb8970 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15987,10 +15987,10 @@ Magit.")
(license license:gpl3+)))
(define-public emacs-lice-el
- (let ((commit "4339929927c62bd636f89bb39ea999d18d269250"))
+ (let ((commit "482e58ab83fff86ed754b00be27b62a219597e7c"))
(package
(name "emacs-lice-el")
- (version (git-version "0.2" "1" commit))
+ (version (git-version "0.2" "2" commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -15999,8 +15999,26 @@ Magit.")
(file-name (git-file-name name version))
(sha256
(base32
- "0879z761b7gajkhq176ps745xpdrivch349crransv8fnsc759yb"))))
+ "0yxkjyhfk8kpr8yqz54gdx6xwkj4s8bnbz60162jh12crj0bs5n7"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-template-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (chmod "lice.el" #o666)
+ (emacs-substitute-variables "lice.el"
+ ("lice:system-template-directory"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs-lice-el/template")))
+ #t))
+ (add-after 'install 'install-templates
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively
+ "template"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs-lice-el/template"))
+ #t)))))
(home-page "https://github.com/buzztaiki/lice-el")
(synopsis "License and header template for Emacs")
(description "@code{lice.el} provides following features:
--
2.28.0
--
The proper basis for marriage is a mutual misunderstanding.
Oscar Wilde
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl9joIIRHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyWWewf/QN9es6uDVefWVbMff8fvbZWnsC+Xxodx
8yHgbx4e7l2ARKT/2iZOqpNFp4qLtKCcNUuXOQrJkZrIEAIlzMebKb5W+MwGRsUm
LeQIRrSEPfN8CXH8GYhJGVSNuy7rXnf9QOoCb4LktHVtGyv+WKppGQQsanLJcZ9i
8Kz5vMFNcGUKRy79nGQ95iw7V83gyJ5DHJ0rJmJPjT6We1TaRHqz71LI2ROYeG3x
0VFO3blLE8JCLnXO4of333DZ/Q0jPemSqQ4vBDa04K7z03AKTPQL2ozPhd4qRPq3
N9K6WvllOOMAvj5y1aa0oJA8I4142xJMDuJUoeJZDNcz1zZuoAF6kQ==
=2Z/K
-----END PGP SIGNATURE-----

Nicolas Goaziou wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)
87tuvq9oli.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (2 lines)
> Subject: [PATCH] gnu: emacs-lice-el: Update to 0.2-2.482e58a.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43211@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43211
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help