Kdenlive Fixes

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Prafulla Giri
Owner
unassigned
Submitted by
Prafulla Giri
Severity
normal
P
P
Prafulla Giri wrote on 4 Sep 2020 10:27
(address . guix-patches@gnu.org)
CAFw+=j2M6U7rALX-ekBTEU7pMuSAwYZ6uur1cbCzyfQLhyKHQw@mail.gmail.com
Esteemed maintainers,

Currently, Kdenlive throws errors regarding 2 things as soon as it starts:
1. ffmpeg, ffprobe and ffplay not being found
2. breeze icon theme not being found

Attached is a patch that addresses the first of these issues.

ffmpeg is added to the input of the package, and the final binary is
wrapped to include the ffmpeg binaries in it's PATH.

As for issue #2, I have sent in (rough) patches that adds the full
breeze-icon theme to guix distribution which should be merged to the tree
before another patch can be sent.

Thank you.
Attachment: file
From 65b56b634745a93bf6eb58c6c3cca023c9f5ab14 Mon Sep 17 00:00:00 2001
From: Prafulla Giri <pratheblackdiamond@gmail.com>
Date: Thu, 3 Sep 2020 19:35:14 +0545
Subject: [PATCH] gnu: kdenlive: Add ffmpeg to input list

* gnu/packages/kde.scm (kdenlive): Add ffmpeg to inputs and wrap
the final binary accordingly to have ffmpeg in it's PATH.
[inputs]: Add ffmpeg.
---
gnu/packages/kde.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 9bc753001e..a9ac23e049 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -155,6 +155,7 @@ This package contains GUI widgets for baloo.")
(inputs
`(("shared-mime-info" ,shared-mime-info)
("frei0r-plugins" ,frei0r-plugins)
+ ("ffmpeg" ,ffmpeg)
("rttr" ,rttr)
("mlt" ,mlt)
("qtbase" ,qtbase)
@@ -190,8 +191,11 @@ This package contains GUI widgets for baloo.")
(qtbase (assoc-ref inputs "qtbase"))
(qtdeclarative (assoc-ref inputs "qtdeclarative"))
(frei0r (assoc-ref inputs "frei0r-plugins"))
+ (ffmpeg (assoc-ref inputs "ffmpeg"))
(qml "/lib/qt5/qml"))
(wrap-program (string-append out "/bin/kdenlive")
+ `("PATH" ":" prefix
+ ,(list (string-append ffmpeg "/bin")))
`("QT_PLUGIN_PATH" ":" prefix
,(map (lambda (label)
(string-append (assoc-ref inputs label)
--
2.28.0
L
L
Ludovic Courtès wrote on 4 Sep 2020 11:24
(name . Prafulla Giri)(address . pratheblackdiamond@gmail.com)(address . 43200-done@debbugs.gnu.org)
87d031vqr9.fsf@gnu.org
Hi,

Prafulla Giri <pratheblackdiamond@gmail.com> skribis:

Toggle quote (9 lines)
> From 65b56b634745a93bf6eb58c6c3cca023c9f5ab14 Mon Sep 17 00:00:00 2001
> From: Prafulla Giri <pratheblackdiamond@gmail.com>
> Date: Thu, 3 Sep 2020 19:35:14 +0545
> Subject: [PATCH] gnu: kdenlive: Add ffmpeg to input list
>
> * gnu/packages/kde.scm (kdenlive): Add ffmpeg to inputs and wrap
> the final binary accordingly to have ffmpeg in it's PATH.
> [inputs]: Add ffmpeg.

Applied, thanks!

Ludo’.
Closed
?