[PATCH] gnu: liblinphone: Add installation of man pages.

  • Done
  • quality assurance status badge
Details
2 participants
  • Michael Rohleder
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20200903184407.10377-1-mike@rohleder.de
* gnu/packages/linphone.scm (liblinphone)[arguments]: Add phase
'install-man-pages.
---
gnu/packages/linphone.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 14da150ced..a6492893c8 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -458,6 +458,14 @@ including media capture, encoding and decoding, and rendering.")
(delete-file-recursively
(string-append out "/share/doc/linphone-" ,version))
#t)))
+ (add-after 'install 'install-man-pages
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man (string-append out "/share/man/man1")))
+ (for-each (lambda (file)
+ (install-file file man))
+ (find-files ".." ".*.1$"))
+ #t)))
(add-after 'separate-outputs 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
(add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
--
2.28.0
Mathieu Othacehe wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 43187-done@debbugs.gnu.org)
87mu26qcl9.fsf@gnu.org
Toggle quote (3 lines)
> * gnu/packages/linphone.scm (liblinphone)[arguments]: Add phase
> 'install-man-pages.

Pushed, thanks!

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43187@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43187
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help