Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
* gnu/packages/pulseaudio.scm (noisetorch): Update to 0.7.2-beta.
[arguments]: Add phase 'disable-update-check.go.
---
gnu/packages/pulseaudio.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)
Toggle diff (37 lines)
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 3757859d11..9522d023ad 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -538,7 +538,7 @@ The plugin is made to work with 1 or 2 channels (ladspa plugin),
(define-public noisetorch
(package
(name "noisetorch")
- (version "0.6.1-beta")
+ (version "0.7.2-beta")
(source
(origin
(method git-fetch)
@@ -547,7 +547,7 @@ The plugin is made to work with 1 or 2 channels (ladspa plugin),
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1jmh7204mhlabdn0azfjrm3kb944j24n0w0cwibqrs9lfgdn8k52"))))
+ (base32 "06xlqjma8h7lcnqgc9226blps6m9dp487hk71lslfxj0jkay548k"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/lawl/NoiseTorch"
@@ -572,6 +572,12 @@ The plugin is made to work with 1 or 2 channels (ladspa plugin),
(lambda ()
(format #t "package main~%~%var version=~s~&" ,version))))
#t))
+ (add-after 'unpack 'disable-update-check.go
+ (lambda _
+ (with-directory-excursion "src/github.com/lawl/NoiseTorch"
+ (substitute* "main.go"
+ ((".*updateCheck.*") "")))
+ #t))
(add-before 'build 'go-generate
(lambda _
(with-directory-excursion "src/github.com/lawl/NoiseTorch"
--
2.28.0