[PATCH] gnu: noisetorch: Update to 0.7.2-beta.

  • Done
  • quality assurance status badge
Details
2 participants
  • Michael Rohleder
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20200902173318.8297-1-mike@rohleder.de
* gnu/packages/pulseaudio.scm (noisetorch): Update to 0.7.2-beta.
[arguments]: Add phase 'disable-update-check.go.
---
gnu/packages/pulseaudio.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 3757859d11..9522d023ad 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -538,7 +538,7 @@ The plugin is made to work with 1 or 2 channels (ladspa plugin),
(define-public noisetorch
(package
(name "noisetorch")
- (version "0.6.1-beta")
+ (version "0.7.2-beta")
(source
(origin
(method git-fetch)
@@ -547,7 +547,7 @@ The plugin is made to work with 1 or 2 channels (ladspa plugin),
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1jmh7204mhlabdn0azfjrm3kb944j24n0w0cwibqrs9lfgdn8k52"))))
+ (base32 "06xlqjma8h7lcnqgc9226blps6m9dp487hk71lslfxj0jkay548k"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/lawl/NoiseTorch"
@@ -572,6 +572,12 @@ The plugin is made to work with 1 or 2 channels (ladspa plugin),
(lambda ()
(format #t "package main~%~%var version=~s~&" ,version))))
#t))
+ (add-after 'unpack 'disable-update-check.go
+ (lambda _
+ (with-directory-excursion "src/github.com/lawl/NoiseTorch"
+ (substitute* "main.go"
+ ((".*updateCheck.*") "")))
+ #t))
(add-before 'build 'go-generate
(lambda _
(with-directory-excursion "src/github.com/lawl/NoiseTorch"
--
2.28.0
Mathieu Othacehe wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 43172-done@debbugs.gnu.org)
87sgbze7ff.fsf@gnu.org
Toggle quote (3 lines)
> * gnu/packages/pulseaudio.scm (noisetorch): Update to 0.7.2-beta.
> [arguments]: Add phase 'disable-update-check.go.

Pushed, thanks!

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43172@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43172
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help