[PATCH] gnu: deluge: Update to 2.0.3.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 5 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20200901212217.29981-1-kkebreau@posteo.net
* gnu/packages/bittorrent.scm (deluge): Update to 2.0.3.
[source]: Update URL.
[inputs]: Remove libtorrent, python2-chardet, python2-pygtk, python2-pyopenssl,
python2-pyxdg, python2-service-identity, python2-twisted.
[propagated-inputs]: Add gobject-introspection, gtk+, librsvg, libtorrent,
python-pycairo, python-chardet, python-dbus, python-mako, python-pygobject,
python-pillow, python-pyopenssl, python-pyxdg, python-rencode,
python-service-identity, python-setproctitle, python-six, python-twisted, and
python-zope-interface.
[native-inputs]: Add python-wheel.
[arguments]: Disable tests. Add 'wrap phase.
---
gnu/packages/bittorrent.scm | 60 ++++++++++++++++++++++++++++---------
1 file changed, 46 insertions(+), 14 deletions(-)

Toggle diff (96 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index f54e568b55..7df9f5fe5b 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -34,6 +34,7 @@
#:use-module (guix build-system python)
#:use-module (guix build-system glib-or-gtk)
#:use-module ((guix licenses) #:prefix l:)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages adns)
#:use-module (gnu packages boost)
@@ -55,6 +56,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages sqlite)
@@ -465,29 +467,59 @@ features.")
(define-public deluge
(package
(name "deluge")
- (version "1.3.15")
+ (version "2.0.3")
(source
(origin
(method url-fetch)
(uri (string-append
- "http://download.deluge-torrent.org/source/deluge-"
- version ".tar.xz"))
+ "https://ftp.osuosl.org/pub/deluge/source/"
+ (version-major+minor version) "/deluge-" version ".tar.xz"))
(sha256
(base32
- "0b7rri4x0wrcj7rjghrnw1kfrsd5i7i6aq85dsg5dg1w1qa0ar59"))))
+ "14d8kn2pvr1qv8mwqrxmj85jycr73vwfqz12hzag0ararbkfhyky"))))
(build-system python-build-system)
- (inputs
- `(("libtorrent" ,libtorrent-rasterbar)
- ("python2-chardet" ,python2-chardet)
- ("python2-pygtk" ,python2-pygtk)
- ("python2-pyopenssl" ,python2-pyopenssl)
- ("python2-pyxdg" ,python2-pyxdg)
- ("python2-service-identity" ,python2-service-identity)
- ("python2-twisted" ,python2-twisted)))
+ (propagated-inputs
+ `(("gobject-introspection" ,gobject-introspection)
+ ("gtk+" ,gtk+)
+ ("librsvg" ,librsvg)
+ ("libtorrent" ,libtorrent-rasterbar)
+ ("python-pycairo" ,python-pycairo)
+ ("python-chardet" ,python-chardet)
+ ("python-dbus" ,python-dbus)
+ ("python-mako" ,python-mako)
+ ("python-pygobject" ,python-pygobject)
+ ("python-pillow" ,python-pillow)
+ ("python-pyopenssl" ,python-pyopenssl)
+ ("python-pyxdg" ,python-pyxdg)
+ ("python-rencode" ,python-rencode)
+ ("python-service-identity" ,python-service-identity)
+ ("python-setproctitle" ,python-setproctitle)
+ ("python-six" ,python-six)
+ ("python-twisted" ,python-twisted)
+ ("python-zope-interface" ,python-zope-interface)))
(native-inputs
- `(("intltool" ,intltool)))
+ `(("intltool" ,intltool)
+ ("python-wheel" ,python-wheel)))
+ ;; TODO: Enable tests.
+ ;; After "pytest-twisted" is packaged, HOME is set, and an X server is
+ ;; started, some of the tests still fail. There are likely some tests that
+ ;; require a network connection.
(arguments
- `(#:python ,python-2))
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
+ (for-each
+ (lambda (program)
+ (wrap-program program
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
+ (map (lambda (name)
+ (string-append out "/bin/" name))
+ '("deluge" "deluge-gtk"))))
+ #t)))))
(home-page "https://www.deluge-torrent.org/")
(synopsis "Fully-featured cross-platform ​BitTorrent client")
(description
--
2.28.0
Mathieu Othacehe wrote 5 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 43161@debbugs.gnu.org)
87ft7xq2sn.fsf@gnu.org
Hey,

Toggle quote (12 lines)
> * gnu/packages/bittorrent.scm (deluge): Update to 2.0.3.
> [source]: Update URL.
> [inputs]: Remove libtorrent, python2-chardet, python2-pygtk, python2-pyopenssl,
> python2-pyxdg, python2-service-identity, python2-twisted.
> [propagated-inputs]: Add gobject-introspection, gtk+, librsvg, libtorrent,
> python-pycairo, python-chardet, python-dbus, python-mako, python-pygobject,
> python-pillow, python-pyopenssl, python-pyxdg, python-rencode,
> python-service-identity, python-setproctitle, python-six, python-twisted, and
> python-zope-interface.
> [native-inputs]: Add python-wheel.
> [arguments]: Disable tests. Add 'wrap phase.

That's a major update!

Toggle quote (4 lines)
> + ;; After "pytest-twisted" is packaged, HOME is set, and an X server is
> + ;; started, some of the tests still fail. There are likely some tests that
> + ;; require a network connection.

Besides wrapping this comment to stay under the 78 columns limit, it all
looks fine.

Thanks,

Mathieu
Kei Kebreau wrote 5 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 43161-done@debbugs.gnu.org)
871rjgov07.fsf@posteo.net
Mathieu Othacehe <othacehe@gnu.org> writes:

Toggle quote (26 lines)
> Hey,
>
>> * gnu/packages/bittorrent.scm (deluge): Update to 2.0.3.
>> [source]: Update URL.
>> [inputs]: Remove libtorrent, python2-chardet, python2-pygtk,
>> python2-pyopenssl,
>> python2-pyxdg, python2-service-identity, python2-twisted.
>> [propagated-inputs]: Add gobject-introspection, gtk+, librsvg, libtorrent,
>> python-pycairo, python-chardet, python-dbus, python-mako, python-pygobject,
>> python-pillow, python-pyopenssl, python-pyxdg, python-rencode,
>> python-service-identity, python-setproctitle, python-six, python-twisted, and
>> python-zope-interface.
>> [native-inputs]: Add python-wheel.
>> [arguments]: Disable tests. Add 'wrap phase.
>
> That's a major update!
>
>> + ;; After "pytest-twisted" is packaged, HOME is set, and an X server is
>> + ;; started, some of the tests still fail. There are likely some
>> tests that
>> + ;; require a network connection.
>
> Besides wrapping this comment to stay under the 78 columns limit, it all
> looks fine.
>

Alright, I was under the impression that the column limit was 80 based
on the note in guix/lint.scm.

Toggle quote (4 lines)
> Thanks,
>
> Mathieu

Pushed with size-reducing and bug-fixing changes to master as commit
01d5eec92d!

Thanks for reviewing,
Kei
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43161@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43161
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help