[PATCH] gnu: Add knockd.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hendur Saga
  • Ludovic Courtès
Owner
unassigned
Submitted by
Hendur Saga
Severity
normal

Debbugs page

Hendur Saga wrote 5 years ago
(name . Tobias Geerinckx-Rice via Guix-patches via)(address . guix-patches@gnu.org)
861573269.1118153.1598909190486@mail.yahoo.com
A patch for a port-knocker daemon. I might work on a knockd-service definition sometime.
- Hendur Saga
Attachment: file
From 4d76736c3f64c674bd80f8fd2806ed6be202d5fa Mon Sep 17 00:00:00 2001
From: Hendursaga <hendursaga@yahoo.com>
Date: Mon, 31 Aug 2020 21:22:54 +0000
Subject: [PATCH] gnu: Add knockd.

* gnu/packages/networking.scm (knockd): New variable.
---
gnu/packages/networking.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1340bef8f0..10e66530df 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -379,6 +379,29 @@ sockets, and also some helper utilities around SCTP.")
;; Others.
license:gpl2+))))
+(define-public knockd
+ (package
+ (name "knockd")
+ (version "0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.zeroflux.org/proj/knock/files/knock-"
+ version ".tar.gz"))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "193qcpsy7v51c6awhg9652l5blyz8vp6n7y6fi7l4rhh6af4ff4r"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libpcap" ,libpcap)))
+ (home-page "https://www.zeroflux.org/projects/knock")
+ (synopsis "Small port-knock daemon")
+ (description "@command{knockd} is a port-knock daemon. It listens to all traffic on
+an ethernet or PPP interface, looking for special \"knock\" sequences of @dfn{port-hits}
+(UDP/TCP packets sent to a server port). This port need not be open, since knockd listens
+at the link-layer level.")
+ (license license:gpl2+)))
+
(define-public nng
(package
(name "nng")
--
2.28.0
Ludovic Courtès wrote 5 years ago
(name . Hendur Saga)(address . hendursaga@yahoo.com)(address . 43142-done@debbugs.gnu.org)
87eenk439i.fsf@gnu.org
Hi,

Hendur Saga <hendursaga@yahoo.com> skribis:

Toggle quote (9 lines)
> A patch for a port-knocker daemon. I might work on a knockd-service definition sometime.
> - Hendur Saga
> From 4d76736c3f64c674bd80f8fd2806ed6be202d5fa Mon Sep 17 00:00:00 2001
> From: Hendursaga <hendursaga@yahoo.com>
> Date: Mon, 31 Aug 2020 21:22:54 +0000
> Subject: [PATCH] gnu: Add knockd.
>
> * gnu/packages/networking.scm (knockd): New variable.

[...]

Toggle quote (6 lines)
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://www.zeroflux.org/proj/knock/files/knock-"
> + version ".tar.gz"))
> + (file-name (git-file-name name version))

Remove this last line and applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43142@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43142
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help