[PATCH] gnu: emacs-elisp-refs: Disable test failing on Emacs 27.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Michael Rohleder
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20200830075025.17460-1-mike@rohleder.de
* gnu/packages/emacs-xyz.scm (emacs-elisp-refs)[arguments]:
Add phase to disable failing test "elisp-refs-next-match" on emacs27.
---
My ert-runner fu is not good enough for a better hack. I tried
'("ert-runner" "-p" "!elisp-refs-next-match") as a test-command, but it
skipped all tests then.

gnu/packages/emacs-xyz.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c6d95d9b83..cfc728b53e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14825,7 +14825,17 @@ continue.")
("emacs-undercover" ,emacs-undercover)))
(arguments
`(#:tests? #t
- #:test-command '("ert-runner")))
+ #:test-command '("ert-runner")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-refs-next-match-test
+ ;; Hack to disable the failing test for emacs27
+ ;; https://github.com/Wilfred/elisp-refs/issues/29
+ (lambda _
+ (substitute* "test/unit-test.el"
+ (("ert-deftest elisp-refs-next-match")
+ "defun elisp-refs-next-match"))
+ #t)))))
(home-page "https://github.com/Wilfred/elisp-refs")
(synopsis "Find callers of elisp functions or macros")
(description "Find references to functions, macros or variables. Unlike a
--
2.28.0
Mathieu Othacehe wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 43108-done@debbugs.gnu.org)
87wo1dthzd.fsf@gnu.org
Hello Michael,

Toggle quote (4 lines)
> My ert-runner fu is not good enough for a better hack. I tried
> '("ert-runner" "-p" "!elisp-refs-next-match") as a test-command, but it
> skipped all tests then.

Well your hack seems to work fine :) Pushed as
a73ccefe315cd16e9d0b31a00bbd61e6cc3042f5.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43108@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43108
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help