[PATCH] gnu: Add libhandy-0.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
20200829164222.20373-1-leo.prikler@student.tugraz.at
As of 355761c2d27fe80ae73b872b8026cb15d8487fd0, packages built against
libhandy either fail to build or to run since they require the 0.0.x API.

* gnu/packages/gnome.scm (libhandy-0.0): New variable.
(gnome-tweaks geary)[inputs]: Use libhandy-0.0 instead of libhandy.
* gnu/packages/gnome.scm (chatty)[inputs]: Likewise.
---
gnu/packages/gnome.scm | 18 ++++++++++++++++--
gnu/packages/messaging.scm | 2 +-
2 files changed, 17 insertions(+), 3 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 59f827d65d..b92d869c08 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9157,7 +9157,7 @@ existing databases over the internet.")
("gtk+" ,gtk+)
("gobject-introspection" ,gobject-introspection)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("libhandy" ,libhandy)
+ ("libhandy" ,libhandy-0.0)
("libnotify" ,libnotify)
("libsoup" ,libsoup)
("nautilus" ,nautilus)
@@ -10521,6 +10521,20 @@ interfaces for mobile devices using GTK+. It provides responsive GTK+ widgets
for usage on small and big screens.")
(license license:lgpl2.1+)))
+(define-public libhandy-0.0
+ (package
+ (inherit libhandy)
+ (version "0.0.13")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/libhandy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "libhandy" version))
+ (sha256
+ (base32 "1y23k623sjkldfrdiwfarpchg5mg58smcy1pkgnwfwca15wm1ra5"))))))
+
(define-public libgit2-glib
(package
(name "libgit2-glib")
@@ -10895,7 +10909,7 @@ join_paths\\('build-aux', 'post_install.py'\\)\\)")
("json-glib" ,json-glib)
("libcanberra" ,libcanberra)
("libgee" ,libgee)
- ("libhandy" ,libhandy)
+ ("libhandy" ,libhandy-0.0)
("libpeas" ,libpeas)
("libsecret" ,libsecret)
("libunwind" ,libunwind)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9dc3e58ef9..8ddced6995 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2257,7 +2257,7 @@ support for high performance Telegram Bot creation.")
("folks" ,folks)
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
- ("libhandy" ,libhandy)
+ ("libhandy" ,libhandy-0.0)
("pidgin" ,pidgin)
("purple-mm-sms" ,purple-mm-sms)
("sqlite" ,sqlite)))
--
2.28.0
Leo Famulari wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 43104-done@debbugs.gnu.org)
20200829185131.GA31222@jasmine.lan
On Sat, Aug 29, 2020 at 06:42:22PM +0200, Leo Prikler wrote:
Toggle quote (7 lines)
> As of 355761c2d27fe80ae73b872b8026cb15d8487fd0, packages built against
> libhandy either fail to build or to run since they require the 0.0.x API.
>
> * gnu/packages/gnome.scm (libhandy-0.0): New variable.
> (gnome-tweaks geary)[inputs]: Use libhandy-0.0 instead of libhandy.
> * gnu/packages/gnome.scm (chatty)[inputs]: Likewise.

Thanks! Pushed as a790dfe8c466069c2c5942bcedceb924de8a50f2 with a minor
tweak in the commit message's comment.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43104@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43104
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help