[PATCH] gnu: reuse: Update to 0.11.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20200829025545.10796-1-mike@rohleder.de
* gnu/packages/license.scm (reuse): Update to 0.11.1.
[native-inputs]: added python-setuptools-scm.
---
gnu/packages/license.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/license.scm b/gnu/packages/license.scm
index 36bcb75f8d..975608c79b 100644
--- a/gnu/packages/license.scm
+++ b/gnu/packages/license.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -168,16 +169,17 @@ belonging to various licenses.")
(define-public reuse
(package
(name "reuse")
- (version "0.7.0")
+ (version "0.11.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "reuse" version))
(sha256
- (base32 "16wn28xxjcm5qlb7bs6jmdkfrkr5v97s59nmi9cn85qcg4gmj7lk"))))
+ (base32 "09qjb4f49vr0a7zrszab8g719ilg2p6b942mr0bgyvplrjikkid5"))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
(inputs
`(("python-binaryornot" ,python-binaryornot)
("python-boolean.py" ,python-boolean.py)
--
2.28.0
Leo Famulari wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 43098-done@debbugs.gnu.org)
20200829185346.GB31222@jasmine.lan
On Sat, Aug 29, 2020 at 04:55:45AM +0200, Michael Rohleder wrote:
Toggle quote (3 lines)
> * gnu/packages/license.scm (reuse): Update to 0.11.1.
> [native-inputs]: added python-setuptools-scm.

Thanks! Pushed as a046c03e139af4dcbe4cab3841fc7377f1152295
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43098@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43098
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help