[PATCH] gnu: Add emacs-auth-source-xoauth2.

  • Done
  • quality assurance status badge
Details
3 participants
  • Morgan.J.Smith
  • Nicolas Goaziou
  • Suhail Singh
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 5 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR1001MB210581BBAD98B2EED92335DFC5570@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-auth-source-xoauth2): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 62c9203efc..997d655683 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12474,6 +12474,30 @@ needs to be refreshed, the code handles it automatically and stores the new
value of the access token.")
(license license:gpl3+)))
+(define-public emacs-auth-source-xoauth2
+ (package
+ (name "emacs-auth-source-xoauth2")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ccrusius/auth-source-xoauth2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nl859csl8xcd6ybpjj15ph8l8fxwkwf45kbylss68alkyf1rl3v"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ccrusius/auth-source-xoauth2")
+ (synopsis "Adds @code{XOAuth2} authentication capabilities to Emacs
+@code{auth-source}")
+ (description "Adds @code{XOAuth2} authentication capabilities to Emacs
+@code{auth-source}. This integration requires some preliminary work on the
+users’ part, which includes creating tokens. For more details, @code{M-x
+describe-variable auth-source-xoauth2-creds}.")
+ (license license:asl2.0)))
+
(define-public emacs-circe
(package
(name "emacs-circe")
--
2.28.0
Nicolas Goaziou wrote 5 years ago
(address . Morgan.J.Smith@outlook.com)(address . 43046-done@debbugs.gnu.org)
875z94b4pd.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (5 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-auth-source-xoauth2): New
> variable.

Thank you.

I fixed indentation, slightly reworded the description and the synopsis,
and pushed.

Regards,
--
Nicolas Goaziou
Closed
Suhail Singh wrote 3 months ago
control message for bug #43046
(address . control@debbugs.gnu.org)
874j3g3hfb.fsf@gmail.com
user guix
unarchive 43046
usertag 43046 - plz-work
archive 43046
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43046@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43046
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help