Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
* gnu/packages/ruby.scm (ruby-kramdown-parser-gfm): New variable.
---
kramdown > 2.0 (commit 2b5b7809b6e91f7e35cc5f082af815c0a4725d58)
moved the support for the GFM format into this library[1].
This format is (at least) used in our jekyll pkg.
gnu/packages/ruby.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (35 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3ff93d2252..16ae477755 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10719,6 +10719,28 @@ of Markdown. It is completely written in Ruby, supports standard Markdown
popular by the PHP @code{Markdown Extra} package and @code{Maruku}.")
(license license:expat)))
+(define-public ruby-kramdown-parser-gfm
+ (package
+ (name "ruby-kramdown-parser-gfm")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "kramdown-parser-gfm" version))
+ (sha256
+ (base32
+ "0a8pb3v951f4x7h968rqfsa19c8arz21zw1vaj42jza22rap8fgv"))))
+ (build-system ruby-build-system)
+ (arguments `(#:tests? #f)) ; no rakefile
+ (propagated-inputs `(("ruby-kramdown" ,ruby-kramdown)))
+ (synopsis
+ "This provides a kramdown parser for the GFM dialect of Markdown")
+ (description
+ "This is a parser for kramdown that converts Markdown documents in the GFM
+dialect to HTML.")
+ (home-page "https://github.com/kramdown/parser-gfm")
+ (license license:expat)))
+
(define-public ruby-http-parser.rb
(package
(name "ruby-http-parser.rb")
--
2.28.0