[PATCH] gnu: Add ruby-kramdown-parser-gfm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20200823223525.9759-1-mike@rohleder.de
* gnu/packages/ruby.scm (ruby-kramdown-parser-gfm): New variable.
---
kramdown > 2.0 (commit 2b5b7809b6e91f7e35cc5f082af815c0a4725d58)
moved the support for the GFM format into this library[1].
This format is (at least) used in our jekyll pkg.


gnu/packages/ruby.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3ff93d2252..16ae477755 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10719,6 +10719,28 @@ of Markdown. It is completely written in Ruby, supports standard Markdown
popular by the PHP @code{Markdown Extra} package and @code{Maruku}.")
(license license:expat)))
+(define-public ruby-kramdown-parser-gfm
+ (package
+ (name "ruby-kramdown-parser-gfm")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "kramdown-parser-gfm" version))
+ (sha256
+ (base32
+ "0a8pb3v951f4x7h968rqfsa19c8arz21zw1vaj42jza22rap8fgv"))))
+ (build-system ruby-build-system)
+ (arguments `(#:tests? #f)) ; no rakefile
+ (propagated-inputs `(("ruby-kramdown" ,ruby-kramdown)))
+ (synopsis
+ "This provides a kramdown parser for the GFM dialect of Markdown")
+ (description
+ "This is a parser for kramdown that converts Markdown documents in the GFM
+dialect to HTML.")
+ (home-page "https://github.com/kramdown/parser-gfm")
+ (license license:expat)))
+
(define-public ruby-http-parser.rb
(package
(name "ruby-http-parser.rb")
--
2.28.0
Nicolas Goaziou wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 43008-done@debbugs.gnu.org)
87d03gs4yy.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (2 lines)
> * gnu/packages/ruby.scm (ruby-kramdown-parser-gfm): New variable.

Applied. Thanks!

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43008@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43008
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help