[PATCH] gnu: lesspipe: Patch paths to inputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20200822164012.8389-1-mike@rohleder.de
* gnu/packages/less.scm (lesspipe)[arguments]: Add phase to patch
paths to tput and file.
---
gnu/packages/less.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/less.scm b/gnu/packages/less.scm
index f6ee355b68..7c5107de09 100644
--- a/gnu/packages/less.scm
+++ b/gnu/packages/less.scm
@@ -80,7 +80,17 @@ text editors.")
(invoke "./configure"
(string-append "--prefix=" out)
"--yes")
- #t))))))
+ #t)))
+ (add-before 'install 'patch-tput-and-file
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "lesspipe.sh"
+ (("tput colors")
+ (string-append (assoc-ref inputs "ncurses")
+ "/bin/tput colors"))
+ (("file -")
+ (string-append (assoc-ref inputs "file")
+ "/bin/file -")))
+ #t)))))
(inputs
`(("file" ,file)
("ncurses" ,ncurses))) ; for tput
--
2.28.0
Leo Famulari wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 42988-done@debbugs.gnu.org)
20200822214659.GB30500@jasmine.lan
On Sat, Aug 22, 2020 at 06:40:12PM +0200, Michael Rohleder wrote:
Toggle quote (3 lines)
> * gnu/packages/less.scm (lesspipe)[arguments]: Add phase to patch
> paths to tput and file.

Thanks! Pushed as 5a4990b98260ba85b8b93d6ac43d871e370d6983
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42988@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42988
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help