[PATCH] gnu: akku: Add akku.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Martin Becze
Owner
unassigned
Submitted by
Martin Becze
Severity
normal
M
M
Martin Becze wrote on 21 Aug 2020 21:24
(address . guix-patches@gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20200821192433.27053-1-mjbecze@riseup.net
* gnu/packages/package-management.scm (akku): New variable.
---
gnu/packages/package-management.scm | 50 +++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index d1fe0e2210..f1951c3218 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
+;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1268,3 +1269,52 @@ applications")
(description "Flatpak is a system for building, distributing, and running
sandboxed desktop applications on GNU/Linux.")
(license license:lgpl2.1+)))
+
+(define-public akku
+ (package
+ (name "akku")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/akkuscm/akku.git")
+ (commit (string-append "v" version))))
+ (sha256 (base32 "1dm32ws3nshnnscd7k75zswxxs1pp25y2q4k8j5ms241hz47by3c"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each patch-shebang
+ '("bootstrap"
+ ".akku/env"))
+ (let* ((home "/tmp")
+ (datadir (string-append home "/.local/share/akku/")))
+ (mkdir-p datadir)
+ (invoke "touch" (string-append datadir "index.db"))
+ (setenv "HOME" home))
+ (invoke "./bootstrap")
+ #t))
+ (add-after 'install 'wrap-executables
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (curl (assoc-ref inputs "curl")))
+ (wrap-program (string-append out "/bin/akku")
+ `("LD_LIBRARY_PATH" ":" prefix (,(string-append curl "/lib"))))
+ #t))))))
+ (native-inputs
+ `(("which" ,which)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-2.2)
+ ("curl" ,curl)))
+ (home-page "https://akkuscm.org/")
+ (synopsis "Akku.scm is a language package manager for Scheme")
+ (description
+ "Akku.scm is a project-based language package manager for R6RS and R7RS Scheme.
+It is mainly meant for programmers who develop portable programs or libraries in Scheme,
+but could potentially work for end-users of those programs. It also has a translator
+from R7RS, which allows most R7RS code to run on R6RS implementations.")
+ (license license:gpl3)))
--
2.28.0
M
M
Martin Becze wrote on 23 Aug 2020 11:17
[PATCH] v2 gnu: akku: Add akku.
(address . 42975@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20200823091740.3451-1-mjbecze@riseup.net
* gnu/packages/package-management.scm (akku): New variable.
---
gnu/packages/package-management.scm | 50 +++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index d1fe0e2210..f1951c3218 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
+;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1268,3 +1269,52 @@ applications")
(description "Flatpak is a system for building, distributing, and running
sandboxed desktop applications on GNU/Linux.")
(license license:lgpl2.1+)))
+
+(define-public akku
+ (package
+ (name "akku")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/akkuscm/akku.git")
+ (commit (string-append "v" version))))
+ (sha256 (base32 "1dm32ws3nshnnscd7k75zswxxs1pp25y2q4k8j5ms241hz47by3c"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each patch-shebang
+ '("bootstrap"
+ ".akku/env"))
+ (let* ((home "/tmp")
+ (datadir (string-append home "/.local/share/akku/")))
+ (mkdir-p datadir)
+ (invoke "touch" (string-append datadir "index.db"))
+ (setenv "HOME" home))
+ (invoke "./bootstrap")
+ #t))
+ (add-after 'install 'wrap-executables
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (curl (assoc-ref inputs "curl")))
+ (wrap-program (string-append out "/bin/akku")
+ `("LD_LIBRARY_PATH" ":" prefix (,(string-append curl "/lib"))))
+ #t))))))
+ (native-inputs
+ `(("which" ,which)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-2.2)
+ ("curl" ,curl)))
+ (home-page "https://akkuscm.org/")
+ (synopsis "Akku.scm is a language package manager for Scheme")
+ (description
+ "Akku.scm is a project-based language package manager for R6RS and R7RS Scheme.
+It is mainly meant for programmers who develop portable programs or libraries in Scheme,
+but could potentially work for end-users of those programs. It also has a translator
+from R7RS, which allows most R7RS code to run on R6RS implementations.")
+ (license license:gpl3)))
--
2.28.0
M
M
Martin Becze wrote on 23 Aug 2020 11:19
(address . 42975@debbugs.gnu.org)
0a239a23-5347-3c1c-2888-72a85e751873@riseup.net
The above fixes some lint errors

On 8/23/20 4:17 AM, Martin Becze wrote:
Toggle quote (71 lines)
> * gnu/packages/package-management.scm (akku): New variable.
> ---
> gnu/packages/package-management.scm | 50 +++++++++++++++++++++++++++++
> 1 file changed, 50 insertions(+)
>
> diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
> index d1fe0e2210..f1951c3218 100644
> --- a/gnu/packages/package-management.scm
> +++ b/gnu/packages/package-management.scm
> @@ -15,6 +15,7 @@
> ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
> ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
> ;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
> +;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -1268,3 +1269,52 @@ applications")
> (description "Flatpak is a system for building, distributing, and running
> sandboxed desktop applications on GNU/Linux.")
> (license license:lgpl2.1+)))
> +
> +(define-public akku
> + (package
> + (name "akku")
> + (version "1.0.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.com/akkuscm/akku.git")
> + (commit (string-append "v" version))))
> + (sha256 (base32 "1dm32ws3nshnnscd7k75zswxxs1pp25y2q4k8j5ms241hz47by3c"))))
> + (build-system gnu-build-system)
> + (arguments
> + '(#:phases (modify-phases %standard-phases
> + (replace 'bootstrap
> + (lambda* (#:key outputs #:allow-other-keys)
> + (for-each patch-shebang
> + '("bootstrap"
> + ".akku/env"))
> + (let* ((home "/tmp")
> + (datadir (string-append home "/.local/share/akku/")))
> + (mkdir-p datadir)
> + (invoke "touch" (string-append datadir "index.db"))
> + (setenv "HOME" home))
> + (invoke "./bootstrap")
> + #t))
> + (add-after 'install 'wrap-executables
> + (lambda* (#:key outputs inputs #:allow-other-keys)
> + (let ((out (assoc-ref outputs "out"))
> + (curl (assoc-ref inputs "curl")))
> + (wrap-program (string-append out "/bin/akku")
> + `("LD_LIBRARY_PATH" ":" prefix (,(string-append curl "/lib"))))
> + #t))))))
> + (native-inputs
> + `(("which" ,which)
> + ("autoconf" ,autoconf)
> + ("automake" ,automake)
> + ("pkg-config" ,pkg-config)))
> + (inputs
> + `(("guile" ,guile-2.2)
> + ("curl" ,curl)))
> + (home-page "https://akkuscm.org/")
> + (synopsis "Akku.scm is a language package manager for Scheme")
> + (description
> + "Akku.scm is a project-based language package manager for R6RS and R7RS Scheme.
> +It is mainly meant for programmers who develop portable programs or libraries in Scheme,
> +but could potentially work for end-users of those programs. It also has a translator
> +from R7RS, which allows most R7RS code to run on R6RS implementations.")
> + (license license:gpl3)))
>
Attachment: signature.asc
M
M
Martin Becze wrote on 23 Aug 2020 20:21
[PATCH v3] gnu: Add akku.
(address . 42975@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20200823182118.9459-1-mjbecze@riseup.net
* gnu/packages/package-management.scm (akku): New variable.
---
gnu/packages/package-management.scm | 51 +++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (68 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index d1fe0e2210..eb5877d167 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
+;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1268,3 +1269,53 @@ applications")
(description "Flatpak is a system for building, distributing, and running
sandboxed desktop applications on GNU/Linux.")
(license license:lgpl2.1+)))
+
+(define-public akku
+ (package
+ (name "akku")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/akkuscm/akku.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "1dm32ws3nshnnscd7k75zswxxs1pp25y2q4k8j5ms241hz47by3c"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each patch-shebang
+ '("bootstrap"
+ ".akku/env"))
+ (let* ((home "/tmp")
+ (datadir (string-append home "/.local/share/akku/")))
+ (mkdir-p datadir)
+ (invoke "touch" (string-append datadir "index.db"))
+ (setenv "HOME" home))
+ (invoke "./bootstrap")
+ #t))
+ (add-after 'install 'wrap-executables
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (curl (assoc-ref inputs "curl")))
+ (wrap-program (string-append out "/bin/akku")
+ `("LD_LIBRARY_PATH" ":" prefix (,(string-append curl "/lib"))))
+ #t))))))
+ (native-inputs
+ `(("which" ,which)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-3.0)
+ ("curl" ,curl)))
+ (home-page "https://akkuscm.org/")
+ (synopsis "A language package manager for Scheme")
+ (description
+ "Akku.scm is a project-based language package manager for R6RS and R7RS Scheme.
+It is mainly meant for programmers who develop portable programs or libraries in Scheme,
+but could potentially work for end-users of those programs. It also has a translator
+from R7RS, which allows most R7RS code to run on R6RS implementations.")
+ (license license:gpl3)))
--
2.28.0
L
L
Leo Famulari wrote on 23 Aug 2020 23:18
(name . Martin Becze)(address . mjbecze@riseup.net)(address . 42975-done@debbugs.gnu.org)
20200823211814.GA24968@jasmine.lan
On Sun, Aug 23, 2020 at 01:21:18PM -0500, Martin Becze wrote:
Toggle quote (2 lines)
> * gnu/packages/package-management.scm (akku): New variable.

Thank you!

I pushed as e343816dcb11f0150fa3b14589142c418dfbb0d8 with the following
changes:

Toggle quote (2 lines)
> + (synopsis "A language package manager for Scheme")

To satisfy the linter's complaint "no article allowed at the beginning
of the synopsis", I removed the first word of the synopsis.

The common English articles are the words A, An, and The. We consider
them unecessary in this context.

Toggle quote (2 lines)
> + (license license:gpl3)))

I changed this to gpl3+.

I made that decision based on the COPYING file, and the license headers
of the files in the bin and lib directories, which consistently include
the text "(at your option) any later version".
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl9C3RUACgkQJkb6MLrK
fwh0gw/9Ht51Uuf2uuHtKnNtl2rXW70gYKY3w0eiAFvzQYxGqrElVMwbgZ/PKZZd
2koofFDl8YPb34ZYKGUvVLUSJXWF+BtzYtNYEpk4rNkeB4omoXKeNtXggKAsIYMa
GQ7Tat5UK+gHSPY0K+0dKylpy7t0OwkgiN8CjqTa0WtEqt/XYxD4rmuXvBJcLEX8
jycMn3hm7jLwvlwRh50JpElKFHbCL/EzPS3rn03Rfc5piD36cT+uJM8AbEEAEfnL
lFpKGV0WgyWD440yT4ePqJXAiUOZHB8YCYYcWvrfuLCq40050QVlP19cIyE8JQC4
2OHSy+OtlWVVke+TbNU+H3QWMiM4ntmTxtIZXMcEkzoAsrooxNPkLCsyPsIuDIJN
w9pPHbsn8+PYouvcA/5bImUSX22MP70hIxclB0LrKgcpLcTgMduo3P99+BDOdZsN
KWoS1BrOfNTmLHymINYZU4Bhs+ZR45uAzgS5ml+Iic07nGF4KrmbGJK+f8ika0Ri
qzsQKPz6XYWAhGkOFOdQf/gbh+158XpGW2MdTMSUFd4fiYeLYA4amAM+eTe5saIP
0eSMg/eLU+LEIy5YzbQDaacWbyiJR9E8EmF3Asr73qXmIYYZQrzZIwu3bZe4NRht
AOCU6Fy78QlaICFrQvu+tq+ovynQSsjCZg44pE/0AtvlYeeopFo=
=yqqF
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42975@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42975
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch