[PATCH] gnu: Add rtaudio.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Mathieu Othacehe
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal

Debbugs page

Vinicius Monego wrote 5 years ago
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200819235602.6585-1-monego@posteo.net
* gnu/packages/audio.scm (rtaudio): New variable.
---
gnu/packages/audio.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 37eca6c291..ca42dcffbe 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1992,6 +1992,48 @@ with applications that support them (e.g. PulseAudio).")
implementation of the Open Sound Control (@dfn{OSC}) protocol.")
(license license:lgpl2.1+)))
+(define-public rtaudio
+ (package
+ (name "rtaudio")
+ (version "5.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/thestk/rtaudio")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "156c2dgh6jrsyfn1y89nslvaxm4yifmxridsb708yvkaym02w2l8"))))
+ (build-system cmake-build-system)
+ (home-page "https://www.music.mcgill.ca/~gary/rtaudio/")
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-1)
+ ("pulseaudio" ,pulseaudio)))
+ (synopsis "Common API for real-time audio I/O")
+ (description
+ "RtAudio is a set of C++ classes that provides a common API for real-time
+audio input/output. It was designed with the following objectives:
+
+@itemize
+@item object-oriented C++ design
+@item simple, common API across all supported platforms
+@item only one source and one header file for easy inclusion in programming
+projects
+@item allow simultaneous multi-api support
+@item support dynamic connection of devices
+@item provide extensive audio device parameter control
+@item allow audio device capability probing
+@item automatic internal conversion for data format, channel number
+compensation, (de)interleaving, and byte-swapping
+@end itemize")
+ ;; License is expat with a non-binding request to send modifications to
+ ;; original developer.
+ (license license:expat)))
+
(define-public python-pyaudio
(package
(name "python-pyaudio")
--
2.20.1
Leo Famulari wrote 5 years ago
(name . Vinicius Monego)(address . monego@posteo.net)(address . 42942@debbugs.gnu.org)
20200822174001.GB12497@jasmine.lan
On Wed, Aug 19, 2020 at 08:56:02PM -0300, Vinicius Monego wrote:
Toggle quote (2 lines)
> * gnu/packages/audio.scm (rtaudio): New variable.

Thanks! Pushed as b6568c35266d75bb6e3c6e2c1981abfdac364961
Mathieu Othacehe wrote 5 years ago
control message for bug #42942
(address . control@debbugs.gnu.org)
87v9h8e8la.fsf@cervin.i-did-not-set--mail-host-address--so-tickle-me
close 42942
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42942@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42942
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help