[PATCH] Add ssss.

  • Done
  • quality assurance status badge
Details
3 participants
  • Hendur Saga
  • Leo Famulari
  • Ludovic Courtès
Owner
unassigned
Submitted by
Hendur Saga
Severity
normal

Debbugs page

Hendur Saga wrote 5 years ago
(name . Tobias Geerinckx-Rice via Guix-patches via)(address . guix-patches@gnu.org)
636909310.4477345.1597856714655@mail.yahoo.com
There are no tests, but I manually confirmed I could split and then combine shares. There is a warning about RLIMIT_MEMLOCK, because ssss tries to memory lock for security reasons, but I assumed that that was system-dependent and not something I should mess with in the package definition.

- Hendursaga
Attachment: file
From e0d85f2bb840d0a3fa9c6c0e5236c3409fe4bd7c Mon Sep 17 00:00:00 2001
From: Hendursaga <hendursaga@yahoo.com>
Date: Wed, 19 Aug 2020 16:58:31 +0000
Subject: [PATCH] gnu: Add ssss.

* gnu/packages/crypto.scm (ssss): New variable.
---
gnu/packages/crypto.scm | 45 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 5532f7e9f8..bc198ef48c 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -53,6 +53,8 @@
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
#:use-module (gnu packages lsof)
+ #:use-module (gnu packages man)
+ #:use-module (gnu packages multiprecision)
#:use-module (gnu packages nettle)
#:use-module (gnu packages password-utils)
#:use-module (gnu packages perl)
@@ -394,6 +396,49 @@ generation of wordlists the included tool @code{worgen} can be used. There is
no man page, refer to the home page for usage details.")
(license (list license:isc license:expat)))))
+(define-public ssss
+ (package
+ (name "ssss")
+ (version "0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://point-at-infinity.org/ssss/ssss-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "15grn2fp1x8p92kxkwbmsx8rz16g93y9grl3hfqbh1jn21ama5jx"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No test suite
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configuration to be done
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((outdir (assoc-ref outputs "out"))
+ (bindir (string-append outdir "/bin"))
+ (docdir (string-append outdir
+ "/share/doc/ssss-"
+ ,version)))
+ (install-file "ssss-combine" bindir)
+ (install-file "ssss-split" bindir)
+ (install-file "ssss.1" docdir)
+ (install-file "ssss.1.html" docdir)
+ #t))))))
+ (inputs
+ `(("gmp" ,gmp)))
+ (native-inputs
+ `(("xmltoman" ,xmltoman)))
+ (home-page "http://point-at-infinity.org/ssss/")
+ (synopsis "Shamir's secret sharing scheme implementation")
+ (description "@command{ssss-split} and @command{ssss-combine} are utilities that split
+and combine secrets securely using Shamir's secret sharing scheme. This implementation
+allows for a threshold scheme where the minimum number of shares can be less than the
+total number of shares generated.")
+ (license license:gpl2+)))
+
(define-public tomb
(package
(name "tomb")
--
2.28.0
Leo Famulari wrote 5 years ago
(name . Hendur Saga via Guix-patches via)(address . guix-patches@gnu.org)(address . 42936-done@debbugs.gnu.org)
20200827010145.GA27480@jasmine.lan
On Wed, Aug 19, 2020 at 05:05:14PM +0000, Hendur Saga via Guix-patches via wrote:
Toggle quote (11 lines)
> There are no tests, but I manually confirmed I could split and then combine shares. There is a warning about�RLIMIT_MEMLOCK, because ssss tries to memory lock for security reasons, but I assumed that that was system-dependent and not something I should mess with in the package definition.
>
> - Hendursaga

> From e0d85f2bb840d0a3fa9c6c0e5236c3409fe4bd7c Mon Sep 17 00:00:00 2001
> From: Hendursaga <hendursaga@yahoo.com>
> Date: Wed, 19 Aug 2020 16:58:31 +0000
> Subject: [PATCH] gnu: Add ssss.
>
> * gnu/packages/crypto.scm (ssss): New variable.

Thanks! Pushed as ce022b2e142c75b9e4d05fc1aec91e345dc374a7
Closed
Ludovic Courtès wrote 5 years ago
(name . Hendur Saga)(address . hendursaga@yahoo.com)(address . 42936-done@debbugs.gnu.org)
87d03aol2x.fsf@gnu.org
Hello,

Hendur Saga <hendursaga@yahoo.com> skribis:

Toggle quote (7 lines)
> From e0d85f2bb840d0a3fa9c6c0e5236c3409fe4bd7c Mon Sep 17 00:00:00 2001
> From: Hendursaga <hendursaga@yahoo.com>
> Date: Wed, 19 Aug 2020 16:58:31 +0000
> Subject: [PATCH] gnu: Add ssss.
>
> * gnu/packages/crypto.scm (ssss): New variable.

I added a copyright line for you (let me know if I got it wrong) and
applied it. Thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42936@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42936
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help