[PATCH] gnu: Add fullswof-2d.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Mathieu Othacehe
  • Paul Garlick
Owner
unassigned
Submitted by
Paul Garlick
Severity
normal

Debbugs page

Paul Garlick wrote 5 years ago
(address . guix-patches@gnu.org)(name . Paul Garlick)(address . pgarlick@tourbillion-technology.com)
1597838632-32403-1-git-send-email-pgarlick@tourbillion-technology.com
* gnu/packages/simulation.scm (fullswof-2d): New variable.
---
gnu/packages/simulation.scm | 72 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 72 insertions(+)

Toggle diff (96 lines)
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 8d57885..a95160c 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -19,6 +19,7 @@
(define-module (gnu packages simulation)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
@@ -47,6 +48,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (guix download)
+ #:use-module (guix svn-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
@@ -724,3 +726,73 @@ problems that can be solved using the Finite Element Method (FEM).
within the FEniCS project. It provides the python user interface to the
FEniCS core components and external libraries.")
(license license:lgpl3+)))
+
+(define-public fullswof-2d
+ (let ((revision 505)
+ (release "1.09.01"))
+ (package
+ (name "fullswof-2d")
+ (version release)
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "https://subversion.renater.fr/"
+ "anonscm/svn/fullswof-2d/tags/"
+ "release-" version))
+ (revision revision)))
+ (file-name (string-append "fullswof-2d-" version "-checkout"))
+ (sha256
+ (base32
+ "16v08dx7h7n4wyddzbwimazwyj74ynis12mpjfkay4243npy44b8"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("inetutils" ,inetutils))) ; for 'hostname', used in the check phase
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (add-after 'build 'build-tools
+ (lambda _
+ (with-directory-excursion "Tools/ConvertFormat"
+ (invoke "make" "../../bin/asc2xyz")
+ (invoke "make" "../../bin/xyz2asc"))
+ (with-directory-excursion "Tools/ExtractWindow"
+ (invoke "make" "../../bin/cropxyz"))
+ #t))
+ (replace 'check ; no check target
+ (lambda _
+ (invoke "make" "benchref")))
+ (replace 'install ; no install target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (doc (string-append
+ out "/share/doc/" ,name "-" ,version))
+ (examples (string-append doc "/Examples")))
+ (with-directory-excursion "bin"
+ (for-each (lambda (binary) (install-file binary bin))
+ (list "asc2xyz" "xyz2asc" "cropxyz"
+ "FullSWOF_2D")))
+ (with-directory-excursion "doc"
+ (for-each (lambda (pdf) (install-file pdf doc))
+ (list "Documentation.pdf" "refman.pdf")))
+ (with-directory-excursion "Tools"
+ (for-each (lambda (dir)
+ (copy-file
+ (string-append dir "/README.txt")
+ (string-append doc "/README_" dir ".txt")))
+ (list "ConvertFormat" "ExtractWindow")))
+ (copy-recursively "Examples" examples)
+ #t))))))
+ (home-page "https://www.idpoisson.fr/fullswof/")
+ (synopsis "Two dimensional flow solver for flood modelling")
+ (description "@code{FullSWOF_2d} is a numerical tool for solving
+the shallow water equations on structured grids. The name FullSWOF
+refers to the Full form of the Shallow Water equations for Overland
+Flow. The discretized system of equations is solved using the finite
+volume method. A choice of shock-capturing methods is available to
+locate the transition boundaries between the wet areas and the dry
+areas in the model. A semi-implicit method is used to advance the
+solution in time. The tool is typically applied to the modelling of
+river flooding.")
+ (license license:cecill))))
--
1.8.3.1
Leo Famulari wrote 5 years ago
(name . Paul Garlick)(address . pgarlick@tourbillion-technology.com)(address . 42929@debbugs.gnu.org)
20200822175804.GC12497@jasmine.lan
On Wed, Aug 19, 2020 at 01:03:52PM +0100, Paul Garlick wrote:
Toggle quote (2 lines)
> * gnu/packages/simulation.scm (fullswof-2d): New variable.

Thanks! Pushed as 40fc8992db016baa7048076947757baf94fb957f
Mathieu Othacehe wrote 5 years ago
control message for bug #42929
(address . control@debbugs.gnu.org)
87tuwse8j4.fsf@cervin.i-did-not-set--mail-host-address--so-tickle-me
close 42929
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42929@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42929
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help