[PATCH 0/2] gnu: qttools: Install additional files.

  • Open
  • quality assurance status badge
Details
One participant
  • Timotej Lazar
Owner
unassigned
Submitted by
Timotej Lazar
Severity
normal
T
T
Timotej Lazar wrote on 19 Aug 2020 13:50
(address . guix-patches@gnu.org)
87zh6qn9bp.fsf@araneo.si
Hi,

this installs desktop files and manpages for Qt utilities.

Thanks!

Timotej Lazar (2):
gnu: qttools: Install desktop files and icons.
gnu: qttools: Install man pages.

gnu/packages/qt.scm | 70 ++++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 69 insertions(+), 1 deletion(-)

--
2.28.0
T
T
Timotej Lazar wrote on 19 Aug 2020 13:53
[PATCH 1/2] gnu: qttools: Install desktop files and icons.
(address . 42928@debbugs.gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
20200819115318.5655-1-timotej.lazar@araneo.si
* gnu/packages/qt.scm (qttools)[phases]: Add 'install-desktop-files.
---
gnu/packages/qt.scm | 62 ++++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 61 insertions(+), 1 deletion(-)

Toggle diff (75 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index ee903ecae9..4ca9786d8b 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1185,7 +1185,67 @@ positioning and geolocation plugins.")))
"1iakl3hlyg51ri1czmis8mmb257b0y1zk2a2knybd3mq69wczc2v"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
- ((#:tests? _ #f) #f))) ; TODO: Enable the tests
+ ((#:tests? _ #f) #f) ; TODO: Enable the tests
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'install 'install-desktop-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (apps (string-append out "/share/applications"))
+ (icons (string-append out "/share/icons/hicolor")))
+ ;; Install icons.
+ (with-directory-excursion "src"
+ (for-each
+ (lambda (icon)
+ ;; Get name and size from the slightly inconsistent filenames.
+ (let* ((parts (string-split (basename icon ".png") #\-))
+ (name (car parts))
+ (size (if (> (length parts) 1) (cadr parts) "32"))
+ (dest (string-append icons "/" size "x" size "/apps")))
+ (mkdir-p dest)
+ (copy-file icon (string-append dest "/" name ".png"))))
+ '("assistant/assistant/images/assistant.png"
+ "assistant/assistant/images/assistant-128.png"
+ "designer/src/designer/images/designer.png"
+ "linguist/linguist/images/icons/linguist-16-32.png"
+ "linguist/linguist/images/icons/linguist-32-32.png"
+ "linguist/linguist/images/icons/linguist-48-32.png"
+ "linguist/linguist/images/icons/linguist-64-32.png"
+ "linguist/linguist/images/icons/linguist-128-32.png"
+ "qdbus/qdbusviewer/images/qdbusviewer.png"
+ "qdbus/qdbusviewer/images/qdbusviewer-128.png")))
+ ;; Install desktop files.
+ (make-desktop-entry-file
+ (string-append apps "/assistant.desktop")
+ #:name "Qt Assistant"
+ #:comment "Browse Qt documentation and examples"
+ #:exec "assistant"
+ #:icon "assistant"
+ #:categories '("Qt" "Development" "Documentation"))
+ (make-desktop-entry-file
+ (string-append apps "/designer.desktop")
+ #:name "Qt Designer"
+ #:comment "Design GUIs for Qt applications"
+ #:exec "designer"
+ #:icon "designer"
+ #:categories '("Qt" "Development" "GUIDesigner")
+ #:mime-type '("application/x-designer"))
+ (make-desktop-entry-file
+ (string-append apps "/linguist.desktop")
+ #:name "Qt Linguist"
+ #:comment "Translate Qt applications"
+ #:exec "linguist"
+ #:icon "linguist"
+ #:categories '("Qt" "Development" "Translation")
+ #:mime-type '("application/x-linguist"))
+ (make-desktop-entry-file
+ (string-append apps "/qdbusviewer.desktop")
+ #:name "Qt D-Bus viewer"
+ #:comment "Browse D-Bus objects and messages"
+ #:exec "qdbusviewer"
+ #:icon "qdbusviewer"
+ #:categories '("Qt" "Development")))
+ #t))))))
(native-inputs
`(("perl" ,perl)
("qtdeclarative" ,qtdeclarative)
--
2.28.0
T
T
Timotej Lazar wrote on 19 Aug 2020 13:53
[PATCH 2/2] gnu: qttools: Install man pages.
(address . 42928@debbugs.gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
20200819115318.5655-2-timotej.lazar@araneo.si
* gnu/packages/qt.scm (qttools)[phases]: Add 'install-man-pages.
---
gnu/packages/qt.scm | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4ca9786d8b..a3ffb7e79d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1188,7 +1188,15 @@ positioning and geolocation plugins.")))
((#:tests? _ #f) #f) ; TODO: Enable the tests
((#:phases phases)
`(modify-phases ,phases
- (add-after 'install 'install-desktop-files
+ (add-after 'install 'install-man-pages
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man (string-append out "/share/man/man1")))
+ (with-directory-excursion "src/linguist"
+ (install-file "lrelease/lrelease.1" man)
+ (install-file "lupdate/lupdate.1" man)))
+ #t))
+ (add-after 'install-man-pages 'install-desktop-files
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(apps (string-append out "/share/applications"))
--
2.28.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 42928@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42928
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch