[PATCH] gnu: Add libinstpatch.

  • Done
  • quality assurance status badge
Details
2 participants
  • Vinicius Monego
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal

Debbugs page

Vinicius Monego wrote 5 years ago
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200816014505.7651-1-monego@posteo.net
* gnu/packages/audio.scm (libinstpatch): New variable.
---
gnu/packages/audio.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 79fdd1f3f0..953bd8dea6 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Jonathan Frederickson <jonathan@terracrypt.net>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4401,6 +4402,38 @@ minimum.")
(home-page "https://git.zrythm.org/cgit/ztoolkit/")
(license license:agpl3+)))
+(define-public libinstpatch
+ (package
+ (name "libinstpatch")
+ (version "1.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/swami/libinstpatch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0psx4hc5yksfd3k2xqsc7c8lbz2d4yybikyddyd9hlkhq979cmjb"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;there are no tests
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("libsndfile" ,libsndfile)))
+ (home-page "http://www.swamiproject.org/")
+ (synopsis "Instrument file software library")
+ (description
+ "libInstPatch is a library for processing digital sample based MIDI
+instrument \"patch\" files. The types of files libInstPatch supports are
+used for creating instrument sounds for wavetable synthesis. libInstPatch
+provides an object framework (based on GObject) to load patch files into,
+which can then be edited, converted, compressed and saved.")
+ (license license:lgpl2.1)))
+
(define-public ztoolkit-rsvg
(package
(inherit ztoolkit)
--
2.20.1
Mathieu Othacehe wrote 5 years ago
(name . Vinicius Monego)(address . monego@posteo.net)(address . 42878-done@debbugs.gnu.org)
878sef118g.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/audio.scm (libinstpatch): New variable.

Pushed, thanks!

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42878@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42878
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help