[PATCH] gnu: Add kxstitch.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 5 years ago
(address . guix-patches@gnu.org)
20200815202344.10272-1-mail@cbaines.net
* gnu/packages/kde-utils.scm (kxstitch): New variable.
---
gnu/packages/kde-utils.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 3c0eb09745..642a5bbea6 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -24,6 +24,8 @@
#:use-module (guix packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages kde)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages kde-plasma)
@@ -297,6 +299,34 @@ Almost completely customizable, Krusader is very user friendly, fast and looks
great on your desktop.")
(license license:gpl2+)))
+(define-public kxstitch
+ (package
+ (name "kxstitch")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/kxstitch/" version
+ "/kxstitch-" version ".tar.xz"))
+ (sha256
+ (base32 "1q6blvcqz6hxdfrkdi0fplmz7rmk3im56kpp68r0yrivhx3hn8sc"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ktexteditor" ,ktexteditor)
+ ("imagemagick" ,imagemagick)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)))
+ (home-page "https://kde.org/applications/en/graphics/org.kde.kxstitch")
+ (synopsis "Create and print cross stitch patterns")
+ (description
+ "KXStitch allows creating and printing cross stitch patterns, which can
+either be created or generated from a image.")
+ (license license:gpl2+)))
+
(define-public okteta
(package
(name "okteta")
@@ -510,3 +540,4 @@ It can quickly remove temporary information, such as web page cookies,
browser history, or the list of recently-opened documents. It helps provide
additional privacy on a system shared between multiple users.")
(license license:lgpl2.0+ )))
+<
--
2.28.0
Mathieu Othacehe wrote 5 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 42876@debbugs.gnu.org)
87eeo712dh.fsf@gnu.org
Hello Christopher,

Toggle quote (2 lines)
> * gnu/packages/kde-utils.scm (kxstitch): New variable.

This looks fine, feel free to proceed!

Thanks,

Mathieu
Christopher Baines wrote 5 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 42876-done@debbugs.gnu.org)
878seex56f.fsf@cbaines.net
Mathieu Othacehe writes:

Toggle quote (6 lines)
> Hello Christopher,
>
>> * gnu/packages/kde-utils.scm (kxstitch): New variable.
>
> This looks fine, feel free to proceed!

Thanks for taking a look, I've pushed this as
f27a7e41568c0ae47b8c9a34c4f7e628e97d6c46 now.

Thanks again,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl85CIlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XerGw/9Hfevu6NXXSywuDQEh6/YotFO2YMYvx2zlHWiEd11voNZEpCQV8e9yYPy
2+IxomcQdXqUQsmSpFRZVp21xbf2RcGskDchpgOyHZSgNA7CF237S9iNLHauWMHd
P6Ad8SbV/zng9KqvIyn7V6Kw5BuyjH7J9ki559VhgusT0GTLQ3TwldQT5NKwouVh
0+ZeWB5MWAsZSq5XpXgeHq10VBSuoh5K2KG4YZqzxxGkHL10oE33b4sGyy8Wy912
GL9K6iKUXQ+TqF3kgxMLLbxRylEurRll4FThXvk/P2GXCHbVz0bh3DNt2XlHk4Vr
xWrO2X5xOGLIWkFyZRT4+0ajsvv+eTi3DQA6hvBg7XGKyPYfCNVLuF4/gV92IZNT
VykvumibWjDqe1F9GkyQpGmbXDy6yZ7XnOEeAxgdrySx7U6Odjrr6PLSyVT3vo/E
KaBucoFKDTmfJ5Z+xmYOHQ6Kw+Je8CC3Yj8mDz0C2g9dkKAL0U6CkA2cot1UPmWq
kk1EKqytaLnIjg2dTvNy7ZXkKOffoBge4z8XtarBFB+QfGERRM790n4Oh+0gLjew
Gt/kh6/I5XO0mU/iX7Rmh0mpnx6lPzomtoyUPar3yvhL5Nc84dxnGxWdVA0XNYBE
HEbn3GX7REgB3CoGxllHmI0KjK5kSkz8ZiQmvJJLOQ5OvsrwmRc=
=CvsJ
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42876@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42876
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help