Jonathan Brielmaier wrote 5 years ago
(name . bug-guix)(address . bug-guix@gnu.org)
When running guix lint with the cve checker I get the following error:
```
guix lint icecat --checkers=cve
fetching CVE database for 2020...view1 [cve]...
Backtrace:
12 (primitive-load "/home/jonathan/.config/guix/current/bi?")
In guix/ui.scm:
2046:12 11 (run-guix-command _ . _)
In srfi/srfi-1.scm:
634:9 10 (for-each #<procedure 7fe83940afc0 at guix/scripts/lin?> ?)
In guix/scripts/lint.scm:
60:4 9 (run-checkers #<package icecat@68.11.0-guix0-preview1 ?> ?)
In srfi/srfi-1.scm:
634:9 8 (for-each #<procedure 7fe83094da20 at guix/scripts/lin?> ?)
In guix/scripts/lint.scm:
69:21 7 (_ _)
In guix/lint.scm:
1110:4 6 (check-vulnerabilities #<package icecat@68.11.0-guix0-?> ?)
1102:9 5 (_ _)
In unknown file:
4 (force #<promise #<procedure 7fe8387c8820 at guix/lint.?>)
In guix/lint.scm:
1085:2 3 (_)
1044:2 2 (call-with-networking-fail-safe _ _ _)
In ice-9/boot-9.scm:
1736:10 1 (with-exception-handler _ _ #:unwind? _ # _)
1669:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1669:16: In procedure raise-exception:
In procedure mkdir: Permission denied
```
I'm on a pretty new guix and I did observe this issue for quite a while:
```
guix describe
guix 697e54b
Repository-URL: https://git.savannah.gnu.org/git/guix.git
Branch: master
Commit: 697e54b2a16575afa9457456fa2a27b0e5895caa
```