problem running xtensa-esp32-elf-g++

DoneSubmitted by Wensheng Xie.
Details
2 participants
  • Wensheng Xie
  • zimoun
Owner
unassigned
Severity
normal
W
W
Wensheng Xie wrote on 12 Aug 2020 05:55
(address . bug-guix@gnu.org)
VI1P190MB0286701C7F9F091F2A4359AAB0420@VI1P190MB0286.EURP190.PROD.OUTLOOK.COM
Dear guix:
I have installed https://github.com/sudomesh/disaster-radiounder guix 1.1.0
```wxie@guix ~/work/disaster-radio/firmware$ pip install -U platformioDefaulting to user installation because normal site-packages is not writeableRequirement already up-to-date: platformio in /home/wxie/.local/lib/python3.8/site-packages (4.3.4)Requirement already satisfied, skipping upgrade: bottle<0.13 in /home/wxie/.local/lib/python3.8/site-packages (from platformio) (0.12.18)Requirement already satisfied, skipping upgrade: click<8,>=5 in /home/wxie/.local/lib/python3.8/site-packages (from platformio) (7.1.2)Requirement already satisfied, skipping upgrade: colorama in /home/wxie/.local/lib/python3.8/site-packages (from platformio) (0.4.3)Requirement already satisfied, skipping upgrade: pyserial!=3.3,<4,>=3 in /home/wxie/.local/lib/python3.8/site-packages (from platformio) (3.4)Requirement already satisfied, skipping upgrade: requests<3,>=2.4.0 in /home/wxie/.local/lib/python3.8/site-packages (from platformio) (2.24.0)Requirement already satisfied, skipping upgrade: semantic_version<3,>=2.8.1 in /home/wxie/.local/lib/python3.8/site-packages (from platformio) (2.8.5)Requirement already satisfied, skipping upgrade: tabulate<1,>=0.8.3 in /home/wxie/.local/lib/python3.8/site-packages (from platformio) (0.8.7)Requirement already satisfied, skipping upgrade: pyelftools<1,>=0.25 in /home/wxie/.local/lib/python3.8/site-packages (from platformio) (0.26)Requirement already satisfied, skipping upgrade: marshmallow>=2 in /home/wxie/.local/lib/python3.8/site-packages (from platformio) (3.7.1)Requirement already satisfied, skipping upgrade: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /home/wxie/.local/lib/python3.8/site-packages (from requests<3,>=2.4.0->platformio) (1.25.10)Requirement already satisfied, skipping upgrade: chardet<4,>=3.0.2 in /home/wxie/.local/lib/python3.8/site-packages (from requests<3,>=2.4.0->platformio) (3.0.4)Requirement already satisfied, skipping upgrade: certifi>=2017.4.17 in /home/wxie/.local/lib/python3.8/site-packages (from requests<3,>=2.4.0->platformio) (2020.6.20)Requirement already satisfied, skipping upgrade: idna<3,>=2.5 in /home/wxie/.local/lib/python3.8/site-packages (from requests<3,>=2.4.0->platformio) (2.10)```
However, somehow the command is not working```Converting main.inosh: /home/wxie/.platformio/packages/toolchain-xtensa32/bin/xtensa-esp32-elf-g++: Datei oder Verzeichnis nicht gefunden*** Error 127```
I checked the file, it exists, but```wxie@guix ~/.platformio/packages/toolchain-xtensa32/bin$ ./xtensa-esp32-elf-gccbash: ./xtensa-esp32-elf-gcc: Datei oder Verzeichnis nicht gefundenwxie@guix ~/.platformio/packages/toolchain-xtensa32/bin$ ./xtensa-esp32-elf-g++bash: ./xtensa-esp32-elf-g++: Datei oder Verzeichnis nicht gefundenwxie@guix ~/.platformio/packages/toolchain-xtensa32/bin$ ./xtensa-esp32-elf-cppbash: ./xtensa-esp32-elf-cpp: Datei oder Verzeichnis nicht gefundenwxie@guix ~/.platformio/packages/toolchain-xtensa32/bin$ sh ./xtensa-esp32-elf-cpp./xtensa-esp32-elf-cpp: ./xtensa-esp32-elf-cpp: Kann die Datei nicht ausführen.wxie@guix ~/.platformio/packages/toolchain-xtensa32/bin$ sh ./xtensa-esp32-elf-g++./xtensa-esp32-elf-g++: ./xtensa-esp32-elf-g++: Kann die Datei nicht ausführen.```
What could be the problem? Does guix support this?
best regards,wxie
Z
Z
zimoun wrote on 5 Jul 11:32 +0200
(name . Wensheng Xie)(address . xiewensheng@hotmail.com)(address . 42819@debbugs.gnu.org)
87im1pksvw.fsf@gmail.com
Hi,
On Wed, 12 Aug 2020 at 11:55, Wensheng Xie <xiewensheng@hotmail.com> wrote:
Toggle quote (3 lines)> I have installed https://github.com/sudomesh/disaster-radiounder guix> 1.1.0
How did you install this package?

Toggle quote (3 lines)> ```> wxie@guix ~/work/disaster-radio/firmware$ pip install -U platformio
This way is not related Guix, IMHO. :-)

Toggle quote (3 lines)> Defaulting to user installation because normal site-packages is not writeable> Requirement already up-to-date: platformio in
[...]
Toggle quote (12 lines)> Requirement already satisfied, skipping upgrade: idna<3,>=2.5 in> /home/wxie/.local/lib/python3.8/site-packages (from> requests<3,>=2.4.0->platformio) (2.10)> ```>> However, somehow the command is not working> ```> Converting main.ino> sh:> /home/wxie/.platformio/packages/toolchain-xtensa32/bin/xtensa-esp32-elf-g++:> Datei oder Verzeichnis nicht gefunden
Which package does provide this ’xtensa-esp32-elf-g++’?

All the best,simon
Z
Z
zimoun wrote on 5 Jul 11:32 +0200
control message for bug #42819
(address . control@debbugs.gnu.org)
87h7h9ksvr.fsf@gmail.com
tags 42819 + moreinfoquit
W
W
Wensheng Xie wrote on 6 Jul 03:34 +0200
Re: bug#42819: problem running xtensa-esp32-elf-g++
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 42819@debbugs.gnu.org)
VI1P190MB0286BB939030A1E1B32037B9B01B9@VI1P190MB0286.EURP190.PROD.OUTLOOK.COM
Hi, Simon:

Thanks for looking into this.
Later, I used another machine with Debian GNU system, and it worked.

The issue can be closed for the moment.
wxie

On 2021/7/5 下午5:32, zimoun wrote:
Toggle quote (34 lines)> Hi,>> On Wed, 12 Aug 2020 at 11:55, Wensheng Xie <xiewensheng@hotmail.com> wrote:>>> I have installed https://github.com/sudomesh/disaster-radio under guix>> 1.1.0> How did you install this package?>>>> ```>> wxie@guix ~/work/disaster-radio/firmware$ pip install -U platformio> This way is not related Guix, IMHO. :-)>>>> Defaulting to user installation because normal site-packages is not writeable>> Requirement already up-to-date: platformio in> [...]>>> Requirement already satisfied, skipping upgrade: idna<3,>=2.5 in>> /home/wxie/.local/lib/python3.8/site-packages (from>> requests<3,>=2.4.0->platformio) (2.10)>> ```>>>> However, somehow the command is not working>> ```>> Converting main.ino>> sh:>> /home/wxie/.platformio/packages/toolchain-xtensa32/bin/xtensa-esp32-elf-g++:>> Datei oder Verzeichnis nicht gefunden> Which package does provide this ’xtensa-esp32-elf-g++’?>>> All the best,> simon
Attachment: OpenPGP_signature
Z
Z
zimoun wrote on 6 Jul 10:32 +0200
(name . Wensheng Xie)(address . xiewensheng@hotmail.com)(address . 42819-done@debbugs.gnu.org)
86v95n3ks2.fsf@gmail.com
Hi,
On Tue, 06 Jul 2021 at 09:34, Wensheng Xie <xiewensheng@hotmail.com> wrote:
Toggle quote (2 lines)> The issue can be closed for the moment.
Thanks. Done.
All the best,simon
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send email to 42819@debbugs.gnu.org