(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
* gnu/packages/photo.scm (darktable): update to 3.2.1.
---
gnu/packages/photo.scm | 29 +++++++++++++++--------------
1 file changed, 15 insertions(+), 14 deletions(-)
Toggle diff (80 lines)
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index abdb751a5a..6be0094a8d 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -465,7 +465,7 @@ photographic equipment.")
(define-public darktable
(package
(name "darktable")
- (version "3.0.2")
+ (version "3.2.1")
(source
(origin
(method url-fetch)
@@ -473,7 +473,7 @@ photographic equipment.")
"https://github.com/darktable-org/darktable/releases/"
"download/release-" version "/darktable-" version ".tar.xz"))
(sha256
- (base32 "1yrnkw8c47kmy2x6m1xp69hwyk02xyc8pd9kvcmyj54lzrhzdfka"))))
+ (base32 "035rvqmw386hm0jpi14lf4dnpr5rjkalzjkyprqh42nwi3m86dkf"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; there are no tests
@@ -482,6 +482,7 @@ photographic equipment.")
(modify-phases %standard-phases
(add-before 'configure 'prepare-build-environment
(lambda* (#:key inputs #:allow-other-keys)
+ ;; Build fails with every version of GCC.
(setenv "CC" "clang") (setenv "CXX" "clang++")
;; Darktable looks for opencl-c.h in the LLVM dir. Guix installs
;; it to the Clang dir. We fix this by patching CMakeLists.txt.
@@ -524,35 +525,35 @@ photographic equipment.")
(inputs
`(("cairo" ,cairo)
("colord-gtk" ,colord-gtk)
- ("cups" ,cups)
+ ("cups" ,cups) ;optional, for printing support
("curl" ,curl)
("dbus-glib" ,dbus-glib)
("exiv2" ,exiv2)
("freeimage" ,freeimage)
- ("gmic" ,gmic)
+ ("gmic" ,gmic) ;optional
("graphicsmagick" ,graphicsmagick)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
("ilmbase" ,ilmbase)
- ("iso-codes" ,iso-codes)
+ ("iso-codes" ,iso-codes) ;optional
("json-glib" ,json-glib)
("lcms" ,lcms)
- ("lensfun" ,lensfun)
- ("libgphoto2" ,libgphoto2)
+ ("lensfun" ,lensfun) ;optional
+ ("libgphoto2" ,libgphoto2) ;optional
("libjpeg" ,libjpeg-turbo)
("libomp" ,libomp)
("libpng" ,libpng)
("librsvg" ,librsvg)
- ("libsecret" ,libsecret)
- ("libsoup" ,libsoup)
+ ("libsecret" ,libsecret) ;optional
+ ("libsoup" ,libsoup) ;optional
("libtiff" ,libtiff)
- ("libwebp" ,libwebp)
- ("libxml2" ,libxml2)
+ ("libwebp" ,libwebp) ;optional, for WebP support
+ ("libxml2" ,libxml2) ;optional, for validation of data/cameras.xml
("libxslt" ,libxslt)
- ("lua" ,lua) ;for plugins
+ ("lua" ,lua) ;optional, for plugins
("openexr" ,openexr)
- ("openjpeg" ,openjpeg)
- ("osm-gps-map" ,osm-gps-map)
+ ("openjpeg" ,openjpeg) ;optional
+ ("osm-gps-map" ,osm-gps-map) ;optional,
("pugixml" ,pugixml)
("python-jsonschema" ,python-jsonschema)
("sqlite" ,sqlite)))
--
2.20.1