make check fails test "tests/packages.scm fold-available-packages with/without cache"

  • Done
  • quality assurance status badge
Details
2 participants
  • jbranso
  • Mathieu Othacehe
Owner
unassigned
Submitted by
jbranso
Severity
normal
J
J
jbranso wrote on 10 Aug 2020 12:07
(address . bug-guix@gnu.org)
f6a42c359f7d88481b6f6aa1dd333c55@dismail.de
Hello,

My recent make check failed the tests/packages.scm
"fold-available-packages with/without cache".

After janneke confirmed that his recent make checked failed the same
test, he encouraged me to submit this bug.

He also showed me how to make a shorter test-suite.log file via
make check TESTS='tests/packages.scm', which is what I'm attaching.

Still the whole test-suite.log file is super long, so here's the main
gist that you ought to see:

test-name: fold-available-packages with/without cache
location: /home/joshua/prog/gnu/guix/guix-src/tests/packages.scm:1309
source:
+ (test-assert
+ "fold-available-packages with/without cache"
+ (let ()
+ (define no-cache
+ (fold-available-packages
+ (lambda* (name version result #:rest rest)
+ (cons (cons* name version rest) result))
+ '()))
+ (define from-cache
+ (call-with-temporary-directory
+ (lambda (cache)
+ (generate-package-cache cache)
+ (mock ((guix describe) current-profile (const cache))
+ (mock ((gnu packages)
+ cache-is-authoritative?
+ (const #t))
+ (fold-available-packages
+ (lambda* (name version result #:rest rest)
+ (cons (cons* name version rest) result))
+ '()))))))
+ (and (equal?
+ (delete-duplicates from-cache)
+ from-cache)
+ (lset= equal? no-cache from-cache))))
actual-value: #f
result: FAIL

Thanks!

Joshua
Attachment: file
Attachment: test-suite.log
M
M
Mathieu Othacehe wrote on 10 Aug 2020 14:41
(name . jbranso--- via Bug reports for GNU Guix)(address . bug-guix@gnu.org)
871rkezn9k.fsf@gnu.org
Hello,

Toggle quote (6 lines)
> He also showed me how to make a shorter test-suite.log file via
> make check TESTS='tests/packages.scm', which is what I'm attaching.
>
> Still the whole test-suite.log file is super long, so here's the main
> gist that you ought to see:

Thanks for the report :)

This should be fixed with 6463578384d9101ca3f0072ca3a19ba7865f4e94.

Mathieu
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42794@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42794
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch