[PATCH] gnu: kdenlive: Update to 20.04.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Michael Rohleder
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20200808181233.13950-1-mike@rohleder.de
* gnu/packages/kde.scm (kdenlive): Update to 20.04.1.
[inputs]: added rttr, qtmultimedia, qtquickcontrols2.
[propagated-inputs]: moved mlt to inputs.
[arguments]: added MLT_PREFIX to wrap-program.
---
This should fix bugs #42217, #38460, #34107.
(needs rttr, patch 42767).

gnu/packages/kde.scm | 23 ++++++++++++++++-------
1 file changed, 16 insertions(+), 7 deletions(-)

Toggle diff (94 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 0ff8fef2b6..9bc753001e 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,6 +41,7 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages boost)
#:use-module (gnu packages code)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
@@ -132,7 +134,7 @@ This package contains GUI widgets for baloo.")
(list license:lgpl2.1+ license:fdl1.2+))))
(define-public kdenlive
- (let ((version "18.08.1"))
+ (let ((version "20.04.1"))
(package
(name "kdenlive")
(version version)
@@ -140,24 +142,25 @@ This package contains GUI widgets for baloo.")
(origin
(method git-fetch)
(uri (git-reference
- (url "git://anongit.kde.org/kdenlive.git")
+ (url "https://anongit.kde.org/kdenlive.git")
(commit (string-append "v" version))))
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0ifnaclsz7w08mc485i3j1kkcpd1m8q5qamckrfwc375ac13xf4g"))))
+ "0n0x34xmcn0k87rqnz0mk462b3al4gq56kn4m00rr428hafscdz7"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("qttools" ,qttools)))
- (propagated-inputs
- `(("mlt" ,mlt)))
(inputs
`(("shared-mime-info" ,shared-mime-info)
("frei0r-plugins" ,frei0r-plugins)
+ ("rttr" ,rttr)
+ ("mlt" ,mlt)
("qtbase" ,qtbase)
("qtscript" ,qtscript)
("qtsvg" ,qtsvg)
+ ("qtmultimedia" ,qtmultimedia)
("kparts" ,kparts)
("knotifications" ,knotifications)
("karchive" ,karchive)
@@ -171,16 +174,19 @@ This package contains GUI widgets for baloo.")
("kdeclarative" ,kdeclarative)
("qtdeclarative" ,qtdeclarative)
("qtquickcontrols" ,qtquickcontrols)
+ ("qtquickcontrols2" ,qtquickcontrols2)
("kiconthemes" ,kiconthemes)
("qtgraphicaleffects" ,qtgraphicaleffects)
("kplotting" ,kplotting)))
(arguments
- `(#:phases
+ `(#:tests? #f ;TODO needs X
+ #:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
+ (qtquickcontrols2 (assoc-ref inputs "qtquickcontrols2"))
(qtbase (assoc-ref inputs "qtbase"))
(qtdeclarative (assoc-ref inputs "qtdeclarative"))
(frei0r (assoc-ref inputs "frei0r-plugins"))
@@ -197,7 +203,10 @@ This package contains GUI widgets for baloo.")
(,(string-append qtbase "/lib/qt5/plugins/platforms")))
`("QML2_IMPORT_PATH" ":" prefix
(,(string-append qtquickcontrols qml)
- ,(string-append qtdeclarative qml)))))
+ ,(string-append qtquickcontrols2 qml)
+ ,(string-append qtdeclarative qml)))
+ `("MLT_PREFIX" ":" =
+ (,(assoc-ref inputs "mlt")))))
#t)))))
(home-page "https://kdenlive.org")
(synopsis "Non-linear video editor")
--
2.28.0
Mathieu Othacehe wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)
87o8nhfqw0.fsf@gnu.org
Hey,

Toggle quote (3 lines)
> This should fix bugs #42217, #38460, #34107.
> (needs rttr, patch 42767).

Nice job! Pushed as a2954e2a44602a5b5d50e11428f18023395fbf1c.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42769@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42769
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help