[PATCH] gnu: add minetest-mineclone.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
20200806132033.19146-1-leo.prikler@student.tugraz.at
* gnu/packages/games.scm (minetest-mineclone): New variable.
---
gnu/packages/games.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9c415bc174..082ae2b364 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3131,6 +3131,30 @@ in different ways.")
(home-page "https://www.minetest.net/")
(license license:lgpl2.1+)))
+(define-public minetest-mineclone
+ (package
+ (name "minetest-mineclone")
+ (version "0.66.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.minetest.land/Wuzzy/MineClone2")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0miszzlzplpvaj0j1yii9867ydr42wsaqa9g6grxdrci75p05g00"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ '(("." "share/minetest/games/mineclone"))))
+ (synopsis "Minecraft clone based on Minetest engine")
+ (description
+ "MineClone is a Minetest subgame, that aims to recreate Minecraft as
+closely as the engine allows.")
+ (home-page "https://content.minetest.net/packages/Wuzzy/mineclone2/")
+ (license license:gpl3+)))
+
(define glkterm
(package
(name "glkterm")
--
2.28.0
Mathieu Othacehe wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 42729-done@debbugs.gnu.org)
87k0yaomli.fsf@gnu.org
Hey,

Toggle quote (2 lines)
> * gnu/packages/games.scm (minetest-mineclone): New variable.

Added your copyright and pushed!

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42729@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42729
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help