* gnu/packages/haskell-xyz.scm (ghc-deferred-folds): New variable.
---
gnu/packages/haskell-xyz.scm | 37 ++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)
Toggle diff (50 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 4d07eb7ea6..1c2f863adf 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2957,6 +2957,43 @@ interfaces common to foreign bindings.")
providing an @code{rnf} implementation.")
(license license:bsd-3)))
+(define-public ghc-deferred-folds
+ (package
+ (name "ghc-deferred-folds")
+ (version "0.9.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/deferred-folds/deferred-folds-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "15lwcc7i7wmi1gkkmak677qw0fnz4a4ldnv842xaimfi64753shv"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-foldl" ,ghc-foldl)
+ ("ghc-hashable" ,ghc-hashable)
+ ("ghc-primitive" ,ghc-primitive)
+ ("ghc-unordered-containers"
+ ,ghc-unordered-containers)
+ ("ghc-vector" ,ghc-vector)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-quickcheck-instances"
+ ,ghc-quickcheck-instances)
+ ("ghc-rerebase" ,ghc-rerebase)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (home-page
+ "https://github.com/metrix-ai/deferred-folds")
+ (synopsis "Abstractions over deferred folds")
+ (description
+ "This library provides abstractions over deferred folds.")
+ (license license:expat)))
+
(define-public ghc-dense-linear-algebra
(package
(name "ghc-dense-linear-algebra")
--
2.28.0