[PATCH] gnu: qtimageformats: fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Michael Rohleder
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)
87ft98drsj.fsf@rohleder.de
nefix reported on IRC that qtimageformats doesnt build.
From 3c74b590d6578bc5a6f9ac84cc8e0339ffee9175 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Fri, 31 Jul 2020 10:11:49 +0200
Subject: [PATCH] gnu: qtimageformats: fix build.

* gnu/packages/qt.scm (qtimageformats): fix build.
---
gnu/packages/qt.scm | 10 ++++++++++
1 file changed, 10 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4b3af757f9..053f744037 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2020 TomZ <tomz@freedommail.ch>
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -712,6 +713,15 @@ HostData=lib/qt5
'(begin
(delete-file-recursively "src/3rdparty")
#t))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments qtsvg)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'fix-build
+ (lambda _ (substitute* "src/plugins/imageformats/jp2/qjp2handler.cpp"
+ (("^#include <jasper/jasper.h>")
+ "#include <jasper/jasper.h>\n#include <QtCore/qmath.h>"))
+ #t))))))
(native-inputs `())
(inputs
`(("jasper" ,jasper)
--
2.28.0
--
some people are so poor that the only
thing they have is money.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl8j0wwACgkQfHr/vv7y
yyW7ewf/Q1P+Czja6vKIw/tQZPr7urkLYkUFknxm7CpIEM74kI5IG6arwg9FpXxA
7dGzwy+3Ho8wuXQtYDsQziJ2+M2GblDfe8mILcM+fOoDw97HwOEPm9c29Q0WpT9N
gZUY3VMqqKznVeWw7qqvLQ+OjRBYCLNKoNaLoqjYg27F596qgcpQcH3WU7zcWzmh
W6xWMB8of2Cj9om8Tn4HH1do29/bEU4N+L87CTS05C4Ifr0F1IpCA3fULw3w+Pry
qIBMCYUu+s+ep94/7XjBBrtxoI59wx1I/B0WBUroXmQ2bkwTlyWg9lLYDkXuv0jN
Em3JPFZbjw8jmZMXGBIQNbBGNR2iCg==
=03Dw
-----END PGP SIGNATURE-----

Mathieu Othacehe wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 42626-done@debbugs.gnu.org)
87wo2iamin.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/qt.scm (qtimageformats): fix build.

Pushed, thanks!

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42626@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42626
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help