Kei Kebreau wrote 5 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
* gnu/packages/maths.scm (wxmaxima): Update to 20.06.6.
[arguments]: Add 'patch-doc-path' phase.
---
gnu/packages/maths.scm | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)
Toggle diff (39 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 3991b2f88b..6f446d9118 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3263,7 +3263,7 @@ point numbers.")
(define-public wxmaxima
(package
(name "wxmaxima")
- (version "20.04.0")
+ (version "20.06.6")
(source
(origin
(method git-fetch)
@@ -3272,7 +3272,7 @@ point numbers.")
(commit (string-append "Version-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0vrjxzfgmjdzm1rgl0crz4b4badl14jwh032y3xkcdvjl5j67lp3"))))
+ (base32 "054f7n5kx75ng5j20rd5q27n9xxk03mrd7sbxyym1lsswzimqh4w"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -3290,6 +3290,14 @@ point numbers.")
`(#:test-target "test"
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-doc-path
+ (lambda _
+ ;; Don't look in share/doc/wxmaxima-xx.xx.x for the
+ ;; documentation. Only licensing information is placed there by
+ ;; Guix.
+ (substitute* "src/Dirstructure.cpp"
+ (("/doc/wxmaxima-\\%s") "/doc/wxmaxima"))
+ #t))
(add-before 'check 'pre-check
(lambda _
;; Tests require a running X server.
--
2.27.0