[PATCH] gnu: python2-setproctitle: fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)
87sgd9e9vh.fsf@rohleder.de
python2-setproctitle fails in test phase, because the "--embed"
parameter should not be used for python-config, but for python3-config,
it seems.
From be8c9241a3dd2d9cf180ec82d787e891731b70e4 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Thu, 30 Jul 2020 09:22:22 +0200
Subject: [PATCH] gnu: python2-setproctitle: fix build.

* gnu/packages/python-xyz.scm (python2-setproctitle): fix build.
---
gnu/packages/python-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0b33fb3a4c..a5c2e60ce4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13529,9 +13529,9 @@ English stemmer.")
(replace 'check
(lambda _
(setenv "PYTHON" (or (which "python3") (which "python")))
- (setenv "PYCONFIG" (string-append (or (which "python3-config")
- (which "python-config"))
- " --embed"))
+ (setenv "PYCONFIG" (if (which "python3-config")
+ "python3-config --embed"
+ "python-config"))
(setenv "CC" "gcc")
;; No need to extend PYTHONPATH to find the built package, since
;; the Makefile will build anyway
--
2.27.0
--
Reality always seems harsher in the early morning.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl8id4IACgkQfHr/vv7y
yyV+IAf/WW8d9ijXF/ih1PF+ol1b9OG02oc9u3x/dBgNm1ZaT8/TKCkxRCEmPLwT
B8M01i83vfnbTB2+eBFEeqaEK4NQ25xtvTWm+u0O54cX6Y+oYgr5y8+ePF9IR600
3a/qY1MqoSOkO6M81fj3TuIozRWnkMdHUoaRsZD7dGXfIzkRdHWPlHJFoIQReWZM
ABnoKkSfe/Tv8NfIH6dY9sfUleBRxh/FotASoTUObbLRZMvVUTwF1XXHykK3rCUC
xj39+ywzF+0Y/LQKL1wE1eDPxEKFI31Wd/oiW2V6pUnwPlr3O6yBCcVwjZaUuD0O
N4uAWV1ac7xdakxY5Yu7xPDobY1KOA==
=ViXY
-----END PGP SIGNATURE-----

Tobias Geerinckx-Rice wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 42616-done@debbugs.gnu.org)
87bljx9uu2.fsf@nckx
Michael Rohleder 写道:
Toggle quote (5 lines)
> python2-setproctitle fails in test phase, because the "--embed"
> parameter should not be used for python-config, but for
> python3-config,
> it seems.

Indeed. Pushed with tweaked commit message as
39386de24439c81f1a7c683ae8c5dd1c5f24e09e.

Thanks!

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXyKcpQAKCRANsP+IT1Vt
eXoFAP9YMxHDwzF6JED4FWhzjUR7m5svzwe+PcQTVFw1e5LLNQD/QxJ5GvVoFHHK
zUIyZ7piGlHWUu55GBH/P6PZfjWHlwI=
=Hkje
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42616@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42616
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help