[PATCH] gnu: Add zeal.

  • Done
  • quality assurance status badge
Details
2 participants
  • Michael Rohleder
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)
873659ftni.fsf@rohleder.de
Not sure if documentation.scm is the right place as it seems to be more
about generating docs not reading, but I don't know a better place.
From 7e5d214e7dbd410d25aa0945566d7a56ec81bf1d Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Thu, 30 Jul 2020 07:29:50 +0200
Subject: [PATCH] gnu: Add zeal.

* gnu/packages/documentation.scm (zeal): New variable.
---
gnu/packages/documentation.scm | 41 +++++++++++++++++++++++++++++++++-
1 file changed, 40 insertions(+), 1 deletion(-)

Toggle diff (77 lines)
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 4708ebcd62..405ebcc1ed 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,19 +33,26 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system qt)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages backup)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages python)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages docbook)
#:use-module (gnu packages flex)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages perl)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages sqlite)
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages xorg))
(define-public asciidoc
(package
@@ -259,3 +267,34 @@ sort, and search the document catalog. It will also be able to communicate
with catalog servers on the Net to search for documents which are not on the
local system.")
(license lgpl2.1+)))
+
+(define-public zeal
+ (package
+ (name "zeal")
+ (version "0.6.1")
+ (home-page "https://github.com/zealdocs/zeal")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05qcjpibakv4ibhxgl5ajbkby3w7bkxsv3nfv2a0kppi1z0f8n8v"))))
+ (build-system qt-build-system)
+ (arguments `(#:tests? #f)) ; no tests
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libarchive" ,libarchive)
+ ("sqlite" ,sqlite)
+ ("qtbase" ,qtbase)
+ ("qtwebkit" ,qtwebkit)
+ ("qtx11extras" ,qtx11extras)
+ ("xcb-util-keyms" ,xcb-util-keysyms)))
+ (synopsis "Offline documentation browser inspired by Dash")
+ (description "Zeal is a simple offline documentation browser
+inspired by Dash.")
+ (license gpl3+)))
--
2.27.0
--
write once - debug everywhere
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl8iXSEACgkQfHr/vv7y
yyXfuQgAslOpKwwmqJtQ38elklgcYHaoT9ZRFpUL/I+dBFFaYL87LZmx3qVI42/x
vU4x31FQzxRG62qYWPnN3cicFXHeov36HW9YfOKj8t2Bt150BXeNdDxfD/seuKZZ
tTwQy1aiz653xbQJDm0puMTwaHZz0VGe9fuTtwvKyBhYHxfb8JfzV+BapVb5u69W
BLztl2cHwES57rZyYy+US9fRQjjy7EHoDrd0Jflz5McaWgp/PJqU3BXttIUwMF6W
w1CIaUP+DqOB0A0zc3p8VV6Zs6kqAHpeMrmpHAKLf+MXZ/2CyNq5bOdTil7QOjIx
qAd3jAbqrlzDy7yHHwSYPxwjZXsUcQ==
=kp/i
-----END PGP SIGNATURE-----

Mathieu Othacehe wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 42613-done@debbugs.gnu.org)
875za2c28e.fsf@gnu.org
Hello Michael,

Toggle quote (2 lines)
> * gnu/packages/documentation.scm (zeal): New variable.

Pushed as 7d456e528b3cd1d89a126b6ae3357de41b74d865.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42613@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42613
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help