(address . bug-guix@gnu.org)
Hello,
Back from holidays, perfect time to fix some Cuirass issues :) The
Cuirass web interface frequently serves 504 errors for all requests,
requiring a service restart on berlin.
Having a look to /var/log/cuirass-web.log it seems that we have indeed
multiple things going wrong.
A first problem is caused by checkout entries pointing to remove
inputs. This should be fix with f71f026a41d8e68e4a7f11ef6e708964594a599c
in Cuirass.
A second issue is caused when a build product download is started, then
aborted. In that case, sendfile throws an exception or enters an endless
loop.
There's a third issue, but the cause is not clear to me:
Toggle snippet (15 lines)
Uncaught exception in fiber ##f:
In ice-9/boot-9.scm:
1736:10 5 (with-exception-handler _ _ #:unwind? _ # _)
In web/server/fiberized.scm:
160:26 4 (_)
In ice-9/suspendable-ports.scm:
83:4 3 (write-bytes #<closed: file 7f3a4ed46310> #vu8(60 33 ?) ?)
In unknown file:
2 (port-write #<closed: file 7f3a4ed46310> #vu8(60 33 # ?) ?)
In ice-9/boot-9.scm:
1669:16 1 (raise-exception _ #:continuable? _)
1669:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1669:16: In procedure raise-exception:
Thanks,
Mathieu