(address . bug-guix@gnu.org)
Hi Guix,
I'm running guix from commit 30aa5dd7e7180d163d409b080bf89e8a15a5ba4d.
I've created a package in local directory lint-test. `guix lint` errors
when processing this package, but other guix commands like build and show
work as expected. A session with these commands:
```
jackhill@alperton ~$ guix lint -L lint-test my-hello
Backtrace:y-hello@2.10 [formatting]...
8 (primitive-load "/home/jackhill/.config/guix/current/bi…")
In guix/ui.scm:
1974:12 7 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1736:10 6 (with-exception-handler _ _ #:unwind? _ # _)
In guix/store.scm:
631:22 5 (thunk)
In srfi/srfi-1.scm:
634:9 4 (for-each #<procedure 7f40c0484020 at guix/scripts/lin…> …)
In guix/scripts/lint.scm:
60:4 3 (run-checkers _ _ #:store _)
In srfi/srfi-1.scm:
634:9 2 (for-each #<procedure 7f40b2ab53f0 at guix/scripts/lin…> …)
241:2 1 (for-each _ _)
In ice-9/boot-9.scm:
1669:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1669:16: In procedure raise-exception:
In procedure for-each: Wrong type argument: #f
jackhill@alperton ~$ guix build -L lint-test my-hello
/gnu/store/h21bncim3hshjpfbs1dn4kvg1ri6zb7z-my-hello-2.10
jackhill@alperton ~$ guix show -L lint-test my-hello
name: my-hello
version: 2.10
outputs: out
systems: x86_64-linux i686-linux
dependencies:
location: lint-test/my-hello.scm:8:2
homepage: https://www.gnu.org/software/hello/
license: GPL 3+
synopsis: Hello, GNU world: An example GNU package
description: GNU Hello prints the message "Hello, world!" and then
+ exits. It serves as an example of standard GNU coding practices. As
+ such, it supports command-line arguments, multiple languages, and so on.
```
my-hello.scm looks like:
```
(define-module (my-hello)
#:use-module (guix build-system gnu)
#:use-module (guix download)
#:use-module (guix licenses)
#:use-module (guix packages))
(define-public my-hello
(package
(name "my-hello")
(version "2.10")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/hello/hello-" version
".tar.gz"))
(sha256
(base32
"0ssi1wpaf7plaswqqjwigppsg5fyh99vdlb9kzl7c9lng89ndq1i"))))
(build-system gnu-build-system)
(synopsis "Hello, GNU world: An example GNU package")
(description
"GNU Hello prints the message \"Hello, world!\" and then exits. It
serves as an example of standard GNU coding practices. As such, it supports
command-line arguments, multiple languages, and so on.")
(home-page "https://www.gnu.org/software/hello/")
(license gpl3+)))
```
Best,
Jack