(address . bug-guix@gnu.org)
Hello,
I stumbled upon this error:
Toggle snippet (73 lines)
$ guix time-machine --commit=897f303d2fa61497a931cf5fcb43349eb5f44c14 -- guix build -S icu4c@62.1
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
La jenaj derivoj estos konstruataj:
/gnu/store/znxvzayw1nfb8z8zky65yz6bgwllyfkp-compute-guix-derivation.drv
/gnu/store/bbh2vbm4f9n8dqc75dkkd4ja4zr5sw8s-module-import.drv
/gnu/store/9xpasxjf8skkwrn5d98cywnjxb3g68xd-config.scm.drv
/gnu/store/m492my56x76vl8xrpkski8ax6x5rbppj-hash.scm.drv
/gnu/store/f661ns6g7xbv293yprics4gxnjgxhh5n-module-import-compiled.drv
building /gnu/store/9xpasxjf8skkwrn5d98cywnjxb3g68xd-config.scm.drv...
building /gnu/store/m492my56x76vl8xrpkski8ax6x5rbppj-hash.scm.drv...
building /gnu/store/bbh2vbm4f9n8dqc75dkkd4ja4zr5sw8s-module-import.drv...
building /gnu/store/f661ns6g7xbv293yprics4gxnjgxhh5n-module-import-compiled.drv...
building /gnu/store/znxvzayw1nfb8z8zky65yz6bgwllyfkp-compute-guix-derivation.drv...
;;; WARNING: loading compiled file /gnu/store/rmsvza0gc8hayx61m54zpbb7rcbrf4zq-module-import-compiled/guix/store.go failed:
;;; In procedure load-thunk-from-memory: incompatible bytecode kind
;;; WARNING: loading compiled file /gnu/store/rmsvza0gc8hayx61m54zpbb7rcbrf4zq-module-import-compiled/guix/utils.go failed:
;;; In procedure load-thunk-from-memory: incompatible bytecode kind
;;; WARNING: loading compiled file /gnu/store/rmsvza0gc8hayx61m54zpbb7rcbrf4zq-module-import-compiled/guix/config.go failed:
;;; In procedure load-thunk-from-memory: incompatible bytecode kind
;;; WARNING: loading compiled file /gnu/store/rmsvza0gc8hayx61m54zpbb7rcbrf4zq-module-import-compiled/guix/memoization.go failed:
;;; In procedure load-thunk-from-memory: incompatible bytecode kind
;;; WARNING: loading compiled file /gnu/store/rmsvza0gc8hayx61m54zpbb7rcbrf4zq-module-import-compiled/guix/profiling.go failed:
[…]
;;; WARNING: loading compiled file /gnu/store/rmsvza0gc8hayx61m54zpbb7rcbrf4zq-module-import-compiled/guix/build/compile.go failed:
;;; In procedure load-thunk-from-memory: incompatible bytecode kind
Backtrace:
In ice-9/boot-9.scm:
222:29 19 (map1 _)
222:29 18 (map1 _)
222:29 17 (map1 (((guix packages)) ((guix sets)) ((guix #)) (…) …))
222:29 16 (map1 (((guix sets)) ((guix modules)) ((guix # #) # …) …))
222:29 15 (map1 (((guix modules)) ((guix build utils) # (#)) (…) …))
222:29 14 (map1 (((guix build utils) #:select (find-files)) (…) …))
222:17 13 (map1 (((guix build compile) #:select (#)) ((srfi #)) …))
3297:17 12 (resolve-interface (guix build compile) #:select _ # _ # …)
In ice-9/threads.scm:
390:8 11 (_ _)
In ice-9/boot-9.scm:
3223:13 10 (_)
In ice-9/threads.scm:
390:8 9 (_ _)
In ice-9/boot-9.scm:
3507:20 8 (_)
2806:4 7 (save-module-excursion #<procedure 7f5972fba0f0 at ice-…>)
3527:26 6 (_)
In unknown file:
5 (primitive-load-path "guix/build/compile" #<procedure 7…>)
In ice-9/eval.scm:
626:19 4 (_ #<directory (guix build compile) 7f5971e90780>)
159:9 3 (_ #<directory (guix build compile) 7f5971e90780>)
182:19 2 (proc #<directory (guix build compile) 7f5971e90780>)
142:16 1 (compile-top-call #<directory (guix build compile) 7f5…> …)
In unknown file:
0 (%resolve-variable (7 . #) #<directory (guix build comp…>)
ERROR: In procedure %resolve-variable:
Unbound variable: tree-il-default-optimization-options
guix time-machine: error: You found a bug: the program '/gnu/store/cxf0z06wqbj43cmxishycj0k6s0694d9-compute-guix-derivation'
failed to compute the derivation for Guix (version: "897f303d2fa61497a931cf5fcb43349eb5f44c14"; system: "x86_64-linux";
host version: "cd0c4268d74e58fcfe9c729183d90665f4abbb09"; pull-version: 1).
Please report it by email to <bug-guix@gnu.org>.
$ guix describe
Generacio 151 Jul 20 2020 11:16:29 (nuna)
guix cd0c426
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: cd0c4268d74e58fcfe9c729183d90665f4abbb09
In that 2018 commit, (guix build compile) looks like this:
Toggle snippet (23 lines)
(define-module (guix build compile)
#:use-module (ice-9 match)
#:use-module (ice-9 format)
#:use-module (ice-9 threads)
#:use-module (system base target)
#:use-module (system base compile)
#:use-module (system base message)
#:use-module (guix modules)
#:use-module (guix build utils)
#:export (%default-optimizations
%lightweight-optimizations
compile-files))
;; [...]
(define %default-optimizations
;; Default optimization options (equivalent to -O2 on Guile 2.2).
(cond-expand
(guile-2.2 (append (tree-il-default-optimization-options)
(cps-default-optimization-options)))
(else '())))
Ludo’.