[PATCH] gnu: Add bashtop.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)
87y2n95jji.fsf@rohleder.de
From cb46f6e74595c7d0df29ffd3431a7cce59e39cfd Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Fri, 24 Jul 2020 11:48:02 +0200
Subject: [PATCH] gnu: Add bashtop.

* gnu/packages/admin.scm (bashtop): New variable.
---
gnu/packages/admin.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c0e7831d5b..033d80e42b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -528,6 +528,30 @@ or via the @code{facter} Ruby library.")
application (for console or X terminals) and requires ncurses.")
(license license:gpl2)))
+(define-public bashtop
+ (package
+ (name "bashtop")
+ (version "0.9.25")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aristocratos/bashtop")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07nlr6vmyb7yihaxj1fp424lmhwkdjl6mls92v90f6gsvikpa13v"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (list (string-append "PREFIX=" %output))
+ #:tests? #f ; bats test fails with loading load.bash
+ #:phases (modify-phases %standard-phases (delete 'configure))))
+ (home-page "https://github.com/aristocratos/bashtop")
+ (synopsis "Linux/OSX/FreeBSD resource monitor")
+ (description "Resource monitor that shows usage and stats for processor,
+memory, disks, network and processes.")
+ (license license:asl2.0)))
+
(define-public pies
(package
(name "pies")
--
2.27.0
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl8artEACgkQfHr/vv7y
yyVQ1wf/RDGcgjc0vSlMx95dElk7e3gJRi4C1c5hx6aYFpMSkufeud/YgJNuMSPX
XYmdlRmpo3T7j9Y4ijaNFzLWfh+M262U9y4IjN++cg/PeaVUzkxxjiOACbcuRQvI
NiYpeO3hcZH4XMRf1OX21yyJti6p1vp+EwlpvlViCdxZcZK9LAg/mSN1bDS2Omrf
03DM5lVZWjQQmKJFa7YTpm36riCSuXIpHpoU5PJdhYRnIX7Z0CKET4aKHOqlycwg
8D69iVd+FQcFMLjDMNy+UQtk9XrOaxj3QrGeXQ57sQzQLkbj9NiUcolXqbicvuF+
37dsuP0+lWn0QqqUiN5AJTVM/UEUEg==
=mhCz
-----END PGP SIGNATURE-----

宋文武 wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 42514-done@debbugs.gnu.org)
87v9ict53r.fsf@member.fsf.org
Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (6 lines)
> From cb46f6e74595c7d0df29ffd3431a7cce59e39cfd Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Fri, 24 Jul 2020 11:48:02 +0200
> Subject: [PATCH] gnu: Add bashtop.
>

Applied, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42514@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42514
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help