[PATCH] gnu: newsboat: Update to 2.20.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Jakub K?dzio?ka
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 22 Jul 2020 20:09
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20200722180916.29315-1-efraim@flashner.co.il
* gnu/packages/syndication.scm (newsboat): Update to 2.20.1.
[source]: Add snippet to loosen version requirement on crate dependency.
[build-system]: Switch to cargo-build-system.
[native-inputs]: Remove asciidoc, add openssl, asciidoctor.
[arguments]: Add gnu-build-system module. Add vendor-dir, cargo-inputs,
cargo-development-inputs fields. Don't delete 'configure phase. Add
custom 'dont-vendor-self-phase. Replace 'build, 'check, 'install phases
with gnu counterparts.
(newsboat-2.13): New variable.
---

This is the patch from when I recorded some of my package updating on
Guix. I'm sending it to guix-patches instead of just pushing it because
I wanted to make sure I did the right thing with the variable names.

---
gnu/packages/syndication.scm | 110 ++++++++++++++++++++++++++++++-----
1 file changed, 97 insertions(+), 13 deletions(-)

Toggle diff (168 lines)
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 3d858240b7..b8665fb9c3 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -22,11 +22,13 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix download)
#:use-module (guix packages)
+ #:use-module (guix build-system cargo)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages check)
+ #:use-module (gnu packages crates-io)
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
#:use-module (gnu packages gettext)
@@ -40,15 +42,18 @@
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages python-web)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages sqlite)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages xml)
+ #:use-module (srfi srfi-1))
(define-public newsboat
(package
(name "newsboat")
- (version "2.13")
+ (version "2.20.1")
(source
(origin
(method url-fetch)
@@ -56,13 +61,20 @@
"/newsboat-" version ".tar.xz"))
(sha256
(base32
- "0pik1d98ydzqi6055vdbkjg5krwifbk2hy2f5jp5p1wcy2s16dn7"))))
- (build-system gnu-build-system)
+ "0rimjikni96m52vhymgsg1b9g99af6ggyzd1lpvhgqsznxwj0y42"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "rust/libnewsboat/Cargo.toml"
+ (("= 1.0.17") "1.0.17"))
+ #t))))
+ (build-system cargo-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
+ ("openssl" ,openssl)
("pkg-config" ,pkg-config)
;; For building documentation.
- ("asciidoc" ,asciidoc)))
+ ("asciidoctor" ,ruby-asciidoctor)))
(inputs
`(("curl" ,curl)
("json-c" ,json-c-0.13)
@@ -71,15 +83,58 @@
("stfl" ,stfl)
("sqlite" ,sqlite)))
(arguments
- '(#:phases
+ `(#:modules ((guix build cargo-build-system)
+ (guix build utils)
+ ((guix build gnu-build-system) #:prefix gnu:))
+ #:vendor-dir "vendor"
+ #:cargo-inputs
+ (("rust-backtrace" ,rust-backtrace-0.3)
+ ("rust-bitflags" ,rust-bitflags-1)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-curl-sys" ,rust-curl-sys-0.4)
+ ("rust-dirs" ,rust-dirs-2.0)
+ ("rust-gettext-rs" ,rust-gettext-rs-0.4)
+ ("rust-gettext-sys" ,rust-gettext-sys-0.19)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-libz-sys" ,rust-libz-sys-1.0)
+ ("rust-natord" ,rust-natord-1.0)
+ ("rust-nom" ,rust-nom-5)
+ ("rust-once-cell" ,rust-once-cell-1.2)
+ ("rust-percent-encoding" ,rust-percent-encoding-2.1)
+ ("rust-rand" ,rust-rand-0.6)
+ ("rust-smallvec" ,rust-smallvec-0.6)
+ ("rust-url" ,rust-url-2.1)
+ ("rust-unicode-width" ,rust-unicode-width-0.1)
+ ("rust-xdg" ,rust-xdg-2.2))
+ #:cargo-development-inputs
+ (("rust-tempfile" ,rust-tempfile-3)
+ ("rust-proptest" ,rust-proptest-0.9)
+ ("rust-section-testing" ,rust-section-testing-0.0))
+ #:phases
(modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (add-after 'build 'build-documentation
- (lambda _
- (invoke "make" "doc"))))
- #:make-flags
- (list (string-append "prefix=" (assoc-ref %outputs "out")))
- #:test-target "test"))
+ (add-after 'configure 'dont-vendor-self
+ (lambda* (#:key vendor-dir #:allow-other-keys)
+ ;; Don't keep the whole tarball in the vendor directory
+ (delete-file-recursively
+ (string-append vendor-dir "/" ,name "-" ,version ".tar.xz"))
+ #t))
+ (replace 'build
+ (lambda* args
+ ((assoc-ref gnu:%standard-phases 'build)
+ #:make-flags
+ (list (string-append "prefix=" (assoc-ref %outputs "out"))))))
+ (replace 'check
+ (lambda* args
+ ((assoc-ref gnu:%standard-phases 'check)
+ #:test-target "test"
+ #:make-flags
+ (list (string-append "prefix=" (assoc-ref %outputs "out"))))))
+ (replace 'install
+ (lambda* args
+ ((assoc-ref gnu:%standard-phases 'install)
+ #:make-flags
+ (list (string-append "prefix=" (assoc-ref %outputs "out")))))))))
(native-search-paths
;; Newsboat respects CURL_CA_BUNDLE.
(package-native-search-paths curl))
@@ -96,6 +151,35 @@ file system, and many more features.")
(license (list license:gpl2+ ; filter/*
license:expat)))) ; everything else
+(define-public newsboat-2.13
+ (package
+ (inherit newsboat)
+ (version "2.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://newsboat.org/releases/" version
+ "/newsboat-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0pik1d98ydzqi6055vdbkjg5krwifbk2hy2f5jp5p1wcy2s16dn7"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(,@(fold alist-delete (package-native-inputs newsboat)
+ '("asciidoctor" "openssl"))
+ ;; For building documentation.
+ ("asciidoc" ,asciidoc)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (add-after 'build 'build-documentation
+ (lambda _
+ (invoke "make" "doc"))))
+ #:make-flags
+ (list (string-append "prefix=" (assoc-ref %outputs "out")))
+ #:test-target "test"))))
+
(define-public liferea
(package
(name "liferea")
--
2.27.0
J
J
Jakub K?dzio?ka wrote on 23 Jul 2020 13:49
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 42477@debbugs.gnu.org)
20200723114959.mz4yykzt3kcfwazk@gravity
On Wed, Jul 22, 2020 at 09:09:16PM +0300, Efraim Flashner wrote:
Toggle quote (10 lines)
> * gnu/packages/syndication.scm (newsboat): Update to 2.20.1.
> [source]: Add snippet to loosen version requirement on crate dependency.
> [build-system]: Switch to cargo-build-system.
> [native-inputs]: Remove asciidoc, add openssl, asciidoctor.
> [arguments]: Add gnu-build-system module. Add vendor-dir, cargo-inputs,
> cargo-development-inputs fields. Don't delete 'configure phase. Add
> custom 'dont-vendor-self-phase. Replace 'build, 'check, 'install phases
> with gnu counterparts.
> (newsboat-2.13): New variable.

Efraim,

I can't help but wonder - what's the motivation here for keeping the
older version around? I think a comment above the definition would be
nice.

Regards,
Jakub K?dzio?ka
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl8ZeWYACgkQ4xWnWEYT
FWT7jw//Z3dkJnCtgYoIzituOdtW10Z/JRldA79G7uE8rLyOBlukP+yJV3mfNfvY
fh/y57eERB0HHad6EdNGIhbRU/Dfr3LuXF7Hi0qcIhKOhSLWjHrSeBmCp6Qd3daj
+FlMgdAcVjSG5oU2vGJXVZGHMCbqO+pl+doRi7NwwhlSWi5FiZP9XrBE2vOJwck+
envEHXc4X1rlqxgMylqB4vyvUcnKEV0bnIOWV50dW/lpHxGt+H9X8ojywyff9Jzo
ZAyBpZjr3Tf2sZgze2EDH3IP4vhDeVQ6LqQ0J952wG2rJB76oHKjx4vyFb/MImqH
HXvJI7xNAK0z/fHSjjU8f0JvBnr4srY5U83GOQznqgpTq3wNkwTUlGXw73ROgDB6
WM6JhQbuMz0cZrlONvT9crUTSI4Ttj9w8qKO3FDfr3ZrQAUWiq7ihvyKCmpggwhY
lAi2q3huWjOUNyiEgzeFBvXsk7O77wzMVFdy8cfS7R/jS0XZ8KrifwK9RxqJoENy
RUfwOYJKzwMps1Z2i/7Sjp9UNKjux6csiEa92xVLDta2R/plyclz7dPbKBqqy73T
1Q1ZL5eeyX7vqgKMKpW6lpXA5mp3+UX944h7Y3IKLbEjpCLZ1bkbqnP937dO+b/h
litpZzsOQRHQ3I6v/06yFf0TUibORystPpb20jWsZkc712Ogfu4=
=dR3m
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 23 Jul 2020 13:59
(name . Jakub K?dzio?ka)(address . kuba@kadziolka.net)(address . 42477@debbugs.gnu.org)
20200723115925.GH3039@E5400
On Thu, Jul 23, 2020 at 01:49:59PM +0200, Jakub K?dzio?ka wrote:
Toggle quote (17 lines)
> On Wed, Jul 22, 2020 at 09:09:16PM +0300, Efraim Flashner wrote:
> > * gnu/packages/syndication.scm (newsboat): Update to 2.20.1.
> > [source]: Add snippet to loosen version requirement on crate dependency.
> > [build-system]: Switch to cargo-build-system.
> > [native-inputs]: Remove asciidoc, add openssl, asciidoctor.
> > [arguments]: Add gnu-build-system module. Add vendor-dir, cargo-inputs,
> > cargo-development-inputs fields. Don't delete 'configure phase. Add
> > custom 'dont-vendor-self-phase. Replace 'build, 'check, 'install phases
> > with gnu counterparts.
> > (newsboat-2.13): New variable.
>
> Efraim,
>
> I can't help but wonder - what's the motivation here for keeping the
> older version around? I think a comment above the definition would be
> nice.

The older one is the last version that builds without rust. I can add a
comment about why it's still there.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8Ze5oACgkQQarn3Mo9
g1EPeBAAuktiq3SmH7IYIWk/yBYw2s8+lboBAvydrBl6Eh8icr2jWqNLmkw1FnhY
CisWdn+GBQnJCGrITyQ6FTxqmDEG76prIOT3meArZ/Lxtlgoxc+QmlwIPsfXx6ei
OOvwZUQzxlTXXcYAvDjyLIIpQVdM4IysEXAZu+JGhZOp2gmdRnr6FXDueJClRWGV
j4dxz4w5KaFUc+jn6HSosQfrs4igbU3ibB7tqggf2dB/412U6WzReeCn2v2TSaVP
heHwmLk5QluLPEwg6NdJHDv70NT0YrJTvM5Ilv2FZJz4IDKhwaNzme/ISNsY8zbh
ONBhF2UkBWEAoDZTiw3Vq0IiZTFk33AUZAPLhfqIJjI/lqtBWSdBiNew11B2tQ9J
PuMk1VWh2FlGGTrcmIAIUWwCaAI31jraaNgTL9Bp9bncNRnIJzRBXIE1VeDtf9H5
59Cn3lF4fkH0Hs4A+Dl5t/jXbICPjS5jrwedtF3/Dpm4WjfnKrHEGYZ624Wn56t6
HABV6ZVf5B8y6bIdDPel5g8Mz3b+AA1JdQRX9VpvKj1WYhVSWy868+Ju3nw4QIRK
gctoJRF1j1vfQ2zYfpl7v+Job8eoA3hOFO7rCykjgl/obmJzdAmbvPudnFmnriS4
jdxziCuuJcabQ0Z6YnxvpQ6cH73n9kHD3Ho8vbXdp70mjVqdTz4=
=d2R2
-----END PGP SIGNATURE-----


J
J
Jakub K?dzio?ka wrote on 23 Jul 2020 15:19
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 42477@debbugs.gnu.org)
20200723131924.vqlwagsafvjqwt3l@gravity
On Thu, Jul 23, 2020 at 02:59:25PM +0300, Efraim Flashner wrote:
Toggle quote (21 lines)
> On Thu, Jul 23, 2020 at 01:49:59PM +0200, Jakub K?dzio?ka wrote:
> > On Wed, Jul 22, 2020 at 09:09:16PM +0300, Efraim Flashner wrote:
> > > * gnu/packages/syndication.scm (newsboat): Update to 2.20.1.
> > > [source]: Add snippet to loosen version requirement on crate dependency.
> > > [build-system]: Switch to cargo-build-system.
> > > [native-inputs]: Remove asciidoc, add openssl, asciidoctor.
> > > [arguments]: Add gnu-build-system module. Add vendor-dir, cargo-inputs,
> > > cargo-development-inputs fields. Don't delete 'configure phase. Add
> > > custom 'dont-vendor-self-phase. Replace 'build, 'check, 'install phases
> > > with gnu counterparts.
> > > (newsboat-2.13): New variable.
> >
> > Efraim,
> >
> > I can't help but wonder - what's the motivation here for keeping the
> > older version around? I think a comment above the definition would be
> > nice.
>
> The older one is the last version that builds without rust. I can add a
> comment about why it's still there.

I gathered as much. I don't understand, though, why a rust-less version
is valuable.

Regards,
Jakub K?dzio?ka
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl8ZjlsACgkQ4xWnWEYT
FWS1+Q//ZSdz5brRJ1ajlhlKLxWH8HXJSrCEtQikKWDMvaM4LUlid8lZwCSorgS+
KstWF/htCZ+4QG+VDIRN+pRvxh3P89nmD17ZuSCYjiugTnPECyAEpyIRmeRR1HXQ
2GSO35ed14xQrQ99lhjdpVmTL+bMM+6cDUWIXAMmIHNuvrv+8JR5P1wOEPXjBwIr
2CHJgOUiHE2D/5WGUruHO7mdZVhmM02To1Q682logDxi/NxULVkvL2GndSdhCNqb
dR6yObMvUBpEVG3fGxvboXFQqeHpyd30lzIw7tgkMB9+3JMCp0EkOCoE+NNxbYPs
Qx+RwzNSPipnrJtGjk97p/gLeXwRuP49uIhkXb6wtuGVnCIZ6DE9hda0dDbKd4xQ
Q6qdvjqKlmoB42RxE6ItHPSpWM/B1W+Itv+EY+Tnkn+ZIXdfGfSVgZI29TTRIG6s
9MU6VaO/27lYnaIs1xvTBzy8fEKBiGUL+aPDMt3BLgYT+o6Si1qqdZ19Dtqo+YiE
YpkIs4b57Km8GavGI8/+aLxWNtfednfUPUNPIfL7OAJJ7Q0WhC+SvJgAy0UfrEPY
D9mTNLGVUOM3zuJkJiTyX0R31DEzSzatk4j11w+hkgtyxQOkpNw5HMeiaWBPUhVc
8cjOxSVURyNaY/AVAd/9aU5RZlctMLjCw1tiOdUchxzPjRCB+jc=
=8c0K
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 23 Jul 2020 16:26
(name . Jakub K?dzio?ka)(address . kuba@kadziolka.net)(address . 42477@debbugs.gnu.org)
20200723142639.GI3039@E5400
On Thu, Jul 23, 2020 at 03:19:24PM +0200, Jakub K?dzio?ka wrote:
Toggle quote (16 lines)
> On Thu, Jul 23, 2020 at 02:59:25PM +0300, Efraim Flashner wrote:
> > On Thu, Jul 23, 2020 at 01:49:59PM +0200, Jakub K?dzio?ka wrote:
> > >
> > > Efraim,
> > >
> > > I can't help but wonder - what's the motivation here for keeping the
> > > older version around? I think a comment above the definition would be
> > > nice.
> >
> > The older one is the last version that builds without rust. I can add a
> > comment about why it's still there.
>
> I gathered as much. I don't understand, though, why a rust-less version
> is valuable.
>

Oh, that's because there are architectures where rust either doesn't
build (like i686-linux) or it builds incredibly slowly (aarch64).


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8ZnhsACgkQQarn3Mo9
g1FPcBAAjInTxHnEVnSMddNgflAk4BUleN6U/258kxa/Obt/BmUp8Nf0yw3wl1Yb
sBZgkvHorOpnbQ6HxdVe7hsYN5Kssp1bUBi19Pdl3C2cf4uHd28DHse1k0ebr5eJ
V2neuDiknLs3gxfleJkrW1aMavYrk2g6U4jQCYiNeOcw0uR8CBmgiDjL7NgS3ZaE
GV4xnya3T8HFbMLC17qD1lmM0fB9CgqUgYFKdcwnePVlTcoBKMq+zHyzH43OFQON
i/IgFfQ3Urhez4DaMbRPkaVo3BohimvXctvOqj+jUA/U2vE+JiH3qh4bXCvfoqbT
fVokwjylttIIzZkS7+KaHx8ZAdjr6e8sem+yN/X3sM34sp00TRX56s/iB32EYxxR
k0+MTPWZ9wC7mygy/nSQ6kepsDOZtdC086ar7FHu6/P46wkFQpA7I4VPSrnMzjGc
DqH+FwZcp41TfNOjCkrcewZIxHNdQyvCpXT2IZtC21x+66AsZbZADQaiBPCTgipv
tYEdeWibjRtYVRkw+SMr5h9g0fzzEbxFwwE+JZ+CaZEbhVcPJ+QL1CaECFHG+jFm
5BVnkbkmre685HjwFYrfUROv7w1LeRB9408su0FJQyeC6jaJjnqNoKgj2JaWcY5Q
ahp0UZyRULUtmSY1LHMwR7FEVMaEwy/n0Rl8U4r7F+LMCzgTi3I=
=2Naj
-----END PGP SIGNATURE-----


J
J
Jakub K?dzio?ka wrote on 23 Jul 2020 20:17
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 42477@debbugs.gnu.org)
20200723181733.xmofd7hhw734co7y@gravity
On Thu, Jul 23, 2020 at 05:26:39PM +0300, Efraim Flashner wrote:
Toggle quote (20 lines)
> On Thu, Jul 23, 2020 at 03:19:24PM +0200, Jakub K?dzio?ka wrote:
> > On Thu, Jul 23, 2020 at 02:59:25PM +0300, Efraim Flashner wrote:
> > > On Thu, Jul 23, 2020 at 01:49:59PM +0200, Jakub K?dzio?ka wrote:
> > > >
> > > > Efraim,
> > > >
> > > > I can't help but wonder - what's the motivation here for keeping the
> > > > older version around? I think a comment above the definition would be
> > > > nice.
> > >
> > > The older one is the last version that builds without rust. I can add a
> > > comment about why it's still there.
> >
> > I gathered as much. I don't understand, though, why a rust-less version
> > is valuable.
> >
>
> Oh, that's because there are architectures where rust either doesn't
> build (like i686-linux) or it builds incredibly slowly (aarch64).

Ah, okay then! For some reason I totally forgot to consider non-x64. I
will try to improve this situation, but in the meantime it's indeed a
good idea.

Regards,
Jakub K?dzio?ka
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl8Z1D0ACgkQ4xWnWEYT
FWQJFg//RyIKvkvwgWsdvmXN7dU8FDn7Xpcy5tRw4M+wgURjccxeRsCCB63HrqdT
p7bMnKswEb0QVPfCwh7EfatCxplgcBqINlqUdmNe8/DewvhyD5YnjSVY9MeUdYDn
VMS5CHIwL5QisPP+mrXfJmIxxPrvs4OdxHE0K0CmCtiWrhkfDtCvqsDzxY126aAY
iyHGvMWqDsI+ck/5FIbaj+rzmqqfkF6cSl1lsk0aTeKf/c8Va0enZsngef2sbtUW
VkzZUrKfakC4Pmf03kATCfM2c8x+NS6sbT6VAjFcoTMBueRshJqyfVl2pPrbDb4F
uo6u+ZyhbVa9WbzWMkAXYM585+3rd8Anlw6K/zkOR9gTw9UatFBZvVfZ6X2M49iP
wsW+41wYL+HihGtpM9+xH45K2ebNjyut4FBElGFLWfOdNdDAt14MsMo9L9ju7Dqo
2YTknIrt85Tuu/h43ZVqGkGLyVQbmTYF4ifTI3zr1ViDIqmq+BxGMaWqjpEB3FB7
qmo8O0qiAp5fxrfpzZphxts1uBlEq94Wn6QrdJLmocS9/wYKOBGmcpZUUM7TR91e
pF/EL953yglVDUipZ9pr5ezL3A9UptDvr8iXX9kM/t9hzYVM3pj5LJKnj4kZc/7O
cGBaiTprfm2+84+4kdldunLsFQEOzu0dsSJm2wJIyk+fwwqO7Mk=
=nR1m
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 26 Jul 2020 18:21
(name . Jakub K?dzio?ka)(address . kuba@kadziolka.net)(address . 42477-done@debbugs.gnu.org)
20200726162154.GC1051@E5400
On Thu, Jul 23, 2020 at 08:17:33PM +0200, Jakub K?dzio?ka wrote:
Toggle quote (26 lines)
> On Thu, Jul 23, 2020 at 05:26:39PM +0300, Efraim Flashner wrote:
> > On Thu, Jul 23, 2020 at 03:19:24PM +0200, Jakub K?dzio?ka wrote:
> > > On Thu, Jul 23, 2020 at 02:59:25PM +0300, Efraim Flashner wrote:
> > > > On Thu, Jul 23, 2020 at 01:49:59PM +0200, Jakub K?dzio?ka wrote:
> > > > >
> > > > > Efraim,
> > > > >
> > > > > I can't help but wonder - what's the motivation here for keeping the
> > > > > older version around? I think a comment above the definition would be
> > > > > nice.
> > > >
> > > > The older one is the last version that builds without rust. I can add a
> > > > comment about why it's still there.
> > >
> > > I gathered as much. I don't understand, though, why a rust-less version
> > > is valuable.
> > >
> >
> > Oh, that's because there are architectures where rust either doesn't
> > build (like i686-linux) or it builds incredibly slowly (aarch64).
>
> Ah, okay then! For some reason I totally forgot to consider non-x64. I
> will try to improve this situation, but in the meantime it's indeed a
> good idea.
>

Ok. Patch pushed!


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8draEACgkQQarn3Mo9
g1HCWg/+MWBnVv07x7sjecxXOM4YR7mXLi9T/llbe/Bsq9zuikKS5VmiBr7+eysT
cG9j/vV02IU19q0CEeFtLDoGZiuyzG8gfrZERG69DivfFMiNMdf+aH4R/U6m8pEL
gO29oW6ndQYOYbO0ooeoVdIhfvQ6lKv1zvq6Q0wHCwZkEjVqLpzuNMuWtM8CTPCZ
PtwadPIx4ELc/xqlZOB7GVzeNJh7kjFZdx0SHAx6rYlaYUpTqt3XiCtQ0vBM5J4i
XprCxBx7nHBf8ewevd8ssvNR4EyBSx4U3zBFUZcZwY25jRqgNPyn4aHFZID/Lk++
59dqNrqjXrOaCbP0kOmPb0RXVnQCvEoLdq+GJUwnAUhoJObaf+L+osSBFRqtad9j
JrrSMBXUOKodOIGJ/PMBGDddpxVQgGCKdwcos10jVoa9ehDU6kEb0a6YGVQne1aJ
p4ab+KUM4bHRw8Cv03pjw9CeTG5JhXwQ1G3ZXi4e/Khb35xdxdPylbeLEjDFPBjz
PIaYNtTbjIAumFYyzO1yuZgBDP7al4aEb3TAuFj6ScTrvonmp6dHz4fXN/2nTeeI
ZYNcGV50iJhSBY6DOjNF/azm6seeJO+J8lCD1/+Bdcxcrl+aQq7kTfNgEptY78DC
VaxIN2VwRQLsotbx21aEMobU90FfnubvSPt2Iu11qtjBZ8NUhcE=
=EQ1h
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42477@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42477
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch