(address . guix-patches@gnu.org)
- Jon 21 Jul 2020 08:26
- Jon 21 Jul 2020 08:28
- Jon 21 Jul 2020 08:29
- Mon 25 Jul 2020 17:31
- Jon 28 Jul 2020 03:57
- Jon 29 Jul 2020 03:23
[PATCH 0/2] gnu: vlc: add support for MIDI and chiptunes
J
[PATCH 1/2] gnu: vlc: Add support for MIDI files
(address . 42460@debbugs.gnu.org)
d3feff06-baa1-53bf-3502-df72516c7f3f@gmail.com
* gnu/packages/video.scm (vlc): add MIDI support with FluidSynth
[inputs]: Add FluidSynth.
[arguments]: Pass "--enable-fluidsynth" to configure
---
gnu/packages/video.scm | 2 ++
1 file changed, 2 insertions(+)
Toggle diff (22 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4120174484..a4e097e9a2 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1249,6 +1249,7 @@ videoformats depend on the configuration flags of
ffmpeg.")
("dbus" ,dbus)
("eudev" ,eudev)
("flac" ,flac)
+ ("fluidsynth" ,fluidsynth)
("ffmpeg" ,ffmpeg)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
@@ -1319,6 +1320,7 @@ videoformats depend on the configuration flags of
ffmpeg.")
(arguments
`(#:configure-flags
`("BUILDCC=gcc"
+ "--enable-fluidsynth"
,(string-append "LDFLAGS=-Wl,-rpath -Wl,"
(assoc-ref %build-inputs "ffmpeg")
"/lib")) ;needed for the tests
J
[PATCH 2/2] gnu: vlc: Add support for gme.
(address . 42460@debbugs.gnu.org)
aa0baa7d-2503-f10f-0477-c8c66726f8cc@gmail.com
* gnu/packages/video.scm: vlc (inputs): Add libgme.
---
gnu/packages/video.scm | 4 ++++
1 file changed, 4 insertions(+)
Toggle diff (38 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index a4e097e9a2..6b57d384e1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -131,6 +132,7 @@
#:use-module (gnu packages markup)
#:use-module (gnu packages maths)
#:use-module (gnu packages mp3)
+ #:use-module (gnu packages music)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages networking)
#:use-module (gnu packages ocr)
@@ -1268,6 +1270,7 @@ videoformats depend on the configuration flags of
ffmpeg.")
("libdvdread" ,libdvdread)
("libebml" ,libebml)
("libgcrypt" ,libgcrypt)
+ ("libgme" ,libgme)
("libidn" ,libidn)
("libkate" ,libkate)
("libmad" ,libmad)
@@ -1321,6 +1324,7 @@ videoformats depend on the configuration flags of
ffmpeg.")
`(#:configure-flags
`("BUILDCC=gcc"
"--enable-fluidsynth"
+ "--enable-gme"
,(string-append "LDFLAGS=-Wl,-rpath -Wl,"
(assoc-ref %build-inputs "ffmpeg")
"/lib")) ;needed for the tests
M
Re: [bug#42460] [PATCH 0/2] gnu: vlc: add support for MIDI and chiptunes
87zh7ntxvo.fsf@gnu.org
Jesse Gibbons <jgibbons2357@gmail.com> writes:
Toggle quote (3 lines)
> The following patch series adds support for MIDI (with FluidSynth) and
> chiptunes (with gme) in VLC.
These patches are also ill-formatted.
And note that the libgme GCC issue should be fixed before adding it as a
dependency to packages.
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl8cUDsACgkQoqBt8qM6
VPrwagf/cTmhYTvG9/xepFsneBZ5JRdGVccMkIPBmlYgpUOcdHr4PvUXTyndOkVX
znh6/D4wTu87VqJ8XayOwk47C/k0XV7iL3Ba9Ek8e5PhkRZ49pe+GyVBnFWsqRuv
cuo9R8hwrSLdOdOTqnywm64vh0U55roCBhaZY+TTUfAaw6+SkN0MsU2Ek90wADMc
mSnvRR/WKbXMppV/0cXxXs5QW56eJ/v7AGRU2FQNqQB3LNxsUyfarLNyYSh0Xr+E
nrrdwIJ70xll4pGMszYxkBy6nxSfgeefDhjNBiYm/5l3lq1l0DB3ot8UKI56xN2d
fEjaApw22oJUbOGhepKp54MYY/NwTA==
=FtXV
-----END PGP SIGNATURE-----
J
6a02947c-4a3f-acfc-34a9-6408d9ae9aae@gmail.com
I'll look into this and combine with #42455 when libgme doesn't have gcc
as a transitive package.
On 7/25/20 9:31 AM, Marius Bakke wrote:
Toggle quote (8 lines)
> Jesse Gibbons <jgibbons2357@gmail.com> writes:
>
>> The following patch series adds support for MIDI (with FluidSynth) and
>> chiptunes (with gme) in VLC.
> These patches are also ill-formatted.
>
> And note that the libgme GCC issue should be fixed before adding it as a
> dependency to packages.
J
a9ffcf2a-4ef8-6697-bb87-4c5e0b980b0c@gmail.com
Is there a bug corresponding to the libgme GCC issue?
On 7/25/20 9:31 AM, Marius Bakke wrote:
Toggle quote (8 lines)
> Jesse Gibbons <jgibbons2357@gmail.com> writes:
>
>> The following patch series adds support for MIDI (with FluidSynth) and
>> chiptunes (with gme) in VLC.
> These patches are also ill-formatted.
>
> And note that the libgme GCC issue should be fixed before adding it as a
> dependency to packages.
?