python-gssapi fails to build

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal
Merged with
M
M
Michael Rohleder wrote on 15 Jul 2020 18:05
(address . bug-guix@gnu.org)
871rlczrui.fsf@rohleder.de
Hey guix!

I tried building synapse and python-gssapi fails in some (kerberos?)
tests:

...
test_verify_mic_iov_bad_mic_raises_error (gssapi.tests.test_raw.TestWrapUnwrap) ... ok
test_wrap_size_limit (gssapi.tests.test_raw.TestWrapUnwrap) ... ok

======================================================================
ERROR: test_add_with_impersonate (gssapi.tests.test_high_level.CredsTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
File "/gnu/store/zc5mv2h8b7p3lzd4cx3pcbcn9ix25vk5-python-k5test-0.9.2/lib/python3.8/site-packages/k5test/unit.py", line 28, in ext_test
func(self, *args, **kwargs)
File "/tmp/guix-build-python-gssapi-1.6.5.drv-0/gssapi-1.6.5/gssapi/tests/test_high_level.py", line 364, in test_add_with_impersonate
new_creds = input_creds.add(server_ctx.initiator_name,
File "/tmp/guix-build-python-gssapi-1.6.5.drv-0/gssapi-1.6.5/gssapi/creds.py", line 378, in add
res = rcred_s4u.add_cred_impersonate_name(self, impersonator,
File "gssapi/raw/ext_s4u.pyx", line 199, in gssapi.raw.ext_s4u.add_cred_impersonate_name
gssapi.raw.misc.GSSError: Major (851968): Unspecified GSS failure. Minor code may provide more information, Minor (2529638928): KDC has no support for padata type

======================================================================
ERROR: test_acquire_creds_impersonate_name (gssapi.tests.test_raw.TestBaseUtilities)
----------------------------------------------------------------------
Traceback (most recent call last):
File "/gnu/store/zc5mv2h8b7p3lzd4cx3pcbcn9ix25vk5-python-k5test-0.9.2/lib/python3.8/site-packages/k5test/unit.py", line 28, in ext_test
func(self, *args, **kwargs)
File "/tmp/guix-build-python-gssapi-1.6.5.drv-0/gssapi-1.6.5/gssapi/tests/test_raw.py", line 421, in test_acquire_creds_impersonate_name
imp_resp = gb.acquire_cred_impersonate_name(server_creds,
File "gssapi/raw/ext_s4u.pyx", line 112, in gssapi.raw.ext_s4u.acquire_cred_impersonate_name
gssapi.raw.misc.GSSError: Major (851968): Unspecified GSS failure. Minor code may provide more information, Minor (2529638928): KDC has no support for padata type

======================================================================
ERROR: test_add_cred_impersonate_name (gssapi.tests.test_raw.TestBaseUtilities)
----------------------------------------------------------------------
Traceback (most recent call last):
File "/gnu/store/zc5mv2h8b7p3lzd4cx3pcbcn9ix25vk5-python-k5test-0.9.2/lib/python3.8/site-packages/k5test/unit.py", line 28, in ext_test
func(self, *args, **kwargs)
File "/tmp/guix-build-python-gssapi-1.6.5.drv-0/gssapi-1.6.5/gssapi/tests/test_raw.py", line 390, in test_add_cred_impersonate_name
imp_resp = gb.add_cred_impersonate_name(input_creds,
File "gssapi/raw/ext_s4u.pyx", line 199, in gssapi.raw.ext_s4u.add_cred_impersonate_name
gssapi.raw.misc.GSSError: Major (851968): Unspecified GSS failure. Minor code may provide more information, Minor (2529638928): KDC has no support for padata type

----------------------------------------------------------------------
Ran 192 tests in 2.094s

FAILED (errors=3, skipped=9)
Test failed: <unittest.runner.TextTestResult run=192 errors=3 failures=0>
error: Test failed: <unittest.runner.TextTestResult run=192 errors=3 failures=0>
command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "test" failed with status 1
builder for `/gnu/store/38kbrahy7qjzwz629vfm62mg6cx95cb1-python-gssapi-1.6.5.drv' failed with exit code 1
build of /gnu/store/38kbrahy7qjzwz629vfm62mg6cx95cb1-python-gssapi-1.6.5.drv failed


--
Unsere Träume können wir erst dann verwirklichen,
wenn wir uns entschließen, daraus zu erwachen.
(Josephine Baker)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl8PKUUACgkQfHr/vv7y
yyWTeAf7Bserveg0yru8jqgJRlep9IUNyERXMzwM/MwVUWztMyWZI8vE7ya4Ngaf
dsAOG7b0M28+euHoPwYG6qx7M3VMwRQIljm1litb9gNxpnanASMQl73eCXkyEjAC
XxaF+hPx/LdeXJvcP5uVyhD8GS0xYECp/JapzbRVe2BvR1fs18YHaurI1nU9jVZa
uJ90fYTB4d1M3Hl1DmPQx2QzL+S27nnJY1QHeap4zm5Rjn5Uio59auYaIwkLC47h
9Hkhki9hq6NBMDTFxgbjL0ocKDt4pxJWOyFXECJLVore3Loh/DnSTafsHRzZFcVJ
hgu12cc69ufk3aGZvTC9K/PqQDbwYg==
=BOal
-----END PGP SIGNATURE-----

M
M
Michael Rohleder wrote on 9 Sep 2020 09:56
control message for bug #42370
(address . control@debbugs.gnu.org)
87k0x3l6xp.fsf@rohleder.de
merge 42370 43284
quit
M
M
Michael Rohleder wrote on 15 Sep 2020 17:28
control message for bug #43402
(address . control@debbugs.gnu.org)
87k0wvnjnr.fsf@rohleder.de
merge 43402 43284
quit
M
M
Maxim Cournoyer wrote on 3 Oct 2020 04:19
Re: bug#43402: Addition
(name . Kurt)(address . gitlabcanada@runbox.com)
87blhkm4oz.fsf@gmail.com
Hello,

Kurt <gitlabcanada@runbox.com> writes:

Toggle quote (3 lines)
> This error is showing up when trying to build the "synapse" matrix
> server.

I fixed the python-gssapi build by skipping the 3 failing tests, in
commit 3dc26bcd78. Synapse seems to build fine now.

Closing.

Thanks for the report!

Maxim
Closed
?