[PATCH] gnu: windowmaker: Update to 0.95.9.

  • Done
  • quality assurance status badge
Details
One participant
  • Kei Kebreau
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 5 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20200715144953.5084-1-kkebreau@posteo.net
* gnu/packages/gnustep.scm (windowmaker): Update to 0.95.9.
[source]: Update URI.
[home-page]: Use HTTPS URL.
---
gnu/packages/gnustep.scm | 36 ++++++++++++++++++------------------
1 file changed, 18 insertions(+), 18 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index 7a8a39eee3..0dcd0bee0d 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -67,16 +67,16 @@ to easily create cross-compiled binaries.")
(define-public windowmaker
(package
(name "windowmaker")
- (version "0.95.8")
+ (version "0.95.9")
(synopsis "NeXTSTEP-like window manager")
(source (origin
(method url-fetch)
(uri (string-append
- "http://windowmaker.org/pub/source/release/WindowMaker-"
- version ".tar.gz"))
+ "https://github.com/window-maker/wmaker/releases/download/"
+ "wmaker-" version "/WindowMaker-" version ".tar.gz"))
(sha256
(base32
- "12p8kljqgx5hnic0zvs5mxwp7kg21sb6qjagb2qw8ydvf5amrgwx"))))
+ "055pqvlkhipyjn7m6bb3fs4zz9rd1ynzl0mmwbhp05ihc3zmh8zj"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -113,26 +113,26 @@ to easily create cross-compiled binaries.")
(call-with-output-file
(string-append xsessions "/windowmaker.desktop")
(lambda (port)
- (format port "~
+ (format port "~
[Desktop Entry]~@
Name=Window Maker~@
Comment=~a~@
Exec=~a/bin/wmaker~@
Type=Application~%"
- (string-map (match-lambda
- (#\newline #\space)
- (chr chr))
- ,synopsis) out))))
+ (string-map (match-lambda
+ (#\newline #\space)
+ (chr chr))
+ ,synopsis) out))))
#t))
(add-after 'install-xsession 'wrap
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
- ;; etc., so make sure everything is in $PATH.
- (wrap-program (string-append bin "/wmaker.inst")
- `("PATH" ":" prefix (,bin)))
- #t))))))
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
+ ;; etc., so make sure everything is in $PATH.
+ (wrap-program (string-append bin "/wmaker.inst")
+ `("PATH" ":" prefix (,bin)))
+ #t))))))
(inputs
`(("libxmu" ,libxmu)
("libxft" ,libxft)
@@ -145,7 +145,7 @@ to easily create cross-compiled binaries.")
("libtiff" ,libtiff)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://windowmaker.org/")
+ (home-page "https://windowmaker.org/")
(description
"Window Maker is an X11 window manager originally designed to provide
integration support for the GNUstep Desktop Environment. In every way
--
2.27.0
Kei Kebreau wrote 5 years ago
(address . 42367-done@debbugs.gnu.org)
87sgdpeixr.fsf@posteo.net
Self-checked on another machine.

Pushed to master as commit 4b3d54e73.

Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (81 lines)
> * gnu/packages/gnustep.scm (windowmaker): Update to 0.95.9.
> [source]: Update URI.
> [home-page]: Use HTTPS URL.
> ---
> gnu/packages/gnustep.scm | 36 ++++++++++++++++++------------------
> 1 file changed, 18 insertions(+), 18 deletions(-)
>
> diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
> index 7a8a39eee3..0dcd0bee0d 100644
> --- a/gnu/packages/gnustep.scm
> +++ b/gnu/packages/gnustep.scm
> @@ -67,16 +67,16 @@ to easily create cross-compiled binaries.")
> (define-public windowmaker
> (package
> (name "windowmaker")
> - (version "0.95.8")
> + (version "0.95.9")
> (synopsis "NeXTSTEP-like window manager")
> (source (origin
> (method url-fetch)
> (uri (string-append
> - "http://windowmaker.org/pub/source/release/WindowMaker-"
> - version ".tar.gz"))
> + "https://github.com/window-maker/wmaker/releases/download/"
> + "wmaker-" version "/WindowMaker-" version ".tar.gz"))
> (sha256
> (base32
> - "12p8kljqgx5hnic0zvs5mxwp7kg21sb6qjagb2qw8ydvf5amrgwx"))))
> + "055pqvlkhipyjn7m6bb3fs4zz9rd1ynzl0mmwbhp05ihc3zmh8zj"))))
> (build-system gnu-build-system)
> (arguments
> `(#:modules ((guix build gnu-build-system)
> @@ -113,26 +113,26 @@ to easily create cross-compiled binaries.")
> (call-with-output-file
> (string-append xsessions "/windowmaker.desktop")
> (lambda (port)
> - (format port "~
> + (format port "~
> [Desktop Entry]~@
> Name=Window Maker~@
> Comment=~a~@
> Exec=~a/bin/wmaker~@
> Type=Application~%"
> - (string-map (match-lambda
> - (#\newline #\space)
> - (chr chr))
> - ,synopsis) out))))
> + (string-map (match-lambda
> + (#\newline #\space)
> + (chr chr))
> + ,synopsis) out))))
> #t))
> (add-after 'install-xsession 'wrap
> - (lambda* (#:key outputs #:allow-other-keys)
> - (let* ((out (assoc-ref outputs "out"))
> - (bin (string-append out "/bin")))
> - ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
> - ;; etc., so make sure everything is in $PATH.
> - (wrap-program (string-append bin "/wmaker.inst")
> - `("PATH" ":" prefix (,bin)))
> - #t))))))
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (bin (string-append out "/bin")))
> + ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
> + ;; etc., so make sure everything is in $PATH.
> + (wrap-program (string-append bin "/wmaker.inst")
> + `("PATH" ":" prefix (,bin)))
> + #t))))))
> (inputs
> `(("libxmu" ,libxmu)
> ("libxft" ,libxft)
> @@ -145,7 +145,7 @@ to easily create cross-compiled binaries.")
> ("libtiff" ,libtiff)))
> (native-inputs
> `(("pkg-config" ,pkg-config)))
> - (home-page "http://windowmaker.org/")
> + (home-page "https://windowmaker.org/")
> (description
> "Window Maker is an X11 window manager originally designed to provide
> integration support for the GNUstep Desktop Environment. In every way
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42367@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42367
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help