[PATCH] gnu: Add thin-provisioning-tools.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jakub Kądziołka
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)
87r1thsmgx.fsf@rohleder.de
I use lvmcache (on ssd) for / (on spinning rust) which works fine.
But it writes the cache to the harddrive on every boot. In order to
debug (and maybe fix it), I think these tools (esp. cache_check) might
be useful...
From 0307f8f0e8f4abb3506ae7f05c84bfe79b50518d Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sun, 12 Jul 2020 00:25:13 +0200
Subject: [PATCH] gnu: Add thin-provisioning-tools.

* gnu/packages/linux.scm (thin-provisioning-tools): New variable.
---
gnu/packages/linux.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bd7cbf183f..c010b3178b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -46,6 +46,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -73,6 +74,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
#:use-module (gnu packages cpio)
@@ -3403,6 +3405,36 @@ mapper. Kernel components are part of Linux-libre.")
#t))))))
(synopsis "Logical volume management for Linux (statically linked)")))
+(define-public thin-provisioning-tools
+ (package
+ (name "thin-provisioning-tools")
+ (version "0.8.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jthornber/thin-provisioning-tools.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01wl8c0cjbx1smbhj8dx6av5bnw5775m58gasc3vqwvsj0s9hq19"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; doesnt build with --enable-testing
+ `(#:tests? #f))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoreconf" ,autoconf)))
+ (inputs
+ `(("boost" ,boost)
+ ("expat" ,expat)
+ ("libaio" ,libaio)))
+ (synopsis "Tools for manipulating the metadata of device-mapper targets")
+ (description "A suite of tools for manipulating the metadata of the
+dm-thin, dm-cache and dm-era device-mapper targets.")
+ (home-page "https://github.com/jthornber/thin-provisioning-tools")
+ (license license:gpl3+)))
+
(define-public wireless-tools
(package
(name "wireless-tools")
--
2.27.0
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl8KQD4ACgkQfHr/vv7y
yyVn6gf/clI0GJVsNwFs4Ykb+5iXAtBDAdTsLkPTbW0QFtbKucKYBs1R81Md3SbG
D0MFB49tTLRP9MM/JkbxghE5pIIJYNLepH2PNlzw2bI1kIYGXOTzzDEQlile/xBZ
aUcjVXmqFTWWQIbvb0ITujL+9zB7NvhBw2jlcuO9y9wzYdiE133eBOkfwCSawrQ4
4uKu1xAIqd6CYWBiOw4YoA0tt2OvC8aLma5/cxsVBmp9B3gvhfj7RWbnoE93yCjE
UVgXkmLXanBllD9DSf/Rc1JrDJ0f/fU+uqcPuDaCzOox40jU8ENYowcFTiQWrnUH
lAvmH+gjLX0pMtUBYezRy1/rNyP5vg==
=uJJ9
-----END PGP SIGNATURE-----

Jakub Kądziołka wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 42329-done@debbugs.gnu.org)
20200712180041.hrjfi5pqso2d2s4c@gravity
On Sun, Jul 12, 2020 at 12:42:06AM +0200, Michael Rohleder wrote:
Toggle quote (6 lines)
> I use lvmcache (on ssd) for / (on spinning rust) which works fine.
> But it writes the cache to the harddrive on every boot. In order to
> debug (and maybe fix it), I think these tools (esp. cache_check) might
> be useful...
>

Thanks for the patch! I decided to expand the comment a bit:

;; Doesn't build with --enable-testing due to a function name collision
;; with glibc. Fixed upstream. TODO: Enable tests when 0.9.0 is released.

Apart from that, LGTM, so I pushed your patch as commit
a68430712fe623a61ba5eecfb8aa4547079a96c2.

Regards,
Jakub Kądziołka
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl8LT8gACgkQ4xWnWEYT
FWTXHxAAvDxIl+NBMaVHU/8OcP052SvDfnmO/Iqh5tWAViT924blntCjw3o+3AF2
5K68Vcao9E6Gb7HSIlt1P54mayLNb688WTU2qJfZ54ow6oqO7FnjtHcl4AFKGs3u
iLvicWJ8vdx5U80qRZbf3dUhwVGm/G2wcQ+eA4u2uxndZuLipc8Sk64reH9uQ/Nv
bgUncBlo/zc4ySXdHBAnmdIqZOYBp7DFjCTajoIm02HvkzWUkKwIiqrSTTA7YTF/
FzvZzbhLR7wTohgW9JGJQG0eNbMw0MQIl6JYZAGghLJn5m58sVQ8t+Q4oZ6E+SAo
p8IiKx676lwL7F8brXANDW2SWfyCQ1xCLNwbeTO4SjIiPxhVWTiraqkf5T+F7MF3
VYDbyRlOiI2mHt6mD6agoajAdzH+2tL33InsO3USq2AFsESXrrZGbq2i+cjMCUL/
unqODqudlI7BGWCMyzH3nGEZgIiPwxWcPONyRLppgc0j/xWFCJjedxC+XG6XWtpv
pmqzIinFbaEqpRtPiJUa6JuqrQo19+ulSUxeGitPyrICDm8Or2tPvSyomWRvyqgE
k9C0t8tkexZwTg0l5UVxlaYCg1Xk75uzmQGvPqKR5andiTttzx1JUucQRcSeEgdT
4mPY8HXZlrIgEJAMtqB07ej0Sx17A+aVw+pgYyWluPHpsd0Q9hg=
=QVuj
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42329@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42329
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help