Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)
I use lvmcache (on ssd) for / (on spinning rust) which works fine.
But it writes the cache to the harddrive on every boot. In order to
debug (and maybe fix it), I think these tools (esp. cache_check) might
be useful...
From 0307f8f0e8f4abb3506ae7f05c84bfe79b50518d Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sun, 12 Jul 2020 00:25:13 +0200
Subject: [PATCH] gnu: Add thin-provisioning-tools.
* gnu/packages/linux.scm (thin-provisioning-tools): New variable.
---
gnu/packages/linux.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Toggle diff (59 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bd7cbf183f..c010b3178b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -46,6 +46,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -73,6 +74,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
#:use-module (gnu packages cpio)
@@ -3403,6 +3405,36 @@ mapper. Kernel components are part of Linux-libre.")
#t))))))
(synopsis "Logical volume management for Linux (statically linked)")))
+(define-public thin-provisioning-tools
+ (package
+ (name "thin-provisioning-tools")
+ (version "0.8.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jthornber/thin-provisioning-tools.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01wl8c0cjbx1smbhj8dx6av5bnw5775m58gasc3vqwvsj0s9hq19"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; doesnt build with --enable-testing
+ `(#:tests? #f))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoreconf" ,autoconf)))
+ (inputs
+ `(("boost" ,boost)
+ ("expat" ,expat)
+ ("libaio" ,libaio)))
+ (synopsis "Tools for manipulating the metadata of device-mapper targets")
+ (description "A suite of tools for manipulating the metadata of the
+dm-thin, dm-cache and dm-era device-mapper targets.")
+ (home-page "https://github.com/jthornber/thin-provisioning-tools")
+ (license license:gpl3+)))
+
(define-public wireless-tools
(package
(name "wireless-tools")
--
2.27.0
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl8KQD4ACgkQfHr/vv7y
yyVn6gf/clI0GJVsNwFs4Ykb+5iXAtBDAdTsLkPTbW0QFtbKucKYBs1R81Md3SbG
D0MFB49tTLRP9MM/JkbxghE5pIIJYNLepH2PNlzw2bI1kIYGXOTzzDEQlile/xBZ
aUcjVXmqFTWWQIbvb0ITujL+9zB7NvhBw2jlcuO9y9wzYdiE133eBOkfwCSawrQ4
4uKu1xAIqd6CYWBiOw4YoA0tt2OvC8aLma5/cxsVBmp9B3gvhfj7RWbnoE93yCjE
UVgXkmLXanBllD9DSf/Rc1JrDJ0f/fU+uqcPuDaCzOox40jU8ENYowcFTiQWrnUH
lAvmH+gjLX0pMtUBYezRy1/rNyP5vg==
=uJJ9
-----END PGP SIGNATURE-----