Morgan.J.Smith wrote 5 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
From: Morgan Smith <Morgan.J.Smith@outlook.com>
* gnu/packages/emacs-xyz.scm (emacs-org-drill): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 89fed81059..abab42a556 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5520,6 +5520,30 @@ Cucumber tool) user stories. Also known by the name @code{cucumber.el}.")
@code{org-mode} to be rendered as UTF-8 characters.")
(license license:gpl3+)))
+(define-public emacs-org-drill
+ (package
+ (name "emacs-org-drill")
+ (version "2.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/phillord/org-drill")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13y302lyscdqrba1sfx60yf5ji2xi7fbsvjsjbw7hiz63kg6rccy"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-persist" ,emacs-persist)
+ ("emacs-org" ,emacs-org)))
+ (home-page "https://gitlab.com/phillord/org-drill")
+ (synopsis "Flash card memorization system using Org mode")
+ (description "This package uses spaced repetition algorithms to conduct
+interactive drill sessions to aid in memorization. In these sessions you are
+shown flash cards created in Org mode.")
+ (license license:gpl3+)))
+
(define-public emacs-org-superstar
(package
(name "emacs-org-superstar")
--
2.27.0