[PATCH] gnu: Add emacs-org-drill.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 5 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR1001MB21057E9145826DEA7C41303DC5620@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-org-drill): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 89fed81059..abab42a556 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5520,6 +5520,30 @@ Cucumber tool) user stories. Also known by the name @code{cucumber.el}.")
@code{org-mode} to be rendered as UTF-8 characters.")
(license license:gpl3+)))
+(define-public emacs-org-drill
+ (package
+ (name "emacs-org-drill")
+ (version "2.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/phillord/org-drill")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13y302lyscdqrba1sfx60yf5ji2xi7fbsvjsjbw7hiz63kg6rccy"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-persist" ,emacs-persist)
+ ("emacs-org" ,emacs-org)))
+ (home-page "https://gitlab.com/phillord/org-drill")
+ (synopsis "Flash card memorization system using Org mode")
+ (description "This package uses spaced repetition algorithms to conduct
+interactive drill sessions to aid in memorization. In these sessions you are
+shown flash cards created in Org mode.")
+ (license license:gpl3+)))
+
(define-public emacs-org-superstar
(package
(name "emacs-org-superstar")
--
2.27.0
Nicolas Goaziou wrote 5 years ago
(address . Morgan.J.Smith@outlook.com)(address . 42320-done@debbugs.gnu.org)
87lfjm1ndi.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (4 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-org-drill): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42320@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42320
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help