(name . Guix patches)(address . guix-patches@gnu.org)
Hi,
This patch adds the ADLPlug LV2 plugin.
Thanks,
Alex
From 9fb65e86d7d175b7680777fb74082491642bfe1c Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 22:46:38 +0100
Subject: [PATCH] gnu: Add adlplug.
* gnu/packages/music.scm (adlplug): New variable.
---
gnu/packages/music.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)
Toggle diff (55 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 0b8b8df226..11cd0dc246 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1422,6 +1422,48 @@ sessions. Solfege is also designed to be extensible so you can easily write
your own lessons.")
(license license:gpl3+)))
+(define-public adlplug
+ (package
+ (name "adlplug")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jpcima/ADLplug.git")
+ (commit (string-append "v" version))
+ (recursive? #t))) ; uses 3rd party submodules
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0n9srdlgl1j528ap5xmllrqs1w6ibc5yf9sphvl1q9kjnizxrs2c"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:configure-flags `("-DADLplug_VST2=OFF"
+ "-DADLplug_VST3=OFF"
+ "-DADLplug_LV2=ON"
+ "-DADLplug_Standalone=ON"
+ "-DADLplug_Jack=ON"
+ "-DADLplug_CHIP=OPL3")))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("freetype" ,freetype)
+ ("jack" ,jack-1)
+ ("libx11" ,libx11)
+ ("libxcursor" ,libxcursor)
+ ("libxinerama" ,libxinerama)
+ ("libxrandr" ,libxrandr)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "FM chip synthesizer plugin")
+ (description
+ "This package provides FM synthesizer plugins, based on
+OPL3 and OPN2 sound chip emulations. The emulations and the drivers are
+provided by libADLMIDI and libOPNMIDI.")
+ (home-page "https://github.com/jpcima/ADLplug")
+ (license license:boost1.0)))
+
(define-public powertabeditor
(package
(name "powertabeditor")
--
2.27.0
-----BEGIN PGP SIGNATURE-----
iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl8GPv4ACgkQAi6uQjE9
cPNqvAf7BnvQEivuIFsKZAQtC/hbtuIcAetAWJ4iNeaIRkQCTrVPnveKzYRvN+95
eXVlj07+32Npt4dlEKE+9Sd1iNxYVoq+RbEMxEhE04ahevbgT9gNap2+pjUktUg1
WH+fd1P/O+wm8eiF/KOWuXsxWS0qj5tuJjsqPVq33qN4UKsxGouYoZ2mKPOMSgkw
kbxa70+b47WDAa6dwPNYKWl1xWUVeW+Udghxjc4GGigqWKyVQBcWgvLiAtkSWWkK
DbAcRtD0FVY4JcceB/ZKwYK0iZR3uzwDJpaWq0w2oOT9q4+CoxOkozIRt83k2JE9
LSkMnB+H2zPZj3IFMyhN4knosmU1eg==
=VW3/
-----END PGP SIGNATURE-----