[PATCH] gnu: Add ttaenc.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal

Debbugs page

Alexandros Theodotou wrote 5 years ago
(name . Guix patches)(address . guix-patches@gnu.org)
c7890e12e96eea0313dbd06136d7ae09b725642c.camel@zrythm.org
Hi,

This patch adds the TTA encoder.

Thanks,
Alex
From cd611e07a71f743d1e71d695c2a48c53e906fc0c Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 22:43:14 +0100
Subject: [PATCH] gnu: Add ttaenc.

* gnu/packages/audio.scm (ttaenc): New variable.
---
gnu/packages/audio.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8fc23825ea..97264e5592 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4003,6 +4003,45 @@ stream to one or more IceCast and/or ShoutCast servers.")
(home-page "https://x42.github.io/libltc/")
(license license:lgpl3+)))
+(define-public ttaenc
+ (package
+ (name "ttaenc")
+ (version "3.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/tta/"
+ "tta/ttaenc-src"
+ "/ttaenc-" version "-src.tgz"))
+ (sha256
+ (base32
+ "1iixpr4b89g9g1hwn8ak8k8iflcww3r5f09a117qdidc2nqcijdj"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc" (string-append "INSDIR=" (assoc-ref %outputs "out") "/bin"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure
+ (delete 'check) ; no check
+ (add-before 'install 'make-bindir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/bin"))
+ #t))))))
+ (synopsis "TTA lossless audio encoder")
+ (description
+ "TTA performs lossless compression on multichannel 8,16 and 24 bits
+data of the Wav audio files. Being lossless means that no data-
+quality is lost in the compression - when uncompressed, the data will
+be identical to the original. The compression ratios of TTA depend on
+the type of music file being compressed, but the compression size
+will generally range between 30% - 70% of the original. TTA format
+supports both of ID3v1/v2 and APEv2 tags. Detailed format description
+is available at http://tta.sourceforge.net")
+ (home-page "http://tausoft.org/")
+ (license license:gpl2)))
+
(define-public redkite
(package
(name "redkite")
--
2.27.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl8GPj8ACgkQAi6uQjE9
cPMZ6Af/Rs9duXSIHrlYhwfCwZqzsvkIjqgpIYd/9TW2k6ancFUWQlJ/n+9L1vBv
fkiJANZMM3fB600bXo6hDVCxkCHkpWZVZ9/Q6lcWtR2rXUmst+KtHYxwWSxA+L8a
BPT351yDOFRvIdRaMIvwwLNTcRzyArbVuGmUTrInlSI+Vb0xu1aMRd3cWeeSTm/T
0LNkblB37VzKAmeVpWHPmFAr0XBuXGfM7n/KYwm5OBzKqYAEEy8MYuuC4wpCYIr1
Tr4o42RYZUkO3H8TBx7o91+wvQaviUKqNyJHh42ERHcSvs5V2bTMM3kUV7KqA2eG
L9NHw7ash0g78Y3oWGGh23fjRz4aJg==
=KUM3
-----END PGP SIGNATURE-----


Marius Bakke wrote 5 years ago
875zahhkte.fsf@gnu.org
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (4 lines)
> Hi,
>
> This patch adds the TTA encoder.

[...]

Toggle quote (2 lines)
> * gnu/packages/audio.scm (ttaenc): New variable.

[...]
Toggle quote (14 lines)
> +(define-public ttaenc
> + (package
> + (name "ttaenc")
> + (version "3.4.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "mirror://sourceforge/tta/"
> + "tta/ttaenc-src"
> + "/ttaenc-" version "-src.tgz"))
> + (sha256
> + (base32
> + "1iixpr4b89g9g1hwn8ak8k8iflcww3r5f09a117qdidc2nqcijdj"))))

If you don't use Emacs, please run ./etc/indent-code.el before
submitting packages. :-)

Toggle quote (5 lines)
> + (build-system gnu-build-system)
> + (arguments
> + `(#:make-flags
> + (list "CC=gcc" (string-append "INSDIR=" (assoc-ref %outputs "out") "/bin"))

I used (string-append "CC=" ,(cc-for-target)) here to aid
cross-compilation.

Toggle quote (5 lines)
> + #:phases
> + (modify-phases %standard-phases
> + (delete 'configure) ; no configure
> + (delete 'check) ; no check

And added #:tests? #f instead of deleting the phase.

Toggle quote (16 lines)
> + (add-before 'install 'make-bindir
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out")))
> + (mkdir-p (string-append out "/bin"))
> + #t))))))
> + (synopsis "TTA lossless audio encoder")
> + (description
> + "TTA performs lossless compression on multichannel 8,16 and 24 bits
> +data of the Wav audio files. Being lossless means that no data-
> +quality is lost in the compression - when uncompressed, the data will
> +be identical to the original. The compression ratios of TTA depend on
> +the type of music file being compressed, but the compression size
> +will generally range between 30% - 70% of the original. TTA format
> +supports both of ID3v1/v2 and APEv2 tags. Detailed format description
> +is available at http://tta.sourceforge.net")

I removed the last sentence, because that URL just redirects to the home
page and did not actually contain a detailed format description. Also,
it was missing punctuation, and lacked two spaces after the previous
punctuation (did you forget to use 'guix lint'?).

Toggle quote (3 lines)
> + (home-page "http://tausoft.org/")
> + (license license:gpl2)))

This is GPL2+, as explicitly stated in the README.

Applied with those changes, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl8WHV0ACgkQoqBt8qM6
VPpEsggAzAUa9DAiTczuPtTJ74jGIpz1jXq/jGJqLnZdn71VlW3NJBBSj11TdKXq
D9i7UotXLE/HpH77UKTd0MMhPE0vh1NKrUbKnWd0QYtw2iyqrzmRAVBuqsxHC8Zb
vGaGKOe9AKULY7jTaH2sEcUPcO8KffXWe8J68byBuc7VmHkFkL16428DEvCGC7GK
61hl8iv97ex+3/oJK4kIJKUiR4KlDJD9cxxzFemfxVV8wsdOarn/mo8b5hDxfesh
7bHQQ6ylP5iInvVW6swriKNcxN5PtSI3AocqGMUyGPknwys89hoV7Nnz/lkQmOQP
kL2pDJpxQqz4PPPBc6qfhO+fDcMj4A==
=JT/S
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42282@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42282
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help