Alexandros Theodotou wrote 5 years ago
(name . Guix patches)(address . guix-patches@gnu.org)
Hi,
This patch adds the TTA encoder.
Thanks,
Alex
From cd611e07a71f743d1e71d695c2a48c53e906fc0c Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 22:43:14 +0100
Subject: [PATCH] gnu: Add ttaenc.
* gnu/packages/audio.scm (ttaenc): New variable.
---
gnu/packages/audio.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
Toggle diff (52 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8fc23825ea..97264e5592 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4003,6 +4003,45 @@ stream to one or more IceCast and/or ShoutCast servers.")
(home-page "https://x42.github.io/libltc/")
(license license:lgpl3+)))
+(define-public ttaenc
+ (package
+ (name "ttaenc")
+ (version "3.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/tta/"
+ "tta/ttaenc-src"
+ "/ttaenc-" version "-src.tgz"))
+ (sha256
+ (base32
+ "1iixpr4b89g9g1hwn8ak8k8iflcww3r5f09a117qdidc2nqcijdj"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc" (string-append "INSDIR=" (assoc-ref %outputs "out") "/bin"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure
+ (delete 'check) ; no check
+ (add-before 'install 'make-bindir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/bin"))
+ #t))))))
+ (synopsis "TTA lossless audio encoder")
+ (description
+ "TTA performs lossless compression on multichannel 8,16 and 24 bits
+data of the Wav audio files. Being lossless means that no data-
+quality is lost in the compression - when uncompressed, the data will
+be identical to the original. The compression ratios of TTA depend on
+the type of music file being compressed, but the compression size
+will generally range between 30% - 70% of the original. TTA format
+supports both of ID3v1/v2 and APEv2 tags. Detailed format description
+is available at http://tta.sourceforge.net")
+ (home-page "http://tausoft.org/")
+ (license license:gpl2)))
+
(define-public redkite
(package
(name "redkite")
--
2.27.0
-----BEGIN PGP SIGNATURE-----
iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl8GPj8ACgkQAi6uQjE9
cPMZ6Af/Rs9duXSIHrlYhwfCwZqzsvkIjqgpIYd/9TW2k6ancFUWQlJ/n+9L1vBv
fkiJANZMM3fB600bXo6hDVCxkCHkpWZVZ9/Q6lcWtR2rXUmst+KtHYxwWSxA+L8a
BPT351yDOFRvIdRaMIvwwLNTcRzyArbVuGmUTrInlSI+Vb0xu1aMRd3cWeeSTm/T
0LNkblB37VzKAmeVpWHPmFAr0XBuXGfM7n/KYwm5OBzKqYAEEy8MYuuC4wpCYIr1
Tr4o42RYZUkO3H8TBx7o91+wvQaviUKqNyJHh42ERHcSvs5V2bTMM3kUV7KqA2eG
L9NHw7ash0g78Y3oWGGh23fjRz4aJg==
=KUM3
-----END PGP SIGNATURE-----