(name . Guix patches)(address . guix-patches@gnu.org)
Hi,
This patch adds distrho-ports, a collection of LV2 plugins ported from
other platforms/frameworks.
The meson build system was recently added and not released yet (it used
an old version of premake before and failed to build on guix).
Thanks,
Alex
From 162c01597dac51a1a2152ea88abe7fa917039d67 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 22:24:53 +0100
Subject: [PATCH] gnu: Add distrho-ports.
* gnu/packages/music.scm (distrho-ports): New variable.
---
gnu/packages/music.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)
Toggle diff (59 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 7f1f3f3e9a..490f010c4a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1076,6 +1076,52 @@ Guile.")
;; more than an hour of silence, so double the max silent time.
(properties `((max-silent-time . 7200)))))
+(define-public distrho-ports
+ ;; the previous release required a version of premake not present
+ ;; in guix. it has now been ported to meson but not released yet
+ (let ((commit "a953bed05844d4a0ba349f75c75b56a430c8b11a")
+ (revision "1"))
+ (package
+ (name "distrho-ports")
+ (version (git-version "2018-04-16" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/DISTRHO/DISTRHO-Ports.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03ji41i6dpknws1vjwfxnl8c8bgisv2ng8xa4vqy2473k7wgdw4v"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("freetype" ,freetype)
+ ("mesa" ,mesa)
+ ("libxrender" ,libxrender)
+ ("libxcursor" ,libxcursor)
+ ("xorgproto" ,xorgproto)
+ ("libx11" ,libx11)))
+ (native-inputs
+ `(("lv2" ,lv2)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Collection of audio plugins and LV2 ports")
+ (description
+ "DISTRHO is a project with the goal of making cross-platform audio
+ plugins and GNU/Linux ports.
+ This package includes HiReSam, LUFSMeter-Multi, LUFSMeter, Arctican Function,
+ Arctican Pilgrim, Dexed, dRowAudio Distortion, dRowAudio Distortion Shaper,
+ dRowAudio Flanger, dRowAudioReverb, dRowAudio Tremolo, DrumSynth, easySSP,
+ EQuinox, JUCE Demo Plugin, JUCE OPL, Klangfalter, Luftikus, Obxd, Pitched
+ Delay, Refine, Stereo Source Separation, TAL Dub 3, TAL Noise Maker, TAL
+ Reverb 2, TAL Reverb 3, TAL Reverb, TAL Vocoder 2, Temper, Vex and
+ Wolpertinger.")
+ (home-page "http://distrho.sourceforge.net/ports")
+ (license (list license:gpl2 ; found in doc directory
+ license:lgpl3+ ; found in doc directory
+ license:gpl3))))) ; mentioned in meson file
+
(define-public non-sequencer
;; The latest tagged release is three years old and uses a custom build
;; system, so we take the last commit.
--
2.27.0
-----BEGIN PGP SIGNATURE-----
iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl8GOjkACgkQAi6uQjE9
cPPgbAf8D5Bf1WP5d57MMgBgChAw+kFAcEcv83P/QNOcopXOwebhT+hBQN6B2GDl
BkeTb1y8klaFYuEY/y/rF7KduHsSaUT7c73xCPo8eWcUd218C1WHEWg1tz/BJpLr
wAWr0PilzIUE+urBLILvX8Zc6UbROeUts3mq3p0TJJuQkLGorakKZ+UUP9xJC+4n
Bmhr5nojWPl8RTBwtgCiGvwkg4ArYvcz0/YpPeb55jRP3SN/oABUpVoGZuIA2NL/
asLWd9sXwG0YwsO1eN55+cKJPNQ6f1PbKgw+WTW0zwcYi1bvMNdVrPKTB1tpnxro
BPEHqVRHYKNAR6YFMP5P4oSWFsYaBg==
=ehsn
-----END PGP SIGNATURE-----