[PATCH 1/2] gnu: carla: Update to 2.1.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal

Debbugs page

Alexandros Theodotou wrote 5 years ago
(name . Guix patches)(address . guix-patches@gnu.org)
c3f98495696e0009b3d1177d7848840f3abaf705.camel@zrythm.org
Hi,

These patches update carla and add gtk2 as a dependency, so it can be
used to bridge gtk2 plugins inside gtk3/qt5 hosts.

Thanks,
Alex
From cf3959b423f73e5725ab961b261828bde6c6b272 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 21:31:38 +0100
Subject: [PATCH 2/2] gnu: carla: Add gtk2 dependency.

* gnu/packages/audio.scm (carla)[inputs]: Add gtk2 to allow bridging
gtk2 plugins in gtk3 hosts.
---
gnu/packages/audio.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index cf80113520..91013547cf 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4077,6 +4077,8 @@ as is the case with audio plugins.")
("file" ,file)
("liblo" ,liblo)
("libsndfile" ,libsndfile)
+ ;; needed for bridging Gtk2 plugins in Gtk3 hosts
+ ("gtk2" ,gtk+-2)
("gtk+" ,gtk+)
("python-pyliblo" ,python-pyliblo)
("python-pyqt" ,python-pyqt)
--
2.27.0
From ec79b9bc3795638e446d244719e6112e134ab56f Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 21:30:39 +0100
Subject: [PATCH 1/2] gnu: carla: Update to 2.1.1.

* gnu/packages/audio.scm (carla): Update to 2.1.1.
---
gnu/packages/audio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 47cec4fea2..cf80113520 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4035,7 +4035,7 @@ as is the case with audio plugins.")
(define-public carla
(package
(name "carla")
- (version "2.0.0")
+ (version "2.1.1")
(source
(origin
(method git-fetch)
@@ -4046,7 +4046,7 @@ as is the case with audio plugins.")
(file-name (git-file-name name version))
(sha256
(base32
- "0fqgncqlr86n38yy7pa118mswfacmfczj7w9xx6c6k0jav3wk29k"))))
+ "0c3y4a6cgi4bv1mg57i3qn5ia6pqjqlaylvkapj6bmpsw71ig22g"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" target
--
2.27.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl8GLckACgkQAi6uQjE9
cPMfkAgAnugSsYhjx6+39/ewLijnAxvtZSkRsgeZ6K0MDzSJbnA/ALcxk9pBTnTU
al8RXeur/Qedta7Z+iiT6MlGTVTkfmKxFed3M8SjCquz3C5puOkNaBOciw5Aio7J
q1lH7o+yjj0iQX6W37Im36g9Z9hPaIyHC/eehJ/QQTNxvSbrtEV2otRzVT3HKwTg
F2M6lVpdVc3ILYpTLxJPN47z0jY1Th/HRbAMB4O2MvPpJM21ji7tgpVqkpz5o/zZ
1JmhjkYkF/+Xdj9AFEMFDJ79KVOMZyGmixRkc65ILAhqe2m2RXofvmUGAJy1zryT
r1xpkImD49zV9LEj42jOLbFAvo1zJQ==
=XQWI
-----END PGP SIGNATURE-----


Marius Bakke wrote 5 years ago
87lfjdhn3k.fsf@gnu.org
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (5 lines)
> Hi,
>
> These patches update carla and add gtk2 as a dependency, so it can be
> used to bridge gtk2 plugins inside gtk3/qt5 hosts.

[...]

Toggle quote (11 lines)
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index cf80113520..91013547cf 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -4077,6 +4077,8 @@ as is the case with audio plugins.")
> ("file" ,file)
> ("liblo" ,liblo)
> ("libsndfile" ,libsndfile)
> + ;; needed for bridging Gtk2 plugins in Gtk3 hosts
> + ("gtk2" ,gtk+-2)

I moved the comment to the same line and applied both patches.

(the alternative was to turn it into a full sentence with capitalization
and punctuation as we usually do for non-margin comments)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl8WEc8ACgkQoqBt8qM6
VPp7QwgAmNc9RhofPWd8zZAcftFf9i1ZceTWoCUEH2cRdovJxL5xB7dnfDv4buUA
ffrDIi6+4W+pf2RRRwgA4UYfhyhdxTeAnBRdNUixFNfrfZ3JZWF8UxqtLeeTJP6E
YG3vvMj+3VX75mYCJcd4NBtmRku0/4WFmSZNzs690xKrkVY9ohULfn9XDG7vlwXc
Szr2TmoVV2zQ5O7y4FN+Y7hZElVETAgGGQXSxJ0ZRfEPr3sHHHCCqZSLMVszF+Q1
w5q4V9XVoglFhJiVsOU76Tl1yrpq7ONCIzGaTuRRD1IzURZkYCU9R/IPknKWJsky
t3GZWrHjSCUVJofSRbLbY94ZoLT3dQ==
=f/yD
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42276@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42276
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help