[PATCH] gnu: zita-resampler: Update to 1.6.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Efraim Flashner
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal

Debbugs page

Alexandros Theodotou wrote 5 years ago
(name . Guix patches)(address . guix-patches@gnu.org)
efafd308ab274119a6304225b7c77b12b2a0a93a.camel@zrythm.org
Hi,

This patch updates zita-resampler. The structure of the source code
changed so it required a few tweaks.

Thanks,
Alex
From 53defb93bb80435e41b297b68cc1efd896060b8d Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 21:19:09 +0100
Subject: [PATCH] gnu: zita-resampler: Update to 1.6.2.

* gnu/packages/audio.scm (zita-resampler): Update to 1.6.2.
---
gnu/packages/audio.scm | 23 +++++++++++++----------
1 file changed, 13 insertions(+), 10 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index c96476857f..571624a622 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3203,7 +3203,7 @@ engine.")
(define-public zita-resampler
(package
(name "zita-resampler")
- (version "1.3.0")
+ (version "1.6.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3213,33 +3213,36 @@ engine.")
(snippet
;; Don't optimize for a specific processor architecture.
'(begin
- (substitute* '("apps/Makefile" "libs/Makefile")
+ (substitute* '("apps/Makefile" "source/Makefile")
(("^CXXFLAGS \\+= -march=native") ""))
#t))
(modules '((guix build utils)))
(sha256
(base32
- "0r9ary5sc3y8vba5pad581ha7mgsrlyai83w7w4x2fmhfy64q0wq"))))
+ "1my5k2dh2dkvjp6xjnf9qy6i7s28z13kw1n9pwa4a2cpwbzawfr3"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" target
- #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "SUFFIX="))
#:phases
(modify-phases %standard-phases
(add-after
'unpack 'patch-makefile-and-enter-directory
(lambda _
- (substitute* "libs/Makefile"
- (("ldconfig") "true")
- (("^LIBDIR =.*") "LIBDIR = lib\n"))
- (chdir "libs")
+ (substitute* "source/Makefile"
+ (("ldconfig") "true")
+ (("^LIBDIR =.*") "LIBDIR = lib\n"))
+ (chdir "source")
#t))
(add-after
'install 'install-symlink
(lambda _
(symlink "libzita-resampler.so"
- (string-append (assoc-ref %outputs "out")
- "/lib/libzita-resampler.so.1"))
+ (string-append
+ (assoc-ref %outputs "out")
+ "/lib/libzita-resampler.so.1"))
#t))
;; no configure script
(delete 'configure))))
--
2.27.0
Efraim Flashner wrote 5 years ago
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 42274-done@debbugs.gnu.org)
20200712183520.GB9396@E5400
I made some changes to the commit message and adjusted the indentation
slightly in the patch. Patch pushed!


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8LV+gACgkQQarn3Mo9
g1HUOg/+OESXY0YMv9Y5u+RG1vQaeDN9JGhf4sXXabtIxt1Dr6mMFs0PkP3Ij+Ud
8GqNpcunNACjefPDQFKF6ccF2Re4cIy2iCnlroSmfn6G3mXw69zcWEnhZDTdMvw8
BndRGThLm0jRguXU3m2AEuz5C9hP6y6l8DIMn6UPqanrisa5RLLGWog0KasHgkKU
KHA13Jm03IV9iIok/pClf+Qt4TLFVv5iCqN0RsVe7ILMoVb5+y0iOoAfF6Cd71wy
ccMG4Vr17UNfZhyFjDl94oc70MF9Esyln+Gw/11AgvUIOjCpuu0aIf28Vt5Suopd
//XWtMeQPIZBmVhl6sR4/VVWXe+owtj2tOt6k5sVK44mozeDpg7K2oAdttPuiyNI
sH0N1YpEt03t+Iiq6LujuHvJ2OmiYck04n1V33KBEggAFHaxXEeFBkHKStOM9h9n
n+FTmI9sl62YvLfNOFXqpFtsqTlZrvrkG65ENnxl08BHWrm64KjZAq7KoD+sUw5M
biYZWxQgqxD16kwNwIJPv+rH8Vya5KEG+aiDfstWg5+EGn0jQzsK+wrFhugrE/Cz
Y46poXD2xR8Nhxr5rfOdaX6Iiep7jccRAT117CdpFylpmWZtRT12PLey5GqX62Lu
SquxmSbxyahTAMAOhPY/qOqKtXXts6ZsSzuAxAenWTr+R42Ryes=
=2aPB
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42274@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42274
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help