[PATCH] gnu: Add emacs-chess.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)
87sge5t1pr.fsf@rohleder.de
From 4da0fa92cb532cf25a0a3fdf9d1369e61b1fa883 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Mon, 6 Jul 2020 11:43:34 +0200
Subject: [PATCH] gnu: Add emacs-chess.

* gnu/packages/emacs-xyz.scm (emacs-chess): New variable.
---
gnu/packages/emacs-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2fdda96b45..1c5ebb0740 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5905,6 +5905,39 @@ The goal of this game is to create a tile with value 2048. The size of the
board and goal value can be customized.")
(license license:gpl3+)))
+(define-public emacs-chess
+ (package
+ (name "emacs-chess")
+ (version "2.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/chess-"
+ version ".tar"))
+ (sha256
+ (base32
+ "1sq1bjmp513vldfh7hc2bbfc54665abqiz0kqgqq3gijckaxn5js"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-pieces
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (site-lisp
+ (string-append
+ out "/share/emacs/site-lisp/pieces")))
+ (mkdir-p site-lisp)
+ (copy-recursively "pieces" site-lisp)
+ #t))))))
+ (home-page "https://elpa.gnu.org/packages/chess.html")
+ (synopsis "Play chess in GNU Emacs")
+ (description "chess.el is an Emacs Lisp library and several
+clients on top of the underlying library functionality for performing
+various activities related to the game of chess.")
+ (license license:gpl3+)))
+
(define-public emacs-4clojure
;; There is no release. Base version is extracted from Version keyword in
;; the main file.
--
2.27.0
--
Programming without a hex editor is like watchmaking without a hammer.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl8C8xAACgkQfHr/vv7y
yyXg+Af/VXTA1ZoRXec8W+83wJp9JtygZK18x97tWp6kJrQ+eH6/mbFLyU0eJfZf
3moYPvGZW6KiMNO2SNi4M4bqOuz2UWGqG//CdC0KiugNB3XTbOq8kjFItu8sHaHD
L1ig9JRGSQdAM4gryMBTGBhz2iKobVzzk/ttZpLQl2g3adUuzd1RHVSh4XrNVFpz
ZoNe20vAcxM7+VpA7gBX1CY4Lo+vL8yDugDK4xJfQjoqlqvlZHa77FqoRvQBf2Cl
3CvoW6gkyHiYBt15ibgpYLybUbWVC/N9jPH1cjIyKaRv+aqlw7zK4l+jFfkXwoMr
ipUTwq0NFy+Q7X6BQkkqB6qfZM162w==
=fKHH
-----END PGP SIGNATURE-----

Nicolas Goaziou wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 42226-done@debbugs.gnu.org)
87tuyj7ci7.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-chess): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42226@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42226
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help